Loading ...
Sorry, an error occurred while loading the content.

Re: Two bugs in vim.vim syntax file

Expand Messages
  • Charles Campbell
    ... The problem is discriminating between marks and strings. My solution has been to reduce the number of items detected as marks and to favor strings.
    Message 1 of 4 , Aug 19, 2013
    • 0 Attachment
      Manuel Ortega wrote:
      > There are at least two bugs in vim syntax highlighting. It occurs
      > when one leaves out optional spaces in a List or Dictionary.
      >
      > For example:
      > let foo = ['one','two','three']
      > shows distractingly bizarre highlighting. The second and third
      > elements have only their first letter colored, and that color is
      > different from the color of the first element. No such problem exists
      > if there are spaces after *ALL* the commas. This problem is
      > relatively recent (like within the last few months sometime).
      >
      > A similar problem for Dictionaries exists. For instance:
      > let foo = {'one':'Washington', 'two':'Lincoln'}
      > Here, the values are uncolored even though the keys are colored.
      > Also, the lefthand single-quotes for the values are uncolored, but
      > their righthand single quotes are colored. Both the keys and the
      > values should be colored. No such problem exists if there are spaces
      > after the colons.
      >
      > The latter problem (or something VERY close to it) has been around for
      > a really long time.
      >
      The problem is discriminating between marks and strings. My "solution"
      has been to reduce the number of items detected as marks and to favor
      strings. Please try
      http://www.drchip.org/astronaut/vim/index.html#SYNTAX_VIM .

      Regards,
      C Campbell

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Manuel Ortega
      On Mon, Aug 19, 2013 at 9:21 AM, Charles Campbell wrote ... That worked! Thanks very much. -Manny -- -- You received this
      Message 2 of 4 , Aug 19, 2013
      • 0 Attachment
        On Mon, Aug 19, 2013 at 9:21 AM, Charles Campbell <Charles.E.Campbell@...> wrote
        The problem is discriminating between marks and strings.  My "solution" has been to reduce the number of items detected as marks and to favor strings.  Please try http://www.drchip.org/astronaut/vim/index.html#SYNTAX_VIM .

        That worked!  Thanks very much.

        -Manny 

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.