Loading ...
Sorry, an error occurred while loading the content.

Bug: file name completion with Chinese charactors doesn't work well on windows

Expand Messages
  • WU Yue
    Hi list, If I :set encoding=utf-8, then the file name completion with Chinese charactors doesn t work. I use utf-8 instead of the default encoding (cp936) on
    Message 1 of 3 , Aug 18 6:51 PM
    • 0 Attachment
      Hi list,

      If I :set encoding=utf-8, then the file name completion with Chinese
      charactors doesn't work.

      I use utf-8 instead of the default encoding (cp936) on windows, the
      reason is that, encoding utf-8 can distinguish Chinese punctuations in
      word motions.

      Platform: Windows XP.
      Affected version of vim: all versions

      How to produce:
      1. set encoding=utf-8 in vimrc, then restart vim.
      2. creat a new file with Chinese name:
      :call mkdir("c:/中文名/中文名2")
      2. At a vim buffer, insert text: c:/中, then try to complete it with
      <C-x><C-f>, completion will say: Pattern not found. However, c:/<C-x><C-f>
      work.

      --
      Regards,
      WU Yue

      State Key laboratory of Natural Products and Functions
      Key Laboratory of Modern Chinese Medicines
      Department of Traditional Chinese Medicine
      China Pharmaceutical University
      No.24, Tongjia Xiang Street, Nanjing 210009, China

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ken Takata
      Hi Yue, ... I think attached patch fixes this problem. Regards, Ken Takata -- -- You received this message from the vim_dev maillist. Do not top-post! Type
      Message 2 of 3 , Aug 19 5:38 AM
      • 0 Attachment
        Hi Yue,

        2013/08/19 Mon 10:51:08 UTC+9 WU Yue wrote:
        > Hi list,
        >
        > If I :set encoding=utf-8, then the file name completion with Chinese
        > charactors doesn't work.
        >
        > I use utf-8 instead of the default encoding (cp936) on windows, the
        > reason is that, encoding utf-8 can distinguish Chinese punctuations in
        > word motions.
        >
        > Platform: Windows XP.
        > Affected version of vim: all versions
        >
        > How to produce:
        > 1. set encoding=utf-8 in vimrc, then restart vim.
        > 2. creat a new file with Chinese name:
        > :call mkdir("c:/中文名/中文名2")
        > 2. At a vim buffer, insert text: c:/中, then try to complete it with
        > <C-x><C-f>, completion will say: Pattern not found. However, c:/<C-x><C-f>
        > work.

        I think attached patch fixes this problem.

        Regards,
        Ken Takata

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Bram Moolenaar
        ... Thanks, I ll add it in the todo list. -- I AM THANKFUL... ...for the piles of laundry and ironing because it means I have plenty of clothes to wear. ///
        Message 3 of 3 , Aug 19 2:08 PM
        • 0 Attachment
          Ken Takata wrote:

          > Hi Yue,
          >
          > 2013/08/19 Mon 10:51:08 UTC+9 WU Yue wrote:
          > > Hi list,
          > >
          > > If I :set encoding=utf-8, then the file name completion with Chinese
          > > charactors doesn't work.
          > >
          > > I use utf-8 instead of the default encoding (cp936) on windows, the
          > > reason is that, encoding utf-8 can distinguish Chinese punctuations in
          > > word motions.
          > >
          > > Platform: Windows XP.
          > > Affected version of vim: all versions
          > >
          > > How to produce:
          > > 1. set encoding=utf-8 in vimrc, then restart vim.
          > > 2. creat a new file with Chinese name:
          > > :call mkdir("c:/中文名/中文名2")
          > > 2. At a vim buffer, insert text: c:/中, then try to complete it with
          > > <C-x><C-f>, completion will say: Pattern not found. However, c:/<C-x><C-f>
          > > work.
          >
          > I think attached patch fixes this problem.

          Thanks, I'll add it in the todo list.


          --
          I AM THANKFUL...
          ...for the piles of laundry and ironing because it means I
          have plenty of clothes to wear.

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.