Loading ...
Sorry, an error occurred while loading the content.
 

system("tmux load-buffer -", buf) hangs

Expand Messages
  • Péter Kasza
    Dear vim_dev list! I ve been using the tslime plugin for some time now, but after an update it somehow doesn t seem to work anymore. The call to system( tmux
    Message 1 of 6 , Aug 14, 2013
      Dear vim_dev list!

      I've been using the tslime plugin for some time now, but after an update it somehow doesn't seem to work anymore. The call to system("tmux load-buffer -", buf) hangs forever. I can make it work by changing the line to system("cat | tmux load-buffer -",buf).

      This is happening on v7.4.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      Hi Péter! ... Can you verify, this happens when using vim -u NONE -U NONE -N (e.g. no custom .vimrc and no plugins loaded)? regards, Christian --
      Message 2 of 6 , Aug 14, 2013
        Hi Péter!

        On Mi, 14 Aug 2013, Péter Kasza wrote:

        > Dear vim_dev list!
        >
        > I've been using the tslime plugin for some time now, but after an update it somehow doesn't seem to work anymore. The call to system("tmux load-buffer -", buf) hangs forever. I can make it work by changing the line to system("cat | tmux load-buffer -",buf).
        >
        > This is happening on v7.4.

        Can you verify, this happens when using vim -u NONE -U NONE -N (e.g. no
        custom .vimrc and no plugins loaded)?

        regards,
        Christian
        --
        Abhängigkeit ist das Los der Frauen; Macht ist, wo die Bärte sind.
        -- Jean-Baptiste Molière (Die Schule der Frauen)

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Péter Kasza
        ... Yep, tried a simple echo system( tmux load-buffer - , asdf ) without vimrc/plugins and the same freeze happened. -- -- You received this message from the
        Message 3 of 6 , Aug 16, 2013
          > custom .vimrc and no plugins loaded)?
          Yep, tried a simple echo system("tmux load-buffer -", "asdf") without vimrc/plugins and the same freeze happened.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... I don t see this. regards, Christian -- Gott hat auch die Dummheit geschaffen, aber er hat sie gerecht verteilt. -- Konrad Adenauer -- -- You received this
          Message 4 of 6 , Aug 17, 2013
            On Fr, 16 Aug 2013, Péter Kasza wrote:

            > > custom .vimrc and no plugins loaded)?
            > Yep, tried a simple echo system("tmux load-buffer -", "asdf") without vimrc/plugins and the same freeze happened.

            I don't see this.

            regards,
            Christian
            --
            Gott hat auch die Dummheit geschaffen, aber er hat sie gerecht verteilt.
            -- Konrad Adenauer

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Péter Kasza
            ... Hmm. This seems to be an issue with zsh and or tmux. Executing the command which vim does also hangs. $ /bin/zsh -c (tmux load-buffer -)
            Message 5 of 6 , Aug 18, 2013
              > > Yep, tried a simple echo system("tmux load-buffer -", "asdf") without vimrc/plugins and the same freeze happened.

              > I don't see this.

              Hmm. This seems to be an issue with zsh and or tmux. Executing the command which vim does also hangs.

              $ /bin/zsh -c "(tmux load-buffer -) < /tmp/file"
              [warn] Epoll ADD(1) on fd 0 failed. Old events were 0; read change was 1 (add); write change was 0 (none): Operation not permitted
              ^C^C^C^C^Czsh: killed /bin/zsh -c "(tmux load-buffer -) < /tmp/file"

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Péter Kasza
              ... I ve figured out the problem. tmux tries to use the epoll method on fd 0, but epoll doesnt support regular files. -- -- You received this message from the
              Message 6 of 6 , Aug 18, 2013
                2013. augusztus 18., vasárnap 13:32:59 UTC+2 időpontban Péter Kasza a következőt írta:
                > > > Yep, tried a simple echo system("tmux load-buffer -", "asdf") without vimrc/plugins and the same freeze happened.
                >
                > > I don't see this.
                >
                > Hmm. This seems to be an issue with zsh and or tmux. Executing the command which vim does also hangs.
                >
                > $ /bin/zsh -c "(tmux load-buffer -) < /tmp/file"
                > [warn] Epoll ADD(1) on fd 0 failed. Old events were 0; read change was 1 (add); write change was 0 (none): Operation not permitted
                > ^C^C^C^C^Czsh: killed /bin/zsh -c "(tmux load-buffer -) < /tmp/file"

                I've figured out the problem. tmux tries to use the epoll method on fd 0, but epoll doesnt support regular files.

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.