Loading ...
Sorry, an error occurred while loading the content.

Segfault on 7.4 caused by syntax :on with Ruby file

Expand Messages
  • Christopher Chow
    When I start vim with vim -u NONE -N with the following code in a ruby file: class Billing::EstimatedImportStrategy
    Message 1 of 10 , Aug 12, 2013
    • 0 Attachment
      When I start vim with vim -u NONE -N with the following code in a ruby file:

      class Billing::EstimatedImportStrategy < Billing::GapImportStrategy
      def applicable?
      has_previous_and_next_data? && has_historic_amount_data?
      end

      def has_historic_amount_data?
      estimated_import.historic_previous_amount.present? &&
      estimated_import.historic_gap_period.any? &&
      estimated_import.historic_next_amount.present?
      end

      def has_previous_and_next_data?
      estimated_import.previous_amount.present? && estimated_import.next_amount.present?
      end

      def estimated_import
      @estimated_import ||=
      Billing::EstimatedImport.new(:started_on => gap.started_on, :ended_on => gap.ended_on, :asset_id => meter.asset.id,
      :resource_type_id => gap.resource_type.id, :division_id => meter.asset.division_id,
      :organisation_id => meter.asset.organisation_id, :processed => false, :amount => nil, :meter_id => meter.id)
      end

      def apply
      estimated_import.save!
      end
      end

      When I run :syntax on, I get a segfault in vim. Here's the output from bugreport.vim: https://gist.github.com/Soliah/6217770

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Dominique Pellé
      ... It did not crash for me on Linux, however, valgrind finds a bug with vim-7.4 (huge, Linux x86_64): $ valgrind --log-file=valgrind.log vim -u NONE -N -c
      Message 2 of 10 , Aug 12, 2013
      • 0 Attachment
        Christopher Chow wrote:

        > When I start vim with vim -u NONE -N with the following code in a ruby file:
        >
        > class Billing::EstimatedImportStrategy < Billing::GapImportStrategy
        > def applicable?
        > has_previous_and_next_data? && has_historic_amount_data?
        > end
        >
        > def has_historic_amount_data?
        > estimated_import.historic_previous_amount.present? &&
        > estimated_import.historic_gap_period.any? &&
        > estimated_import.historic_next_amount.present?
        > end
        >
        > def has_previous_and_next_data?
        > estimated_import.previous_amount.present? && estimated_import.next_amount.present?
        > end
        >
        > def estimated_import
        > @estimated_import ||=
        > Billing::EstimatedImport.new(:started_on => gap.started_on, :ended_on => gap.ended_on, :asset_id => meter.asset.id,
        > :resource_type_id => gap.resource_type.id, :division_id => meter.asset.division_id,
        > :organisation_id => meter.asset.organisation_id, :processed => false, :amount => nil, :meter_id => meter.id)
        > end
        >
        > def apply
        > estimated_import.save!
        > end
        > end
        >
        > When I run :syntax on, I get a segfault in vim. Here's the output from bugreport.vim: https://gist.github.com/Soliah/6217770


        It did not crash for me on Linux, however, valgrind finds a
        bug with vim-7.4 (huge, Linux x86_64):

        $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb

        ==5283== Invalid write of size 8
        ==5283== at 0x56062B: addstate (regexp_nfa.c:4172)
        ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
        ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
        ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
        ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
        ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
        ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
        ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
        ==5283== by 0x581A8E: win_line (screen.c:4274)
        ==5283== by 0x58858F: win_update (screen.c:2010)
        ==5283== by 0x58BE31: update_screen.part.21 (screen.c:681)
        ==5283== by 0x624A26: main_loop (main.c:1232)
        ==5283== Address 0xe383a88 is 87,752 bytes inside a block of size 99,280 free'd
        ==5283== at 0x4C2B4F0: realloc (in
        /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
        ==5283== by 0x5602D2: addstate (regexp_nfa.c:4022)
        ==5283== by 0x560196: addstate (regexp_nfa.c:4060)
        ==5283== by 0x560157: addstate (regexp_nfa.c:4167)
        ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
        ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
        ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
        ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
        ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
        ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
        ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
        ==5283== by 0x581A8E: win_line (screen.c:4274)
        ==5283==
        ==5283== Invalid write of size 4
        ==5283== at 0x56062F: addstate (regexp_nfa.c:4172)
        ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
        ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
        ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
        ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
        ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
        ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
        ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
        ==5283== by 0x581A8E: win_line (screen.c:4274)
        ==5283== by 0x58858F: win_update (screen.c:2010)
        ==5283== by 0x58BE31: update_screen.part.21 (screen.c:681)
        ==5283== by 0x624A26: main_loop (main.c:1232)
        ==5283== Address 0xe383a90 is 87,760 bytes inside a block of size 99,280 free'd
        ==5283== at 0x4C2B4F0: realloc (in
        /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
        ==5283== by 0x5602D2: addstate (regexp_nfa.c:4022)
        ==5283== by 0x560196: addstate (regexp_nfa.c:4060)
        ==5283== by 0x560157: addstate (regexp_nfa.c:4167)
        ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
        ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
        ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
        ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
        ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
        ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
        ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
        ==5283== by 0x581A8E: win_line (screen.c:4274)


        I can reproduce it with a much simpler input file
        containing just 6 spaces and a x:

        $ cat foo.rb
        x
        $ vim valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb

        Regards
        Dominique

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Bram Moolenaar
        ... Thanks for reporting the problem. Dominique had another example. Must be something special in the syntax file. -- ... /// Bram Moolenaar --
        Message 3 of 10 , Aug 12, 2013
        • 0 Attachment
          Christopher Chow wrote:

          > When I start vim with vim -u NONE -N with the following code in a ruby file:
          >
          > class Billing::EstimatedImportStrategy < Billing::GapImportStrategy
          > def applicable?
          > has_previous_and_next_data? && has_historic_amount_data?
          > end
          >
          > def has_historic_amount_data?
          > estimated_import.historic_previous_amount.present? &&
          > estimated_import.historic_gap_period.any? &&
          > estimated_import.historic_next_amount.present?
          > end
          >
          > def has_previous_and_next_data?
          > estimated_import.previous_amount.present? && estimated_import.next_amount.present?
          > end
          >
          > def estimated_import
          > @estimated_import ||=
          > Billing::EstimatedImport.new(:started_on => gap.started_on, :ended_on => gap.ended_on, :asset_id => meter.asset.id,
          > :resource_type_id => gap.resource_type.id, :division_id => meter.asset.division_id,
          > :organisation_id => meter.asset.organisation_id, :processed => false, :amount => nil, :meter_id => meter.id)
          > end
          >
          > def apply
          > estimated_import.save!
          > end
          > end
          >
          > When I run :syntax on, I get a segfault in vim. Here's the output from
          > bugreport.vim: https://gist.github.com/Soliah/6217770

          Thanks for reporting the problem. Dominique had another example. Must
          be something special in the syntax file.

          --
          From "know your smileys":
          :----} You lie like Pinocchio

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Dominique Pellé
          ... I could narrow it down further. I can reproduce it with: # Create a file (6 space and a x, bug does not happen with less than 6 spaces): $ echo x
          Message 4 of 10 , Aug 13, 2013
          • 0 Attachment
            Dominique Pellé wrote:

            > Christopher Chow wrote:
            >
            >> When I start vim with vim -u NONE -N with the following code in a ruby file:
            >>
            >> class Billing::EstimatedImportStrategy < Billing::GapImportStrategy
            >> def applicable?
            >> has_previous_and_next_data? && has_historic_amount_data?
            >> end
            >>
            >> def has_historic_amount_data?
            >> estimated_import.historic_previous_amount.present? &&
            >> estimated_import.historic_gap_period.any? &&
            >> estimated_import.historic_next_amount.present?
            >> end
            >>
            >> def has_previous_and_next_data?
            >> estimated_import.previous_amount.present? && estimated_import.next_amount.present?
            >> end
            >>
            >> def estimated_import
            >> @estimated_import ||=
            >> Billing::EstimatedImport.new(:started_on => gap.started_on, :ended_on => gap.ended_on, :asset_id => meter.asset.id,
            >> :resource_type_id => gap.resource_type.id, :division_id => meter.asset.division_id,
            >> :organisation_id => meter.asset.organisation_id, :processed => false, :amount => nil, :meter_id => meter.id)
            >> end
            >>
            >> def apply
            >> estimated_import.save!
            >> end
            >> end
            >>
            >> When I run :syntax on, I get a segfault in vim. Here's the output from bugreport.vim: https://gist.github.com/Soliah/6217770
            >
            >
            > It did not crash for me on Linux, however, valgrind finds a
            > bug with vim-7.4 (huge, Linux x86_64):
            >
            > $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb
            >
            > ==5283== Invalid write of size 8
            > ==5283== at 0x56062B: addstate (regexp_nfa.c:4172)
            > ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
            > ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
            > ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
            > ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
            > ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
            > ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
            > ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
            > ==5283== by 0x581A8E: win_line (screen.c:4274)
            > ==5283== by 0x58858F: win_update (screen.c:2010)
            > ==5283== by 0x58BE31: update_screen.part.21 (screen.c:681)
            > ==5283== by 0x624A26: main_loop (main.c:1232)
            > ==5283== Address 0xe383a88 is 87,752 bytes inside a block of size 99,280 free'd
            > ==5283== at 0x4C2B4F0: realloc (in
            > /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
            > ==5283== by 0x5602D2: addstate (regexp_nfa.c:4022)
            > ==5283== by 0x560196: addstate (regexp_nfa.c:4060)
            > ==5283== by 0x560157: addstate (regexp_nfa.c:4167)
            > ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
            > ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
            > ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
            > ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
            > ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
            > ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
            > ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
            > ==5283== by 0x581A8E: win_line (screen.c:4274)
            > ==5283==
            > ==5283== Invalid write of size 4
            > ==5283== at 0x56062F: addstate (regexp_nfa.c:4172)
            > ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
            > ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
            > ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
            > ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
            > ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
            > ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
            > ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
            > ==5283== by 0x581A8E: win_line (screen.c:4274)
            > ==5283== by 0x58858F: win_update (screen.c:2010)
            > ==5283== by 0x58BE31: update_screen.part.21 (screen.c:681)
            > ==5283== by 0x624A26: main_loop (main.c:1232)
            > ==5283== Address 0xe383a90 is 87,760 bytes inside a block of size 99,280 free'd
            > ==5283== at 0x4C2B4F0: realloc (in
            > /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
            > ==5283== by 0x5602D2: addstate (regexp_nfa.c:4022)
            > ==5283== by 0x560196: addstate (regexp_nfa.c:4060)
            > ==5283== by 0x560157: addstate (regexp_nfa.c:4167)
            > ==5283== by 0x560675: addstate_here (regexp_nfa.c:4290)
            > ==5283== by 0x56A81C: nfa_regmatch (regexp_nfa.c:5369)
            > ==5283== by 0x56C73B: nfa_regtry (regexp_nfa.c:6349)
            > ==5283== by 0x56CC07: nfa_regexec_both (regexp_nfa.c:6533)
            > ==5283== by 0x5C3E78: syn_regexec (syntax.c:3272)
            > ==5283== by 0x5CA6D6: syn_current_attr (syntax.c:2092)
            > ==5283== by 0x5CF1B7: get_syntax_attr (syntax.c:1851)
            > ==5283== by 0x581A8E: win_line (screen.c:4274)
            >
            >
            > I can reproduce it with a much simpler input file
            > containing just 6 spaces and a x:
            >
            > $ cat foo.rb
            > x
            > $ vim valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb
            >
            > Regards
            > Dominique


            I could narrow it down further. I can reproduce it with:

            # Create a file (6 space and a x, bug does not happen with less than 6 spaces):
            $ echo " x" > foo
            $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo

            Then in Vim-7.4 (huge, Linux x86_64) search for:
            /\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!

            and observe errors in valgrind.log.
            Above regexp is actually used in syntax/ruby.rb:

            syn match rubyPredefinedConstant
            "\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!"

            Regards
            Dominique

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Doug Kearns
            On 14 August 2013 05:03, Dominique Pellé wrote: ... Bug aside that pattern has been simplified recently so the OP may
            Message 5 of 10 , Aug 13, 2013
            • 0 Attachment
              On 14 August 2013 05:03, Dominique Pellé <dominique.pelle@...> wrote:
              <snip>

              > I could narrow it down further. I can reproduce it with:
              >
              > # Create a file (6 space and a x, bug does not happen with less than 6 spaces):
              > $ echo " x" > foo
              > $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo
              >
              > Then in Vim-7.4 (huge, Linux x86_64) search for:
              > /\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!
              >
              > and observe errors in valgrind.log.
              > Above regexp is actually used in syntax/ruby.rb:
              >
              > syn match rubyPredefinedConstant
              > "\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!"

              Bug aside that pattern has been 'simplified' recently so the OP may
              like to try out the latest ruby.vim syntax file (not included in 7.4).

              Regards,
              Doug

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • James McCoy
              ... The attached patch fixes this. Cheers, -- James GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy
              Message 6 of 10 , Aug 13, 2013
              • 0 Attachment
                On Tue, Aug 13, 2013 at 09:03:36PM +0200, Dominique Pellé wrote:
                > I could narrow it down further. I can reproduce it with:
                >
                > # Create a file (6 space and a x, bug does not happen with less than 6 spaces):
                > $ echo " x" > foo
                > $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb
                >
                > Then in Vim-7.4 (huge, Linux x86_64) search for:
                > /\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!
                >
                > and observe errors in valgrind.log.

                The attached patch fixes this.

                Cheers,
                --
                James
                GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy <jamessan@...>
              • Bram Moolenaar
                ... Thanks! -- ... /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net /// sponsor Vim, vote for features --
                Message 7 of 10 , Aug 14, 2013
                • 0 Attachment
                  James McCoy wrote:

                  > On Tue, Aug 13, 2013 at 09:03:36PM +0200, Dominique Pellé wrote:
                  > > I could narrow it down further. I can reproduce it with:
                  > >
                  > > # Create a file (6 space and a x, bug does not happen with less than 6 spaces):
                  > > $ echo " x" > foo
                  > > $ valgrind --log-file=valgrind.log vim -u NONE -N -c 'syn on' foo.rb
                  > >
                  > > Then in Vim-7.4 (huge, Linux x86_64) search for:
                  > > /\%(\%(\.\@<!\.\)\@<!\|::\)\_s*\zs\%(MatchingData\|ARGF\|ARGV\|ENV\)\>\%(\s*(\)\@!
                  > >
                  > > and observe errors in valgrind.log.
                  >
                  > The attached patch fixes this.

                  Thanks!


                  --
                  From "know your smileys":
                  |-P Reaction to unusually ugly C code

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Matt Yoder
                  FWIW I too have segfaults with ruby syntax on, 7.4, os x 10.6.8. Updating my vim syntax file resolved the problem. M -- -- You received this message from the
                  Message 8 of 10 , Aug 15, 2013
                  • 0 Attachment
                    FWIW I too have segfaults with ruby syntax on, 7.4, os x 10.6.8. Updating my vim syntax file resolved the problem.

                    M

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Christian Brabandt
                    ... Well, 7.4.003 should have fixed that. Can you confirm? regards, Christian -- Durch die Leidenschaften lebt der Mensch, durch die Vernunft existiert er
                    Message 9 of 10 , Aug 15, 2013
                    • 0 Attachment
                      On Do, 15 Aug 2013, Matt Yoder wrote:

                      > FWIW I too have segfaults with ruby syntax on, 7.4, os x 10.6.8.
                      > Updating my vim syntax file resolved the problem.

                      Well, 7.4.003 should have fixed that. Can you confirm?

                      regards,
                      Christian
                      --
                      Durch die Leidenschaften lebt der Mensch, durch die Vernunft existiert
                      er bloß.
                      -- Nicolas Sébastien de Chamfort

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Christopher Chow
                      I m running HEAD now and the original file I posted is working correctly. -- -- You received this message from the vim_dev maillist. Do not top-post! Type
                      Message 10 of 10 , Aug 17, 2013
                      • 0 Attachment
                        I'm running HEAD now and the original file I posted is working correctly.

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      Your message has been successfully submitted and would be delivered to recipients shortly.