Loading ...
Sorry, an error occurred while loading the content.

Re: The maximised vim window has white paddings to the screen edge under windows.

Expand Messages
  • Mike Williams
    ... AFAIK this is normal. The client area is always a whole number of lines and columns, and any remaining space horizontally and vertically is filled with
    Message 1 of 5 , Aug 5, 2013
    • 0 Attachment
      On 04/08/2013 03:52, Bohr Shaw wrote:
      > On Sunday, August 4, 2013 8:34:05 AM UTC+8, Andrei Olsen wrote:
      >> On Sunday, August 4, 2013 2:12:28 AM UTC+2, Bohr Shaw wrote:
      >>> This is a the left and bottom part of the whole screen picture.
      >>
      >> This is probably related to this discussion:
      >> https://groups.google.com/d/topic/vim_dev/ODi7rQPQdTw/discussion
      >
      > My problem exists only when the vim window maximizes. And I'm using the official build which may be not compiled with VS2012. I just have built vim with VS2012. And the issue discussed in the other post doesn't exist anymore.
      > So this is a new issue.

      AFAIK this is normal. The client area is always a whole number of lines
      and columns, and any remaining space horizontally and vertically is
      filled with the default system border color. The padding is more
      noticeable with a dark colorscheme.

      If you change the size of your font you should see the right and bottom
      padding area change in size depending on the fit. VIM has never filled
      the client area up to the client border with the current background.

      Now, whether VIM should display its content centred in the client area
      when maximised so the padding is symmetrical is another question ;-)

      Mike
      --
      It's a poodle... set it on delicate.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.