Loading ...
Sorry, an error occurred while loading the content.

[BUG] When trying to view help for /\%(\) E55 pops out

Expand Messages
  • ZyX
    Steps to reproduce: vim -u NONE -N -c :h / %( ) . This will produce two ôE55: Unmatched )ö messages and one ôE149: Sorry, no help for / %( )ö. Note that
    Message 1 of 2 , Aug 3, 2013
    • 0 Attachment
      Steps to reproduce:

      vim -u NONE -N -c ':h /\%(\)'

      . This will produce two “E55: Unmatched \)” messages and one “E149: Sorry, no help for /\%(\)”. Note that there is such tag. Trying to use “:h /\%(” works.

      According to “:h {subject}” ({subject} should be typed literally) (which points to the help of “:h {subject}”, {subject} is meant to be a placeholder) {subject} may contain “*”, “[]” and “?” that have special meaning, but not a single word about “\)” having special meaning as well. It is even explicitely suggested to use :tag in a help window to use regexes.

      Checked with vim-9999 (vim 7.4b, patches 1-10).

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... I ll fix it. -- The 50-50-90 rule: Anytime you have a 50-50 chance of getting something right, there s a 90% probability you ll get it wrong. /// Bram
      Message 2 of 2 , Aug 3, 2013
      • 0 Attachment
        ZyX wrote:

        > Steps to reproduce:
        >
        > vim -u NONE -N -c ':h /\%(\)'
        >
        > . This will produce two “E55: Unmatched \)” messages and one
        > “E149: Sorry, no help for /\%(\)”. Note that there is such tag.
        > Trying to use “:h /\%(” works.
        >
        > According to “:h {subject}” ({subject} should be typed
        > literally) (which points to the help of “:h {subject}”,
        > {subject} is meant to be a placeholder) {subject} may contain
        > “*”, “[]” and “?” that have special meaning, but not
        > a single word about “\)” having special meaning as well. It is
        > even explicitely suggested to use :tag in a help window to use
        > regexes.
        >
        > Checked with vim-9999 (vim 7.4b, patches 1-10).

        I'll fix it.

        --
        The 50-50-90 rule: Anytime you have a 50-50 chance of getting
        something right, there's a 90% probability you'll get it wrong.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.