Loading ...
Sorry, an error occurred while loading the content.

Re: [Patch] Escape file names when reading files in Zip container

Expand Messages
  • Charles Campbell
    ... I believe that this issue has been addressed previously. You can get the latest zip plugin from my website:
    Message 1 of 4 , Aug 1, 2013
    View Source
    • 0 Attachment
      Cedric Bosdonnat wrote:
      > Hello,
      >
      > I'm editing OOXML files pretty often with vim and the zip plugin.
      > However those have a [Content_Types.xml] file inside the zip that can't
      > be opened.
      >
      > You'll find attached a simple patch against trunk to fix that problem by
      > just escaping the name of the file to open in the unzip command.
      >
      I believe that this issue has been addressed previously. You can get
      the latest zip plugin from my website:

      http://www.drchip.org/astronaut/vim/index.html#ZIP

      Regards,
      Chip Campbell

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Cedric Bosdonnat
      Hello Charles, ... Indeed, that is fixed in your latest source. Do you know what is the process to get that in the official vim sources to have it picked by
      Message 2 of 4 , Aug 2, 2013
      View Source
      • 0 Attachment
        Hello Charles,

        On Thu, 2013-08-01 at 14:56 -0400, Charles Campbell wrote:
        > I believe that this issue has been addressed previously. You can get
        > the latest zip plugin from my website:
        >
        > http://www.drchip.org/astronaut/vim/index.html#ZIP

        Indeed, that is fixed in your latest source. Do you know what is the
        process to get that in the official vim sources to have it picked by the
        linux distros?

        --
        Cedric

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... Yes. I update the scripts I maintain and post them on my website. Occasionally, after they ve been there for awhile without complaints, I send them
        Message 3 of 4 , Aug 8, 2013
        View Source
        • 0 Attachment
          Cedric Bosdonnat wrote:
          > Hello Charles,
          >
          > On Thu, 2013-08-01 at 14:56 -0400, Charles Campbell wrote:
          >> I believe that this issue has been addressed previously. You can get
          >> the latest zip plugin from my website:
          >>
          >> http://www.drchip.org/astronaut/vim/index.html#ZIP
          > Indeed, that is fixed in your latest source. Do you know what is the
          > process to get that in the official vim sources to have it picked by the
          > linux distros?
          >
          >
          Yes.

          I update the scripts I maintain and post them on my website.
          Occasionally, after they've been there for awhile without complaints, I
          send them upstream.

          Regards,
          Chip Campbell

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.