Loading ...
Sorry, an error occurred while loading the content.

Re: 7.4a - Confirm dialog box larger than screen size

Expand Messages
  • Bram Moolenaar
    ... Thanks. Obviously one should not use a dialog with so much text, but not being able to click cancel is a problem. -- hundred-and-one symptoms of being
    Message 1 of 11 , Aug 1, 2013
    • 0 Attachment
      Andrei Olsen wrote:

      > On Tuesday, July 9, 2013 3:50:20 PM UTC+2, David Fishburn wrote:
      > > I believe I saw this fixed earlier, or something related.
      > >
      > >
      > > I have tested this with:
      > >
      > > :ver
      > > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
      > >
      > > MS-Windows 32-bit GUI version with OLE support
      > > Included patches: 1-6
      > > Compiled by me
      > > Big version with GUI.  Features included (+) or not (-):
      > >
      > >
      > > Run on Windows 7 x64.
      > >
      > >
      > >
      > > gvim.exe -u NONE -U NONE
      > >
      > >
      > > Open Vim.
      > > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
      > > Or
      > >
      > > Simply maximize Vim by double clicking on the title bar.
      > >
      > >
      > > Run the following:
      > >
      > > :echo confirm('Test'.repeat("\nNext line", 80))
      > >
      > >
      > >
      > > This will produce a dialog box with a scrollbar within it.
      > > The scrolling of the items is correct.
      > >
      > >
      > > But, there are 2 issues.
      > >
      > >
      > >
      > > 1.  Assuming your taskbar is at the default windows position (bottom
      > > of screen) then window is much longer than than the window size.
      > >  Many of the "Next lines" are off the screen and the OK button is no
      > > where to be seen.
      > >
      > >
      > >
      > > 2.  If you taskbar is at the top of the screen (as mine always is)
      > > then the problem may stem from the same issue of being too large,
      > > but there is an additional problem.  The top of the window is
      > > underneath the taskbar, so you cannot click on it to move it.  Many
      > > of the "Next lines" are off the screen and the OK button is no where
      > > to be seen.
      > >
      > >
      > >
      > > Please make sure Vim has either been maximized or nearly the length
      > > of the screen first.  If you do not, you will not see the same
      > > behaviour.  The confirm modal window is larger than Vim, but it will
      > > not exceed screen size if Vim isn't using most of screen
      > > real-estate.
      > >
      > >
      > >
      > > David
      >
      > The attached patch should fix it. The dialog is border size smaller
      > than the window so it would fit when the window is maximized.
      >
      > Also made the dialog a bit smaller when we don't have a window, e.g.
      > gvim -h. It didn't fit completely on my PC, part of the dialog was
      > behind the taskbar.

      Thanks. Obviously one should not use a dialog with so much text, but
      not being able to click "cancel" is a problem.

      --
      hundred-and-one symptoms of being an internet addict:
      29. Your phone bill comes to your doorstep in a box.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • David Fishburn
      ... Before the fix there are 2 problems that I see. 1. The Ok Cancel buttons are off the screen at the bottom. 2. If your task bar is at the top of your
      Message 2 of 11 , Aug 1, 2013
      • 0 Attachment

        On Thu, Aug 1, 2013 at 7:23 AM, Bram Moolenaar <Bram@...> wrote:

        Andrei Olsen wrote:

        > On Tuesday, July 9, 2013 3:50:20 PM UTC+2, David Fishburn wrote:
        > > I believe I saw this fixed earlier, or something related.
        > >
        > >
        > > I have tested this with:
        > >
        > > :ver
        > > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
        > >
        > > MS-Windows 32-bit GUI version with OLE support
        > > Included patches: 1-6
        > > Compiled by me
        > > Big version with GUI.  Features included (+) or not (-):
        > >
        > >
        > > Run on Windows 7 x64.
        > >
        > >
        > >
        > > gvim.exe -u NONE -U NONE
        > >
        > >
        > > Open Vim.
        > > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
        > > Or
        > >
        > > Simply maximize Vim by double clicking on the title bar.
        > >
        > >
        > > Run the following:
        > >
        > > :echo confirm('Test'.repeat("\nNext line", 80))
        > >
        > >
        > >
        > > This will produce a dialog box with a scrollbar within it.
        > > The scrolling of the items is correct.
        > >
        > >
        > > But, there are 2 issues.
        > >
        > >
        > >
        > > 1.  Assuming your taskbar is at the default windows position (bottom
        > > of screen) then window is much longer than than the window size.
        > >  Many of the "Next lines" are off the screen and the OK button is no
        > > where to be seen.
        > >
        > >
        > >
        > > 2.  If you taskbar is at the top of the screen (as mine always is)
        > > then the problem may stem from the same issue of being too large,
        > > but there is an additional problem.  The top of the window is
        > > underneath the taskbar, so you cannot click on it to move it.  Many
        > > of the "Next lines" are off the screen and the OK button is no where
        > > to be seen.
        > >
        > >
        > >
        > > Please make sure Vim has either been maximized or nearly the length
        > > of the screen first.  If you do not, you will not see the same
        > > behaviour.  The confirm modal window is larger than Vim, but it will
        > > not exceed screen size if Vim isn't using most of screen
        > > real-estate.
        > >
        > >
        > >
        > > David
        >
        > The attached patch should fix it. The dialog is border size smaller
        > than the window so it would fit when the window is maximized.
        >
        > Also made the dialog a bit smaller when we don't have a window, e.g.
        > gvim -h. It didn't fit completely on my PC, part of the dialog was
        > behind the taskbar.

        Thanks.  Obviously one should not use a dialog with so much text, but
        not being able to click "cancel" is a problem.


        Agreed.

        Before the fix there are 2 problems that I see.

        1.  The Ok Cancel buttons are off the screen at the bottom.

        2.  If your task bar is at the top of your screen (instead of the default bottom) the "X" to close the window is also not visible.  Because it is not visible, you cannot "move" the window to get access to it.  ALT-Space-M(ove) does not work since we are in an single line edit box waiting for user input.  To the ALT-Space-M goes into the user input.  The Escape button (on Windows) closes the dialog.

        The dialog box does have a scroll bar, so the N entries in the window will scroll so they can still see and read what is within the dialog.

        David


        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Ben Fritz
        ... Obviously this should be fixed, but this way of moving dialogs and windows should probably work in the meantime: 1. On Windows XP (and Vista?) right-click
        Message 3 of 11 , Aug 1, 2013
        • 0 Attachment
          On Thursday, August 1, 2013 11:28:45 AM UTC-5, David Fishburn wrote:
          > > 2. If your task bar is at the top of your screen (instead of the default bottom) the "X" to close the window is also not visible. Because it is not visible, you cannot "move" the window to get access to it. ALT-Space-M(ove) does not work since we are in an single line edit box waiting for user input. To the ALT-Space-M goes into the user input. The Escape button (on Windows) closes the dialog.
          >

          Obviously this should be fixed, but this way of moving dialogs and windows should probably work in the meantime:

          1. On Windows XP (and Vista?) right-click on the task bar entry for the dialog/window you want to move. On Windows 7, shift + right-click.
          2. Choose "move"
          3. Hit any arrow key on your keyboard
          4. Move the mouse and the window will move with it

          I found this to be useful when doing a remote login to my work PC...and I needed to see something on the 2nd monitor. I think it should work in this case also.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • David Fishburn
          Turns out this problem also affects Linux (gnome in this case). Here is a picture plus the version information in the background. Thanks, David -- -- You
          Message 4 of 11 , Sep 2, 2013
          • 0 Attachment
             
            Turns out this problem also affects Linux (gnome in this case).

            Here is a picture plus the version information in the background.

            Thanks,
            David

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • David Fishburn
            ... Can anyone confirm the same (incorrect) behaviour on non-Windows platforms? Thanks, David -- -- You received this message from the vim_dev maillist. Do
            Message 5 of 11 , Oct 2, 2013
            • 0 Attachment

              On Mon, Sep 2, 2013 at 9:15 PM, David Fishburn <dfishburn.vim@...> wrote:
               
              Turns out this problem also affects Linux (gnome in this case).

              ...

              Can anyone confirm the same (incorrect) behaviour on non-Windows platforms?

              Thanks,
              David

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.