Loading ...
Sorry, an error occurred while loading the content.

Re: 'autochdir' causes setbufvar() to change directory

Expand Messages
  • Bram Moolenaar
    ... Thanks! -- Time is an illusion. Lunchtime doubly so. -- Ford Prefect, in Douglas Adams The Hitchhiker s Guide to the Galaxy /// Bram Moolenaar --
    Message 1 of 7 , Jul 31, 2013
    • 0 Attachment
      Christian Brabandt wrote:

      > On Tue, July 16, 2013 16:57, Benjamin Fritz wrote:
      > > Eric Van Dewoestine found this while investigating an eclim issue I was having.
      > > When 'autochdir' is set, calling setbufvar() changes Vim's current
      > > directory to that of the buffer having its variable set. I think this
      > > should not happen.
      > > Reproduced using the following on Solaris with Vim 7.4a.6, and also on
      > > Windows (slightly modified) with Vim 7.3.822.
      > > mkdir test1
      > > mkdir test2
      > > touch test1/test1.txt
      > > touch test2/test2.txt
      > > gvim -N -u NONE -i NONE test1/test1.txt test2/test2.txt
      > > :set autochdir
      > > :pwd
      > > /accts/btfritz/temp/test1
      > > :call setbufvar('test2', 'myvar', "foobar")
      > > :pwd
      > > /accts/btfritz/temp/test2
      >
      > Here is a patch.

      Thanks!

      --
      Time is an illusion. Lunchtime doubly so.
      -- Ford Prefect, in Douglas Adams'
      "The Hitchhiker's Guide to the Galaxy"

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.