Loading ...
Sorry, an error occurred while loading the content.

Re: 7.4a - Confirm dialog box larger than screen size

Expand Messages
  • David Fishburn
    Can anyone else reproduce this? Any GUI experts out there? Thanks, David ... -- -- You received this message from the vim_dev maillist. Do not top-post! Type
    Message 1 of 11 , Jul 31, 2013
    • 0 Attachment
      Can anyone else reproduce this?

      Any GUI experts out there?

      Thanks,
      David


      On Tue, Jul 9, 2013 at 11:13 AM, Bram Moolenaar <Bram@...> wrote:

      David Fishburn wrote:

      > I believe I saw this fixed earlier, or something related.
      >
      > I have tested this with:
      > :ver
      > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
      > MS-Windows 32-bit GUI version with OLE support
      > Included patches: 1-6
      > Compiled by me
      > Big version with GUI.  Features included (+) or not (-):
      >
      > Run on Windows 7 x64.
      >
      > gvim.exe -u NONE -U NONE
      >
      > Open Vim.
      > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
      > Or
      > Simply maximize Vim by double clicking on the title bar.
      >
      > Run the following:
      > :echo confirm('Test'.repeat("\nNext line", 80))
      >
      > This will produce a dialog box with a scrollbar within it.
      > The scrolling of the items is correct.
      >
      > But, there are 2 issues.
      >
      > 1.  Assuming your taskbar is at the default windows position (bottom of
      > screen) then window is much longer than than the window size.  Many of the
      > "Next lines" are off the screen and the OK button is no where to be seen.
      >
      > 2.  If you taskbar is at the top of the screen (as mine always is) then the
      > problem may stem from the same issue of being too large, but there is an
      > additional problem.  The top of the window is underneath the taskbar, so
      > you cannot click on it to move it.  Many of the "Next lines" are off the
      > screen and the OK button is no where to be seen.
      >
      > Please make sure Vim has either been maximized or nearly the length of the
      > screen first.  If you do not, you will not see the same behaviour.  The
      > confirm modal window is larger than Vim, but it will not exceed screen size
      > if Vim isn't using most of screen real-estate.

      Perhaps the height computatins do not add the height of the buttons?

      --
         [The rest of the ARMY stand around looking at a loss.]
      INSPECTOR END OF FILM: (picks up megaphone) All right!  Clear off!  Go on!
                       "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

       /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net   \\\
      ///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\  an exciting new programming language -- http://www.Zimbu.org        ///
       \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Mike Williams
      ... Yep, reproduced. Even happens with gui VIM on linux builds and without increasing the window height from the default 25 lines. No idea for other
      Message 2 of 11 , Jul 31, 2013
      • 0 Attachment
        On 31/07/2013 14:06, David Fishburn wrote:
        > Can anyone else reproduce this?

        Yep, reproduced. Even happens with gui VIM on linux builds and without
        increasing the window height from the default 25 lines. No idea for
        other platforms.

        > Any GUI experts out there?

        A quick look at the Windows code for the dialog shows it limits the
        message content of the dialog to the height of the Window used by VIM,
        but takes no account of the title bar or any buttons and title bar
        extending beyond top and bottom of the window/screen.

        I haven't looked at the GTK code but it would seem it has no checks at
        all on the dialog height relative to the window or screen dimensions.
        Other platforms may vary again.

        While not nice, what is the usage scenario where such a tall dialog is
        useful?

        > Thanks,
        > David
        >
        >
        > On Tue, Jul 9, 2013 at 11:13 AM, Bram Moolenaar <Bram@...> wrote:
        >
        >>
        >> David Fishburn wrote:
        >>
        >>> I believe I saw this fixed earlier, or something related.
        >>>
        >>> I have tested this with:
        >>> :ver
        >>> VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul 9 2013 09:34:36)
        >>> MS-Windows 32-bit GUI version with OLE support
        >>> Included patches: 1-6
        >>> Compiled by me
        >>> Big version with GUI. Features included (+) or not (-):
        >>>
        >>> Run on Windows 7 x64.
        >>>
        >>> gvim.exe -u NONE -U NONE
        >>>
        >>> Open Vim.
        >>> Resize Vim so that the top and bottom of the Vim window is nearly
        >> maximized.
        >>> Or
        >>> Simply maximize Vim by double clicking on the title bar.
        >>>
        >>> Run the following:
        >>> :echo confirm('Test'.repeat("\nNext line", 80))
        >>>
        >>> This will produce a dialog box with a scrollbar within it.
        >>> The scrolling of the items is correct.
        >>>
        >>> But, there are 2 issues.
        >>>
        >>> 1. Assuming your taskbar is at the default windows position (bottom of
        >>> screen) then window is much longer than than the window size. Many of
        >> the
        >>> "Next lines" are off the screen and the OK button is no where to be seen.
        >>>
        >>> 2. If you taskbar is at the top of the screen (as mine always is) then
        >> the
        >>> problem may stem from the same issue of being too large, but there is an
        >>> additional problem. The top of the window is underneath the taskbar, so
        >>> you cannot click on it to move it. Many of the "Next lines" are off the
        >>> screen and the OK button is no where to be seen.
        >>>
        >>> Please make sure Vim has either been maximized or nearly the length of
        >> the
        >>> screen first. If you do not, you will not see the same behaviour. The
        >>> confirm modal window is larger than Vim, but it will not exceed screen
        >> size
        >>> if Vim isn't using most of screen real-estate.
        >>
        >> Perhaps the height computatins do not add the height of the buttons?
        >>
        >> --
        >> [The rest of the ARMY stand around looking at a loss.]
        >> INSPECTOR END OF FILM: (picks up megaphone) All right! Clear off! Go on!
        >> "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES
        >> LTD
        >>
        >> /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net
        >> \\\
        >> /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/\\\
        >> \\\ an exciting new programming language -- http://www.Zimbu.org
        >> ///
        >> \\\ help me help AIDS victims -- http://ICCF-Holland.org
        >> ///
        >>
        >


        Mike
        --
        The day Microsoft builds something that doesn't suck is the day they
        build a vacuum cleaner.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • David Fishburn
        On Wed, Jul 31, 2013 at 11:24 AM, Mike Williams
        Message 3 of 11 , Jul 31, 2013
        • 0 Attachment
          On Wed, Jul 31, 2013 at 11:24 AM, Mike Williams <mike.williams@...> wrote:
          On 31/07/2013 14:06, David Fishburn wrote:
          Can anyone else reproduce this?

          Yep, reproduced.  Even happens with gui VIM on linux builds and without increasing the window height from the default 25 lines.  No idea for other platforms.


          Any GUI experts out there?

          A quick look at the Windows code for the dialog shows it limits the message content of the dialog to the height of the Window used by VIM, but takes no account of the title bar or any buttons and title bar extending beyond top and bottom of the window/screen.

          I haven't looked at the GTK code but it would seem it has no checks at all on the dialog height relative to the window or screen dimensions. Other platforms may vary again.

          While not nice, what is the usage scenario where such a tall dialog is useful?


          When using the confirm() function, you can ask the user for input.
          In my particular case (dbext.vim plugin) you can create "named connection profiles".
          When you first use the plugin it will prompt you (by #) which profile you would like to use.

          This is simply generated by entries you have put in your .vimrc.

          So in the end you are prompted like this:

          Enter profile #:
          1.  Oracle - DB_x
          2.  MySQL - MythTV
          3.  Sybase 

          Ok       Cancel

          In my case, I have over 75 profiles.  The 75 lines easily create a box that is larger than the window, so I expect it to scroll within the window.

          confirm() is a nice generic way to get input, the text added can easily be large.

          Thanks for testing and confirming.
          David






          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Andrei Olsen
          ... The attached patch should fix it. The dialog is border size smaller than the window so it would fit when the window is maximized. Also made the dialog a
          Message 4 of 11 , Jul 31, 2013
          • 0 Attachment
            On Tuesday, July 9, 2013 3:50:20 PM UTC+2, David Fishburn wrote:
            > I believe I saw this fixed earlier, or something related.
            >
            >
            > I have tested this with:
            >
            > :ver
            > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
            >
            > MS-Windows 32-bit GUI version with OLE support
            > Included patches: 1-6
            > Compiled by me
            > Big version with GUI.  Features included (+) or not (-):
            >
            >
            > Run on Windows 7 x64.
            >
            >
            >
            > gvim.exe -u NONE -U NONE
            >
            >
            > Open Vim.
            > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
            > Or
            >
            > Simply maximize Vim by double clicking on the title bar.
            >
            >
            > Run the following:
            >
            > :echo confirm('Test'.repeat("\nNext line", 80))
            >
            >
            >
            > This will produce a dialog box with a scrollbar within it.
            > The scrolling of the items is correct.
            >
            >
            > But, there are 2 issues.
            >
            >
            >
            > 1.  Assuming your taskbar is at the default windows position (bottom of screen) then window is much longer than than the window size.  Many of the "Next lines" are off the screen and the OK button is no where to be seen.
            >
            >
            >
            > 2.  If you taskbar is at the top of the screen (as mine always is) then the problem may stem from the same issue of being too large, but there is an additional problem.  The top of the window is underneath the taskbar, so you cannot click on it to move it.  Many of the "Next lines" are off the screen and the OK button is no where to be seen.
            >
            >
            >
            > Please make sure Vim has either been maximized or nearly the length of the screen first.  If you do not, you will not see the same behaviour.  The confirm modal window is larger than Vim, but it will not exceed screen size if Vim isn't using most of screen real-estate.
            >
            >
            >
            > David

            The attached patch should fix it. The dialog is border size smaller than the window so it would fit when the window is maximized.

            Also made the dialog a bit smaller when we don't have a window, e.g. gvim -h. It didn't fit completely on my PC, part of the dialog was behind the taskbar.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Bram Moolenaar
            ... Thanks. Obviously one should not use a dialog with so much text, but not being able to click cancel is a problem. -- hundred-and-one symptoms of being
            Message 5 of 11 , Aug 1, 2013
            • 0 Attachment
              Andrei Olsen wrote:

              > On Tuesday, July 9, 2013 3:50:20 PM UTC+2, David Fishburn wrote:
              > > I believe I saw this fixed earlier, or something related.
              > >
              > >
              > > I have tested this with:
              > >
              > > :ver
              > > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
              > >
              > > MS-Windows 32-bit GUI version with OLE support
              > > Included patches: 1-6
              > > Compiled by me
              > > Big version with GUI.  Features included (+) or not (-):
              > >
              > >
              > > Run on Windows 7 x64.
              > >
              > >
              > >
              > > gvim.exe -u NONE -U NONE
              > >
              > >
              > > Open Vim.
              > > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
              > > Or
              > >
              > > Simply maximize Vim by double clicking on the title bar.
              > >
              > >
              > > Run the following:
              > >
              > > :echo confirm('Test'.repeat("\nNext line", 80))
              > >
              > >
              > >
              > > This will produce a dialog box with a scrollbar within it.
              > > The scrolling of the items is correct.
              > >
              > >
              > > But, there are 2 issues.
              > >
              > >
              > >
              > > 1.  Assuming your taskbar is at the default windows position (bottom
              > > of screen) then window is much longer than than the window size.
              > >  Many of the "Next lines" are off the screen and the OK button is no
              > > where to be seen.
              > >
              > >
              > >
              > > 2.  If you taskbar is at the top of the screen (as mine always is)
              > > then the problem may stem from the same issue of being too large,
              > > but there is an additional problem.  The top of the window is
              > > underneath the taskbar, so you cannot click on it to move it.  Many
              > > of the "Next lines" are off the screen and the OK button is no where
              > > to be seen.
              > >
              > >
              > >
              > > Please make sure Vim has either been maximized or nearly the length
              > > of the screen first.  If you do not, you will not see the same
              > > behaviour.  The confirm modal window is larger than Vim, but it will
              > > not exceed screen size if Vim isn't using most of screen
              > > real-estate.
              > >
              > >
              > >
              > > David
              >
              > The attached patch should fix it. The dialog is border size smaller
              > than the window so it would fit when the window is maximized.
              >
              > Also made the dialog a bit smaller when we don't have a window, e.g.
              > gvim -h. It didn't fit completely on my PC, part of the dialog was
              > behind the taskbar.

              Thanks. Obviously one should not use a dialog with so much text, but
              not being able to click "cancel" is a problem.

              --
              hundred-and-one symptoms of being an internet addict:
              29. Your phone bill comes to your doorstep in a box.

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ an exciting new programming language -- http://www.Zimbu.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • David Fishburn
              ... Before the fix there are 2 problems that I see. 1. The Ok Cancel buttons are off the screen at the bottom. 2. If your task bar is at the top of your
              Message 6 of 11 , Aug 1, 2013
              • 0 Attachment

                On Thu, Aug 1, 2013 at 7:23 AM, Bram Moolenaar <Bram@...> wrote:

                Andrei Olsen wrote:

                > On Tuesday, July 9, 2013 3:50:20 PM UTC+2, David Fishburn wrote:
                > > I believe I saw this fixed earlier, or something related.
                > >
                > >
                > > I have tested this with:
                > >
                > > :ver
                > > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  9 2013 09:34:36)
                > >
                > > MS-Windows 32-bit GUI version with OLE support
                > > Included patches: 1-6
                > > Compiled by me
                > > Big version with GUI.  Features included (+) or not (-):
                > >
                > >
                > > Run on Windows 7 x64.
                > >
                > >
                > >
                > > gvim.exe -u NONE -U NONE
                > >
                > >
                > > Open Vim.
                > > Resize Vim so that the top and bottom of the Vim window is nearly maximized.
                > > Or
                > >
                > > Simply maximize Vim by double clicking on the title bar.
                > >
                > >
                > > Run the following:
                > >
                > > :echo confirm('Test'.repeat("\nNext line", 80))
                > >
                > >
                > >
                > > This will produce a dialog box with a scrollbar within it.
                > > The scrolling of the items is correct.
                > >
                > >
                > > But, there are 2 issues.
                > >
                > >
                > >
                > > 1.  Assuming your taskbar is at the default windows position (bottom
                > > of screen) then window is much longer than than the window size.
                > >  Many of the "Next lines" are off the screen and the OK button is no
                > > where to be seen.
                > >
                > >
                > >
                > > 2.  If you taskbar is at the top of the screen (as mine always is)
                > > then the problem may stem from the same issue of being too large,
                > > but there is an additional problem.  The top of the window is
                > > underneath the taskbar, so you cannot click on it to move it.  Many
                > > of the "Next lines" are off the screen and the OK button is no where
                > > to be seen.
                > >
                > >
                > >
                > > Please make sure Vim has either been maximized or nearly the length
                > > of the screen first.  If you do not, you will not see the same
                > > behaviour.  The confirm modal window is larger than Vim, but it will
                > > not exceed screen size if Vim isn't using most of screen
                > > real-estate.
                > >
                > >
                > >
                > > David
                >
                > The attached patch should fix it. The dialog is border size smaller
                > than the window so it would fit when the window is maximized.
                >
                > Also made the dialog a bit smaller when we don't have a window, e.g.
                > gvim -h. It didn't fit completely on my PC, part of the dialog was
                > behind the taskbar.

                Thanks.  Obviously one should not use a dialog with so much text, but
                not being able to click "cancel" is a problem.


                Agreed.

                Before the fix there are 2 problems that I see.

                1.  The Ok Cancel buttons are off the screen at the bottom.

                2.  If your task bar is at the top of your screen (instead of the default bottom) the "X" to close the window is also not visible.  Because it is not visible, you cannot "move" the window to get access to it.  ALT-Space-M(ove) does not work since we are in an single line edit box waiting for user input.  To the ALT-Space-M goes into the user input.  The Escape button (on Windows) closes the dialog.

                The dialog box does have a scroll bar, so the N entries in the window will scroll so they can still see and read what is within the dialog.

                David


                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
                 
                 
              • Ben Fritz
                ... Obviously this should be fixed, but this way of moving dialogs and windows should probably work in the meantime: 1. On Windows XP (and Vista?) right-click
                Message 7 of 11 , Aug 1, 2013
                • 0 Attachment
                  On Thursday, August 1, 2013 11:28:45 AM UTC-5, David Fishburn wrote:
                  > > 2. If your task bar is at the top of your screen (instead of the default bottom) the "X" to close the window is also not visible. Because it is not visible, you cannot "move" the window to get access to it. ALT-Space-M(ove) does not work since we are in an single line edit box waiting for user input. To the ALT-Space-M goes into the user input. The Escape button (on Windows) closes the dialog.
                  >

                  Obviously this should be fixed, but this way of moving dialogs and windows should probably work in the meantime:

                  1. On Windows XP (and Vista?) right-click on the task bar entry for the dialog/window you want to move. On Windows 7, shift + right-click.
                  2. Choose "move"
                  3. Hit any arrow key on your keyboard
                  4. Move the mouse and the window will move with it

                  I found this to be useful when doing a remote login to my work PC...and I needed to see something on the 2nd monitor. I think it should work in this case also.

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • David Fishburn
                  Turns out this problem also affects Linux (gnome in this case). Here is a picture plus the version information in the background. Thanks, David -- -- You
                  Message 8 of 11 , Sep 2, 2013
                  • 0 Attachment
                     
                    Turns out this problem also affects Linux (gnome in this case).

                    Here is a picture plus the version information in the background.

                    Thanks,
                    David

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                     
                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • David Fishburn
                    ... Can anyone confirm the same (incorrect) behaviour on non-Windows platforms? Thanks, David -- -- You received this message from the vim_dev maillist. Do
                    Message 9 of 11 , Oct 2, 2013
                    • 0 Attachment

                      On Mon, Sep 2, 2013 at 9:15 PM, David Fishburn <dfishburn.vim@...> wrote:
                       
                      Turns out this problem also affects Linux (gnome in this case).

                      ...

                      Can anyone confirm the same (incorrect) behaviour on non-Windows platforms?

                      Thanks,
                      David

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    Your message has been successfully submitted and would be delivered to recipients shortly.