Loading ...
Sorry, an error occurred while loading the content.

Vim 7.4b not getting any syntax or other default files

Expand Messages
  • Sazid Al Rashid
    Recently, I compiled Vim 7.4b with Python, Ruby, Lua, Perl and huge feature list. But, in Ubuntu 13.04, when I open Vim 7.4b, it complains that the syntax.vim
    Message 1 of 3 , Jul 31, 2013
    • 0 Attachment
      Recently, I compiled Vim 7.4b with Python, Ruby, Lua, Perl and huge feature list. But, in Ubuntu 13.04, when I open Vim 7.4b, it complains that the syntax.vim file could not be loaded. Moreover, it did not load the other things, like-colorschemes and default plugins. Then, I copied the whole /usr/share/vim74b/ directory to /usr/share/vim74 and it worked! I don't know, if its a bug or because of the version number(vim74b)!

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Elimar Riesebieter
      ... AFAIK /usr/share/vim/vim74b should be correct for the Debian packaging as there is a link made to /usr/share/vim/vimcurrent. $ echo $VIMRUNTIME
      Message 2 of 3 , Jul 31, 2013
      • 0 Attachment
        * Sazid Al Rashid <sazidozon@...> [2013-07-31 01:25 -0700]:

        > Recently, I compiled Vim 7.4b with Python, Ruby, Lua, Perl and
        > huge feature list. But, in Ubuntu 13.04, when I open Vim 7.4b, it
        > complains that the syntax.vim file could not be loaded. Moreover,
        > it did not load the other things, like-colorschemes and default
        > plugins. Then, I copied the whole /usr/share/vim74b/ directory to
        > /usr/share/vim74 and it worked! I don't know, if its a bug or
        > because of the version number(vim74b)!
        >

        AFAIK /usr/share/vim/vim74b should be correct for the Debian
        packaging as there is a link made to /usr/share/vim/vimcurrent.


        $ echo $VIMRUNTIME
        /usr/share/vim/vimcurrent

        Elimar
        --
        Numeric stability is probably not all that
        important when you're guessing;-)

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... Did you perhaps sometime in the misty past set up a VIMRUNTIME environment variable? Regards, Chip Campbell -- -- You received this message from the
        Message 3 of 3 , Aug 6, 2013
        • 0 Attachment
          Sazid Al Rashid wrote:
          > Recently, I compiled Vim 7.4b with Python, Ruby, Lua, Perl and huge feature list. But, in Ubuntu 13.04, when I open Vim 7.4b, it complains that the syntax.vim file could not be loaded. Moreover, it did not load the other things, like-colorschemes and default plugins. Then, I copied the whole /usr/share/vim74b/ directory to /usr/share/vim74 and it worked! I don't know, if its a bug or because of the version number(vim74b)!
          >
          Did you perhaps sometime in the misty past set up a "VIMRUNTIME"
          environment variable?

          Regards,
          Chip Campbell

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.