Loading ...
Sorry, an error occurred while loading the content.

insert map doesn't work with remapped keys (keyboard=...)

Expand Messages
  • Ron Aaron
    I have a mapping: inoremap :call SmartQuote(1) a which does the right thing when a single-quote is inserted. That is, it either creates
    Message 1 of 1 , Jul 29, 2013
    • 0 Attachment
      I have a mapping:

      inoremap <buffer> ' '<Esc>:call SmartQuote(1)<CR>a

      which "does the right thing" when a single-quote is inserted. That is, it either creates a set of matching typographically correct single-quotes, or it inserts an apostrophe. It works fine in English.

      When I switch the keyboard to Hebrew (set rl keymap=hebrew) this mapping no longer works. It looks like the reason is that the "single quote" is remapped to "comma" (which is correct). But pressing the correct remapped single-quote key (w) does not fire the mapping.

      It seems to me this is incorrect behavior; but in the meantime can anyone suggest a reasonable workaround?


      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.