Loading ...
Sorry, an error occurred while loading the content.
 

Re: With vim 7.4a and 7.4b I get default compatible mode even with a vimrc file

Expand Messages
  • Lech Lorens
    ... Note that if you place the file under $HOME/vimfiles, it should be called vimrc, not _vimrc, nor .vimrc. Cheers, Lech -- -- You received this message from
    Message 1 of 7 , Jul 29, 2013
      On 29-Jul-2013 Stephen Lee <stephenletterbox@...> wrote:
      > On Tuesday, July 30, 2013 1:07:20 AM UTC+8, Ben Fritz wrote:
      > >
      > > Also note, the recommended place for your _vimrc file is in $HOME (or $HOME/vimfiles with the latest 7.4 beta builds).
      >
      > Thankyou for your help. It looks like it is just a usage problem.
      >
      > I try to put _vimrc file under the same directory with vim73 because I need to mantain several computers and laptops at different places. It makes it more portable by putting everything together.

      Note that if you place the file under $HOME/vimfiles, it should be
      called vimrc, not _vimrc, nor .vimrc.

      Cheers,
      Lech

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • anst
      ... As I stated in my first post the vimrc file is read so it is not a problem with paths. I have a copy of the _vimrc in ... vim and one called vimrc in
      Message 2 of 7 , Jul 30, 2013
        On Monday, 29 July 2013 11:16:49 UTC+2, anst wrote:
        > On windows 7 64-bit I get this behaviour both in gvim and vim.
        > The options I have in the vimrc file are read, so this seems like a bug.
        >
        > Regards
        > Andreas Stabel

        As I stated in my first post the vimrc file is read so it is not a problem with paths. I have a copy of the _vimrc in ...\vim and one called vimrc in ...\vim\vim32
        Stephen Lee suggested I remove the copy in ...\vim, but this didn't change anything.

        The funny thing is that if I put nocp in the vimrc file I get nocompatible !
        This solves my problem, so if it is not considered serious this need not be treated as a bug.

        Thanks for all suggestions
        Andreas

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.