Loading ...
Sorry, an error occurred while loading the content.

[patch] Japanese man pages are not shown properly

Expand Messages
  • Ken Takata
    Hi, We vim-jp.org members found that the Japanese man pages are not shown properly on Linux. (Word spacing is not correct.) The Japanese man pages are
    Message 1 of 2 , Jul 29, 2013
    • 0 Attachment
      Hi,

      We vim-jp.org members found that the Japanese man pages are not shown
      properly on Linux. (Word spacing is not correct.) The Japanese man pages
      are currently placed in the ja.UTF-8/ directory, but it should be ja/.
      groff should load /usr/share/groff/1.21/tmac/ja.tmac to process Japanese
      text, but the ja.tmac isn't loaded if the man pages are placed in
      ja.UTF-8/.
      The following patch fixes this:

      --- a/src/Makefile
      +++ b/src/Makefile
      @@ -1402,7 +1402,7 @@
      DEST_MAN_IT = $(DEST_MAN_TOP)/it$(MAN1DIR)
      DEST_MAN_IT_I = $(DEST_MAN_TOP)/it.ISO8859-1$(MAN1DIR)
      DEST_MAN_IT_U = $(DEST_MAN_TOP)/it.UTF-8$(MAN1DIR)
      -DEST_MAN_JA_U = $(DEST_MAN_TOP)/ja.UTF-8$(MAN1DIR)
      +DEST_MAN_JA_U = $(DEST_MAN_TOP)/ja$(MAN1DIR)
      DEST_MAN_PL = $(DEST_MAN_TOP)/pl$(MAN1DIR)
      DEST_MAN_PL_I = $(DEST_MAN_TOP)/pl.ISO8859-2$(MAN1DIR)
      DEST_MAN_PL_U = $(DEST_MAN_TOP)/pl.UTF-8$(MAN1DIR)

      BTW, I'm not sure about FreeBSD or other systems.

      Regards,
      Ken Takata

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Thanks. ... Me neither, I haven t used it for a long time now. -- I am also told that there is a logical proof out there somewhere that demonstrates that
      Message 2 of 2 , Jul 29, 2013
      • 0 Attachment
        Ken Takata wrote:

        > We vim-jp.org members found that the Japanese man pages are not shown
        > properly on Linux. (Word spacing is not correct.) The Japanese man pages
        > are currently placed in the ja.UTF-8/ directory, but it should be ja/.
        > groff should load /usr/share/groff/1.21/tmac/ja.tmac to process Japanese
        > text, but the ja.tmac isn't loaded if the man pages are placed in
        > ja.UTF-8/.
        > The following patch fixes this:
        >
        > --- a/src/Makefile
        > +++ b/src/Makefile
        > @@ -1402,7 +1402,7 @@
        > DEST_MAN_IT = $(DEST_MAN_TOP)/it$(MAN1DIR)
        > DEST_MAN_IT_I = $(DEST_MAN_TOP)/it.ISO8859-1$(MAN1DIR)
        > DEST_MAN_IT_U = $(DEST_MAN_TOP)/it.UTF-8$(MAN1DIR)
        > -DEST_MAN_JA_U = $(DEST_MAN_TOP)/ja.UTF-8$(MAN1DIR)
        > +DEST_MAN_JA_U = $(DEST_MAN_TOP)/ja$(MAN1DIR)
        > DEST_MAN_PL = $(DEST_MAN_TOP)/pl$(MAN1DIR)
        > DEST_MAN_PL_I = $(DEST_MAN_TOP)/pl.ISO8859-2$(MAN1DIR)
        > DEST_MAN_PL_U = $(DEST_MAN_TOP)/pl.UTF-8$(MAN1DIR)

        Thanks.

        > BTW, I'm not sure about FreeBSD or other systems.

        Me neither, I haven't used it for a long time now.

        --
        I am also told that there is a logical proof out there somewhere
        that demonstrates that there is no task which duct tape cannot handle.
        -- Paul Brannan

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.