Loading ...
Sorry, an error occurred while loading the content.

gvim handling Ctrl+NonLatinKeys

Expand Messages
  • Сергей Миронов
    Hi group. I m running vim/gvim on Linux with ru_RU.UTF-8 locale and have a problem for which I can t find an answer. Basically, gvim doesn t handle Ctrl-key if
    Message 1 of 1 , Jul 22, 2013
    • 0 Attachment
      Hi group. I'm running vim/gvim on Linux with ru_RU.UTF-8 locale and have a problem for which I can't find an answer. Basically, gvim doesn't handle Ctrl-key if key is a cyrillic key.

      For example, I have W and Ц sharing same key on my keyboard. In Insert mode, C-W deletes a word as usual, but C-Ц just displays Ц as if no Ctrl was pressed.

      I've checked X event with xev. It detects W as W, Ц as Ц, C-W as С-W and С-Ц as C-W as it should. Xterm (and console vim under xterm) works correctly too.

      Please help!
      Sergey

      Also, looks like StackOverflow question describes similar situation for Esperanto: http://stackoverflow.com/questions/16013290/shortcut-with-ctrl-doest-work-in-gvim

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.