Loading ...
Sorry, an error occurred while loading the content.

Re: diff syntax update (translations to many languages need to be checked)

Expand Messages
  • Antonio Giovanni Colombo
    Hi everybody, Italian is practically OK, but I have the following remarks: syn match diffOnly ^Only in .* The format of the above [English] line is different
    Message 1 of 9 , Jul 21, 2013
    • 0 Attachment
      Hi everybody,

      Italian is practically OK, but I have the following remarks:

      syn match diffOnly "^Only in .*"
      The format of the above [English] line is different (missing ": .*$")

      syn match diffDiffer "^I file .* e .* sono diversi$"
      should be:
      syn match diffBDiffer "^I file binari .* e .* sono diversi$"

      - "file binari", i.e. non-TEXT files

      syn match diffIsA "^File .* è un .* mentre file .* è un .*$"
      should be:
      syn match diffIsA "^File .* è un/o/a .* mentre file .* è un/o/a .*$"

      - reason is that "directory" in Italian needs "una" instead of "un".
      - We could live also WITHOUT the "o/a" for the sake of simplicity.

      All the best, Antonio


      On Sun, Jul 21, 2013 at 3:42 PM, Jakson Alves de Aquino <jalvesaq@...> wrote:
      Hi,

      I updated the translations of diff messages in syntax/diff.vim to
      (...)


      --
             /||\    | Antonio Colombo
        / || \   |  azc100@...  
       /  ()  \  |  antonio@...  
      (___||___) |   azc10@...

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Yukihiro Nakadaira
      On Mon, Jul 22, 2013 at 12:39 AM, Jakson Alves de Aquino
      Message 2 of 9 , Jul 21, 2013
      • 0 Attachment
        On Mon, Jul 22, 2013 at 12:39 AM, Jakson Alves de Aquino <jalvesaq@...> wrote:
        On Sun, Jul 21, 2013 at 11:47 AM, Yukihiro Nakadaira
        <yukihiro.nakadaira@...> wrote:
        > On Sun, Jul 21, 2013 at 10:42 PM, Jakson Alves de Aquino
        > <jalvesaq@...> wrote:
        >>
        >> Hi,
        >>
        >> I updated the translations of diff messages in syntax/diff.vim to
        >> version 3.3 of diffutils. Some messages are translated twice to
        >> match both diffutils 3.3 and older versions. The messages are in
        >> many languages and they were collected from the po files by a
        >> script. It would be good if speakers of the many languages could
        >> check if the diff.vim syntax script works for them. The languages
        >> are:
        >>
        >>     Catalan, Chinese, Croatian, Czech, Danish, Dutch,
        >>     Esperanto, Finnish, French, Galician, German,
        >>     Greek, Hebrew, Hungarian, Indonesian, Irish,
        >>     Italian, Japanese, Latvian, Malay, Polish,
        >>     Portuguese, Romanian, Russian, Serbian, Spanish,
        >>     Swedish, Turkish, Uzbek and Vietnamese.
        >
        >
        > Japanese messages looks good to me.
        >
        > Perhaps diffNoEOL should have backslash?
        > - syn match diffNoEOL    "^No newline at end of file .*"
        > - syn match diffNoEOL    "^\\ No newline at end of file .*"

        Yes, you are right. The backslash doesn't appear in the po files,
        but it's added by src/diff3.c just before the message to be
        translated. The backslash should be added to all diffNoEOL
        strings. The attached file fix this

        It works.  Thank you.

        --
        Yukihiro Nakadaira - yukihiro.nakadaira@...

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Jakson Alves de Aquino
        On Sun, Jul 21, 2013 at 12:39 PM, Antonio Giovanni Colombo ... OK. I added the : .* By the way, I think I could remove the $ from all strings ending as .*$
        Message 3 of 9 , Jul 21, 2013
        • 0 Attachment
          On Sun, Jul 21, 2013 at 12:39 PM, Antonio Giovanni Colombo
          <azc100@...> wrote:
          > Italian is practically OK, but I have the following remarks:
          >
          > syn match diffOnly "^Only in .*"
          > The format of the above [English] line is different (missing ": .*$")

          OK. I added the : .*

          By the way, I think I could remove the "$" from all strings ending
          as ".*$"

          > syn match diffDiffer "^I file .* e .* sono diversi$"
          > should be:
          > syn match diffBDiffer "^I file binari .* e .* sono diversi$"

          OK.

          > syn match diffIsA "^File .* è un .* mentre file .* è un .*$"
          > should be:
          > syn match diffIsA "^File .* è un/o/a .* mentre file .* è un/o/a .*$"

          The diffutils-3.3/po/it.po file has only one translation for this
          message:

          "File %s è un %s mentre file %s è un %s\n"

          --
          Jakson Alves de Aquino
          Federal University of Ceará
          Social Sciences Department
          www.lepem.ufc.br/aquino.php

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Antonio Giovanni Colombo
          ...fine for me (Italian) All the best, Antonio -- /|| | Antonio Colombo / || | azc100@gmail.com / () | antonio@geekcorp.com (___||___) |
          Message 4 of 9 , Jul 21, 2013
          • 0 Attachment
            ...fine for me (Italian)
            All the best, Antonio
            --
                   /||\    | Antonio Colombo
              / || \   |  azc100@...  
             /  ()  \  |  antonio@...  
            (___||___) |   azc10@...

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.