Loading ...
Sorry, an error occurred while loading the content.

:global wrong delimiters

Expand Messages
  • Dimitar DIMITROV
    Hi list, From :h:g (line 57) I get it :g9pattern9ACTION shouldn t work, but it does. ... Regards   Dimitar ... GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar
    Message 1 of 3 , Jul 19, 2013
    • 0 Attachment
      Hi list,

      From :h:g (line 57) I get it :g9pattern9ACTION shouldn't work, but it does.
      These work as well:

      :g"pattern"ACTION
      :g|pattern|ACTION

      Regards
       
      Dimitar

      ---
      GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Marcin Szamotulski
      ... This is a feature not a bug :). Check out :help E146 (this is about :s command but it also applies to the :g command). This is often used in vimgolf.
      Message 2 of 3 , Jul 19, 2013
      • 0 Attachment
        On 17:26 Fri 19 Jul , Dimitar DIMITROV wrote:
        > Hi list,
        >
        > >From :h:g (line 57) I get it :g9pattern9ACTION shouldn't work, but it does.
        > These work as well:
        >
        > :g"pattern"ACTION
        > :g|pattern|ACTION
        >
        > Regards
        >
        >  
        > Dimitar
        >
        >
        > ---
        > GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

        This is a feature not a bug :). Check out :help E146 (this is about :s
        command but it also applies to the :g command). This is often used in
        vimgolf.

        Best regards,
        Marcin

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Dimitar DIMITROV
        ... Well I know this and I have read the help but have you? :) The help implies that 9 (alphanumeric character), , or | can t be used as delimiters.
        Message 3 of 3 , Jul 19, 2013
        • 0 Attachment
          > > Hi list,
          > >
          > > >From :h:g (line 57) I get it :g9pattern9ACTION shouldn't work, but it does.
          > > These work as well:
          > >
          > > :g"pattern"ACTION
          > > :g|pattern|ACTION
          > >
          > > Regards
          > >
          > >
          > > Dimitar
          > >
          > >
          > > ---
          > > GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>
          >
          > This is a feature not a bug :).  Check out :help E146 (this is about :s
          > command but it also applies to the :g command).  This is often used in
          > vimgolf.

          Well I know this and I have read the help but have you? :)
          The help implies that 9 (alphanumeric character), '\', '"' or '|' can't be used as delimiters.
          So :g::, :g@@, :g%% are all ok but not the ones I mentioned.
          Not sure this is actually a problem... although I tried the following :g|^|p|echo 'ok' and I would expect one 'ok' only
          to be displayed instead of one per line and this might be because | has a special meaning for :g same as ::, @@ and %% above.

          > Best regards,
          > Marcin
           
          Dimitar

          ---
          GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.