Loading ...
Sorry, an error occurred while loading the content.

:set show values when it shouldn't

Expand Messages
  • Dimitar DIMITROV
    Hi all, According to :h:se, :se isn t supposed to output anything at all when in default mode but it does when started like this: command vim -nNX -u NONE  
    Message 1 of 4 , Jul 17 2:03 PM
    • 0 Attachment
      Hi all,

      According to :h:se, :se isn't supposed to output anything at all when in default mode but it does when started like this:
      command vim -nNX -u NONE
       
      Dimitar

      ---
      GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Gary Johnson
      ... Actually, :help :set doesn t say that--it says it shows all options that differ from their default value. Vim usually considers options that it sets
      Message 2 of 4 , Jul 17 2:28 PM
      • 0 Attachment
        On 2013-07-17, Dimitar DIMITROV wrote:
        > Hi all,
        >
        > According to :h:se, :se isn't supposed to output anything at all when in
        > default mode but it does when started like this:
        > command vim -nNX -u NONE

        Actually, ":help :set" doesn't say that--it says it shows "all
        options that differ from their default value." Vim usually
        considers options that it sets itself as a result of external
        factors to be different from their default values.

        What options are you seeing?

        I would expect you to be seeing at least "noloadplugins" because you
        used "-n" and "updatecount=0" because you used "-u NONE".

        Regards,
        Gary

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Gary Johnson
        ... Oops. I meant: I would expect you to be seeing at least updatecount=0 because you used -n and noloadplugins because you used -u NONE . Regards,
        Message 3 of 4 , Jul 17 2:33 PM
        • 0 Attachment
          On 2013-07-17, Gary Johnson wrote:
          > On 2013-07-17, Dimitar DIMITROV wrote:
          > > Hi all,
          > >
          > > According to :h:se, :se isn't supposed to output anything at all when in
          > > default mode but it does when started like this:
          > > command vim -nNX -u NONE
          >
          > Actually, ":help :set" doesn't say that--it says it shows "all
          > options that differ from their default value." Vim usually
          > considers options that it sets itself as a result of external
          > factors to be different from their default values.
          >
          > What options are you seeing?
          >
          > I would expect you to be seeing at least "noloadplugins" because you
          > used "-n" and "updatecount=0" because you used "-u NONE".

          Oops. I meant:

          I would expect you to be seeing at least "updatecount=0" because you
          used "-n" and "noloadplugins" because you used "-u NONE".

          Regards,
          Gary

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Dimitar DIMITROV
          ... Thanks Gary, I get it. This is what :se shows for me: helplang=en       noloadplugins         scroll=25          
          Message 4 of 4 , Jul 17 2:55 PM
          • 0 Attachment
            > On 2013-07-17, Gary Johnson wrote:
            > > On 2013-07-17, Dimitar DIMITROV wrote:
            > > > Hi all,
            > > >
            > > > According to :h:se, :se isn't supposed to output anything at all when in
            > > > default mode but it does when started like this:
            > > > command vim -nNX -u NONE
            > >
            > > Actually, ":help :set" doesn't say that--it says it shows "all
            > > options that differ from their default value."  Vim usually
            > > considers options that it sets itself as a result of external
            > > factors to be different from their default values.
            > >
            > > What options are you seeing?
            > >
            > > I would expect you to be seeing at least "noloadplugins" because you
            > > used "-n" and "updatecount=0"
            because you used "-u NONE".
            >
            > Oops.  I meant:
            >
            > I would expect you to be seeing at least "updatecount=0" because you
            > used "-n" and "noloadplugins" because you used "-u NONE".
            >
            > Regards,
            > Gary

            Thanks Gary, I get it.

            This is what :se shows for me:

            helplang=en       noloadplugins         scroll=25           ttyfast             ttymouse=sgr        updatecount=0
            fileencodings=ucs-bom,utf-8,default,latin1

            After reading more carefully I see that the above are not default values and why
            they are set, except for 'helplang maybe for which the help is not very clear
            about the default value.
             
            Dimitar

            ---
            GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.