Loading ...
Sorry, an error occurred while loading the content.

Problems with "make autoconf"

Expand Messages
  • björn
    Hi, Whenever I type make autoconf (on Mac OS X 10.6, GNU Make 3.81), the auto/configure script is run instead of begin generated by autoconf . The problem
    Message 1 of 3 , Jul 17, 2013
    • 0 Attachment
      Hi,

      Whenever I type "make autoconf" (on Mac OS X 10.6, GNU Make 3.81), the 'auto/configure' script is run instead of begin generated by "autoconf".  The problem seems to be the src/Makefile target:

      config auto/config.mk: auto/configure config.mk.in config.h.in

      This target gets run instead of the "autoconf" target when I type "make autoconf".  If I change the above target to

      config: auto/configure config.mk.in config.h.in

      then everything works fine.

      First of all I do not understand why this target is called when I specify another one - am I missing something?

      Is the problem localized to Mac OS X or is anybody else experiencing the same problem?

      Björn

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • James McCoy
      ... auto/configure script is run instead of begin generated by autoconf . ... autoconf . If I change the above target to ... another one - am I missing
      Message 2 of 3 , Jul 17, 2013
      • 0 Attachment


        On Jul 17, 2013 11:04 AM, "björn" <bjorn.winckler@...> wrote:
        >
        > Hi,
        >
        > Whenever I type "make autoconf" (on Mac OS X 10.6, GNU Make 3.81), the 'auto/configure' script is run instead of begin generated by "autoconf".  The problem seems to be the src/Makefile target:
        >
        > config auto/config.mk: auto/configure config.mk.in config.h.in
        >
        > This target gets run instead of the "autoconf" target when I type "make autoconf".  If I change the above target to
        >
        > config: auto/configure config.mk.in config.h.in
        >
        > then everything works fine.
        >
        > First of all I do not understand why this target is called when I specify another one - am I missing something?

        There is an "include auto/config.mk" statement in the makefile. This causes make to check whether the auto/config.mk is out of date.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • bjorn.winckler
        ... OK, that makes sense I suppose. This causes the problem that it is impossible to generate auto/configure from scratch (i.e. without a valid
        Message 3 of 3 , Jul 18, 2013
        • 0 Attachment
          On Wednesday, July 17, 2013 7:18:33 PM UTC+2, James McCoy wrote:
          > On Jul 17, 2013 11:04 AM, "björn" <bjorn.w...@...> wrote:
          >
          > > First of all I do not understand why this target is called when I specify another one - am I missing something?
          >
          > There is an "include auto/config.mk" statement in the makefile. This causes make to check whether the auto/config.mk is out of date.

          OK, that makes sense I suppose. This causes the problem that it is impossible to generate "auto/configure" from scratch (i.e. without a valid auto/configure script already being available). It is also bizarre that upon calling "make autoconf" the first thing that happens is that "auto/configure" runs, only to then be replaced when autoconf subsequently is called.

          My particular scenario is that when I pull from mainline Vim into the MacVim repo there are often conflicts in "auto/configure" -- if I then try "make autoconf" to generate a new "auto/configure" it fails because "auto/configure" contains conflict markers (which git adds to show where the conflicts are).

          It would be nice to be able to be able to run autoconf without already having to have the file that is supposed to be generated in place. Is there a way that this can be supported? (I can definitely work around this, but the whole process just seems a bit counterintuitive and likely to keep tripping people up.)

          Björn

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.