Loading ...
Sorry, an error occurred while loading the content.

Issue 152 in vim: 7.4a.24 BETA can't remove lines

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines
    Message 1 of 9 , Jul 16 4:51 PM
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove lines
      http://code.google.com/p/vim/issues/detail?id=152

      Latest vim from mercurial repository can't remove lines.
      Steps to reproduce: launch vim, press "i" to go to insert mode, then press
      a few times "enter" to make new lines. Now those lines neither "backspace"
      nor "delete" can't remove.

      Version:7.4a.24 BETA
      Configure: ./configure --enable-rubyinterp --enable-pythoninterp
      --enable-perlinterp --enable-gui=gtk2 --enable-cscope --prefix=/usr
      --with-python-config-dir=/usr/lib/python2.7/config-x86_64-linux-gnu/


      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 I just noticed one thing:
      Message 2 of 9 , Jul 16 5:09 PM
      • 0 Attachment
        Comment #1 on issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove
        lines
        http://code.google.com/p/vim/issues/detail?id=152

        I just noticed one thing: original(precompiled from repository) ViM shows
        below label "--insert--" when in insert mode. But the mercurial one lefts
        this field empty.

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        Comment #2 on issue 152 by vega.james@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 The behavior you re
        Message 3 of 9 , Jul 16 6:04 PM
        • 0 Attachment
          Comment #2 on issue 152 by vega.james@...: 7.4a.24 BETA can't remove
          lines
          http://code.google.com/p/vim/issues/detail?id=152

          The behavior you're expecting is not default behavior in Vim. Both of
          those require settings to be changed.

          For the first, you likely had "set backspace=2" in the config you were
          previously using. For the latter, that only happens when you have "set
          showmode" configured.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • vim@...
          Comment #3 on issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 I asked vim for those
          Message 4 of 9 , Jul 16 6:35 PM
          • 0 Attachment
            Comment #3 on issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove
            lines
            http://code.google.com/p/vim/issues/detail?id=152

            I asked vim for those values:
            "set backspace?" backspace=
            "set showmode?" noshowmode
            By the way, now I've compiled ViM left in the sources and default one
            installed in system. Default works as I expected.

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Comment #4 on issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 I asked vim for those
            Message 5 of 9 , Jul 16 6:40 PM
            • 0 Attachment
              Comment #4 on issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove
              lines
              http://code.google.com/p/vim/issues/detail?id=152

              I asked vim for those values:
              "set backspace?" backspace=
              "set showmode?" noshowmode
              If I set showmode, behaviour remains as was.
              By the way, now I've compiled ViM left in the sources and default one
              installed in system. Default works as I expected.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • vim@...
              Comment #5 on issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 I asked vim for those
              Message 6 of 9 , Jul 16 6:43 PM
              • 0 Attachment
                Comment #5 on issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove
                lines
                http://code.google.com/p/vim/issues/detail?id=152

                I asked vim for those values:
                "set backspace?" backspace=
                "set showmode?" noshowmode
                If I set showmode, behaviour remains as was.
                By the way, now I've compiled ViM left in the sources and default one
                installed in system. Default works as I expected.
                UPD: If I set showmode, "--insert--" label appears. But lines deletion do
                not works anyway.

                --
                You received this message because this project is configured to send all
                issue notifications to this address.
                You may adjust your notification preferences at:
                https://code.google.com/hosting/settings

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • vim@...
                Comment #6 on issue 152 by antoine....@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 It seems that you run in
                Message 7 of 9 , Jul 16 7:10 PM
                • 0 Attachment
                  Comment #6 on issue 152 by antoine....@...: 7.4a.24 BETA can't remove
                  lines
                  http://code.google.com/p/vim/issues/detail?id=152

                  It seems that you run in 'compatible' mode.This could be due to the lack of
                  a vimrc.

                  I suggest the following:
                  1. Start Vim.
                  2. In Normal mode, type
                  :e ~/.vimrc
                  followed by Enter.While you're typing that, it should appear at the very
                  bottom of the Vim screen.
                  3. In that new file, enter the following lines (in Insert mode):

                  " Vim configuration file
                  runtime vimrc_example.vim
                  " user customizations come here
                  set showmode

                  4. Go back to Normal mode, then exit with saving:

                  :x

                  That's all.The vimrc_example.vim includes
                  set backspace=indent,eol,start
                  so you don't need to repeat that one. The next time you start Vim, it
                  should let you backspace over a linebreak while in Insert mode, and
                  --INSERT-- --REPLACE-- --VISUAL-- etc.should appear at the bottom when you
                  aren't in Normal mode.

                  Best regards,
                  Tony.
                  --
                  "I would rather see a saloon on every corner than a Catholic in
                  the White House. I would rather see a nigger as president."
                  [Bob Jones, Sr., founder of Bob Jones University]


                  See
                  :help 'backspace'
                  :help 'showmode'


                  --
                  You received this message because this project is configured to send all
                  issue notifications to this address.
                  You may adjust your notification preferences at:
                  https://code.google.com/hosting/settings

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • vim@...
                  Comment #7 on issue 152 by HiAngel...@gmail.com: 7.4a.24 BETA can t remove lines http://code.google.com/p/vim/issues/detail?id=152 It works, thanks you very
                  Message 8 of 9 , Jul 16 7:33 PM
                  • 0 Attachment
                    Comment #7 on issue 152 by HiAngel...@...: 7.4a.24 BETA can't remove
                    lines
                    http://code.google.com/p/vim/issues/detail?id=152

                    It works, thanks you very much! By the way: aren’t you magician?
                    P.S. I can't find sacramental button: how to close bug?

                    --
                    You received this message because this project is configured to send all
                    issue notifications to this address.
                    You may adjust your notification preferences at:
                    https://code.google.com/hosting/settings

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • vim@...
                    Updates: Status: Fixed Owner: drc...@campbellfamily.biz Comment #8 on issue 152 by drc...@campbellfamily.biz: 7.4a.24 BETA can t remove lines
                    Message 9 of 9 , Mar 4, 2014
                    • 0 Attachment
                      Updates:
                      Status: Fixed
                      Owner: drc...@...

                      Comment #8 on issue 152 by drc...@...: 7.4a.24 BETA can't
                      remove lines
                      http://code.google.com/p/vim/issues/detail?id=152

                      You need to find commands on your system that will copy and move files.
                      cmd /c copy -and- cmd /c move worked under windows xp. Just set
                      g:netrw_localcopycmd and g:netrw_localmovecmd to whatever works for you.

                      --
                      You received this message because this project is configured to send all
                      issue notifications to this address.
                      You may adjust your notification preferences at:
                      https://code.google.com/hosting/settings

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    Your message has been successfully submitted and would be delivered to recipients shortly.