Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 7.4a echon - Press ENTER or type command to continue

Expand Messages
  • David Fishburn
    This sympton I was only able to reproduce on some Unix machines, I can now produce it on Windows machines too. If you execute this command: let msg = Enter
    Message 1 of 2 , Jul 15, 2013
    • 0 Attachment
      This sympton I was only able to reproduce on some Unix machines, I can now produce it on Windows machines too.

      If you execute this command:
      let msg = "Enter character:" | echo msg | let c = getchar() | let c = nr2char(c) | echon c

      The output you get is:
      Enter character:j


      Some users on different *nix machines report they get:
      Enter character:
      j
      Press Enter or type command to continue.

      Where I cannot reproduce this exactly, there is a simple variant which can be reproduced.

      gvim -u NONE -U NONE -N
      :let msg = "Enter character:" | echo msg | let c = getchar() | let c = nr2char(c) | echon c

      If the command fits on one line, I get:
      Enter character:j


      If you make the width of the screen smaller so that the command above (90 characters long) must wrap, when you execute it you get:
      Enter character:j
      Press ENTER or type command to continue.

      Is this a bug or is it expected?

      Thanks,
      David


      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Bram Moolenaar
      ... Expected. The prompt is on the second line from the bottom. Going back to the text means the output of echon is removed, since a redraw is needed
      Message 2 of 2 , Jul 16, 2013
      • 0 Attachment
        David Fishburn wrote:

        > This sympton I was only able to reproduce on some Unix machines, I can now
        > produce it on Windows machines too.
        >
        > If you execute this command:
        > let msg = "Enter character:" | echo msg | let c = getchar() | let c =
        > nr2char(c)
        > | echon c
        >
        > The output you get is:
        > Enter character:j
        >
        >
        > Some users on different *nix machines report they get:
        > Enter character:
        > j
        > Press Enter or type command to continue.
        >
        > Where I cannot reproduce this exactly, there is a simple variant which can
        > be reproduced.
        >
        > gvim -u NONE -U NONE -N
        > :let msg = "Enter character:" | echo msg | let c = getchar() | let c =
        > nr2char(c)
        > | echon c
        >
        > If the command fits on one line, I get:
        > Enter character:j
        >
        >
        > If you make the width of the screen smaller so that the command above (90
        > characters long) must wrap, when you execute it you get:
        > Enter character:j
        > Press ENTER or type command to continue.
        >
        > Is this a bug or is it expected?

        Expected. The prompt is on the second line from the bottom. Going back
        to the text means the output of "echon" is removed, since a redraw is
        needed (scroll everything down).

        If you set 'cmdheight' to 2 then there is no need for the redraw and you
        don't get the press-enter prompt.

        --
        An easy way to determine if you have enough teamwork to be doomed is simply to
        measure how long it takes from the time you decide to go to lunch together
        until the time you actually eat.
        (Scott Adams - The Dilbert principle)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.