Loading ...
Sorry, an error occurred while loading the content.

Patch 7.3.787 performance

Expand Messages
  • Travis
    Hi, I noticed in the vim 7.4a beta (I believe it is the patch 7.3.787 but I m not entirely sure), it looks like relative line number performance has greatly
    Message 1 of 2 , Jul 11 8:56 AM
    • 0 Attachment
      Hi,

      I noticed in the vim 7.4a beta (I believe it is the patch 7.3.787 but I'm not entirely sure), it looks like relative line number performance has greatly decreased.

      If I open a file with just 100 lines, scrolling via rnu is quite choppy, and if I turn it off, it's very fast again. This worked before the RNU patch.

      I also have row and column highlighting off.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      ... Recently, there was another patch, modifying the behaviour of 7.3.787. So please try with vim 7.4 beta and try different settings of :set rnu and :set nu
      Message 2 of 2 , Jul 11 12:15 PM
      • 0 Attachment
        On Do, 11 Jul 2013, Travis wrote:

        > I noticed in the vim 7.4a beta (I believe it is the patch 7.3.787 but I'm not entirely sure), it looks like relative line number performance has greatly decreased.
        >
        > If I open a file with just 100 lines, scrolling via rnu is quite choppy, and if I turn it off, it's very fast again. This worked before the RNU patch.
        >
        > I also have row and column highlighting off.

        Recently, there was another patch, modifying the behaviour of 7.3.787.
        So please try with vim 7.4 beta and try different settings of :set rnu
        and :set nu

        Mit freundlichen Grüßen
        Christian
        --
        Mädchen - das sind diejenigen, die rückwärts tanzen.
        -- Bob Hope

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.