Loading ...
Sorry, an error occurred while loading the content.
 

Re: :rubydo X fail on Mac OS X 10.7.5

Expand Messages
  • Timothee Gauthier
    I confirm that : $ sudo make install STRIP=/usr/bin/true Work s fine. Why I ve never see this command on other topics with all the people complaining that vim
    Message 1 of 6 , Jul 9, 2013
      I confirm that :
      $ sudo make install STRIP=/usr/bin/true

      Work's fine.

      Why I've never see this command on other topics with all the people complaining that vim doesn't work well with ruby + os X ?

      I will try this night on an older macbook running OS X 10.6.7

      Thanks for the reply.

      Le lundi 8 juillet 2013 13:25:03 UTC+2, Timothee Gauthier a écrit :
      > Hi,
      >
      > I compile Vim on OS X with the latest version, but when I do in vim every "rubydo" command:
      > :rubydo puts "x"
      >
      > It crash with
      > Vim: Caught deadly signal TRAP
      > Vim: Finished.
      >
      > > vim --version
      > VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul 8 2013 10:54:48)
      > MacOS X (unix) version
      > Included patches: 1-2
      > Compiled by tim@plop
      > Big version without GUI. Features included (+) or not (-):
      >
      > ...[removed long description]
      > +diff +menu +ruby +writebackup
      > ...[removed long description]
      >
      > system vimrc file: "$VIM/vimrc"
      > user vimrc file: "$HOME/.vimrc"
      > 2nd user vimrc file: "~/.vim/vimrc"
      > user exrc file: "$HOME/.exrc"
      > fall-back for $VIM: "/usr/local/share/vim"
      > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DMACOS_X_UNIX -no-cpp-precomp -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
      > Linking: gcc -L. -L/Users/tim/.rbenv/versions/2.0.0-p195/lib -L/usr/local/lib -o vim -lm -lncurses -liconv -framework Cocoa -framework Python -lruby-static -lobjc -L/Users/tim/.rbenv/versions/2.0.0-p195/lib
      >
      > I run on
      > Mac OS X 10.7.5 (on Intel)
      >
      > ruby --version (compiled with rbenv)
      > ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-darwin11.4.2]
      >
      > Since I m new in the compiling world, I print what I've made:
      >
      > hg pull
      > hg update
      > make clean
      > ./configure --with-features=HUGE --enable-rubyinterp
      > make
      > sudo make install
      >
      >
      > And I also tried
      > /configure --with-features=HUGE \
      > --enable-multibyte=yes \
      > --enable-cscope=yes \
      > --enable-rubyinterp=yes \
      > --with-ruby-command=/Users/tim/.rbenv/versions/2.0.0-p195/bin/ruby \
      >
      > And it end with the same problem.
      >
      > Do you need more datas to help me ?
      >
      > Thank you.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Timothee Gauthier
      You said it s because of ruby 2.0, But I tried to compile with ruby 1.8.7 (on the system) and 1.9.3, and it ends with the same problem. Thanks for the
      Message 2 of 6 , Jul 9, 2013
        You said it's because of ruby 2.0,
        But I tried to compile with ruby 1.8.7 (on the system)
        and 1.9.3, and it ends with the same problem.

        Thanks for the solution.

        Le lundi 8 juillet 2013 18:20:36 UTC+2, Kent Sibilev a écrit :
        > On Monday, July 8, 2013 7:25:03 AM UTC-4, Timothee Gauthier wrote:
        > > Hi,
        > >
        > > I compile Vim on OS X with the latest version, but when I do in vim every "rubydo" command:
        > > :rubydo puts "x"
        > >
        > > It crash with
        > > Vim: Caught deadly signal TRAP
        > > Vim: Finished.
        > >
        >
        > When you install vim, ask it not to strip symbol table:
        >
        > $ sudo make install STRIP=/usr/bin/true
        >
        > For some reason ruby 2.0 has problems with that.
        >
        > BR,
        > Kent

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Manuel Ortega
        On Tue, Jul 9, 2013 at 6:05 AM, Timothee Gauthier
        Message 3 of 6 , Jul 9, 2013
          On Tue, Jul 9, 2013 at 6:05 AM, Timothee Gauthier <itsumo.sibyllin@...> wrote:
          I confirm that :
          $ sudo make install STRIP=/usr/bin/true

          Work's fine.

          Why I've never see this command on other topics with all the people complaining that vim doesn't work well with ruby + os X ?

          If memory serves, this was discussed by Homebrew: https://github.com/mxcl/homebrew/issues/17904



          -Manny

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.