Loading ...
Sorry, an error occurred while loading the content.
 

vim stops

Expand Messages
  • Dimitar DIMITROV
    Hi, running the latest version of vim (from mercurial) I experience the following weird behaviour: 1. command /usr/local/bin/vim -nNX -u NONE 2. zzzzzzzzzzzz
    Message 1 of 7 , Jul 8 6:05 AM
      Hi, running the latest version of vim (from mercurial) I experience the following weird behaviour:

      1. command /usr/local/bin/vim -nNX -u NONE
      2. zzzzzzzzzzzz shift (hold on to z then simultaneosly press shift)
      Vim stops

      Ran it under valgrind but it reports: definitely lost: 0 bytes in 0 blocks

      Version:
      VIM - Vi IMproved 7.4a BETA (2013 Jul 6, compiled Jul  8 2013 13:51:44)
      Included patches: 1-2
       
      Dimitar

      ---
      GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • tooth pik
      ... it s a feature -- ZZ is a quit command -- see ... -- _|_ _ __|_|_ ._ o| ... -- -- You received this message from the vim_dev maillist. Do not top-post!
      Message 2 of 7 , Jul 8 6:36 AM
        On Mon, Jul 08, 2013 at 02:05:19PM +0100, Dimitar DIMITROV wrote:
        > Hi, running the latest version of vim (from mercurial) I experience the following weird behaviour:

        > 1. command /usr/local/bin/vim -nNX -u NONE
        > 2. zzzzzzzzzzzz shift (hold on to z then simultaneosly press shift)
        > Vim stops

        it's a feature -- ZZ is a quit command -- see

        :h ZZ

        --
        _|_ _ __|_|_ ._ o|
        |_(_)(_)|_| ||_)||<
        |

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Dimitar DIMITROV
        No, I didn t right ZZ but zzzzzz. It s different :)   Dimitar ... GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka)
        Message 3 of 7 , Jul 8 6:41 AM
          No, I didn't right ZZ but zzzzzz. It's different :)
           
          Dimitar

          ---
          GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

          De : tooth pik <toothpik6@...>
          À : vim_dev@...
          Envoyé le : Lundi 8 juillet 2013 14h36
          Objet : Re: vim stops

          On Mon, Jul 08, 2013 at 02:05:19PM +0100, Dimitar DIMITROV wrote:
          > Hi, running the latest version of vim (from mercurial) I experience the following weird behaviour:

          > 1. command /usr/local/bin/vim -nNX -u NONE
          > 2. zzzzzzzzzzzz shift (hold on to z then simultaneosly press shift)
          > Vim stops

          it's a feature -- ZZ is a quit command -- see

              :h ZZ

          --
          _|_ _  __|_|_ ._ o| 
          |_(_)(_)|_| ||_)||<
                        |     

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.




          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Manuel Ortega
          ... Bram, I looked at this and didn t remember offhand what the -X flag did. No wonder: vim --help has no entry for that flag. But :h startup-options
          Message 4 of 7 , Jul 8 7:15 AM

            1. command /usr/local/bin/vim -nNX -u NONE

            Bram,

            I looked at this and didn't remember offhand what the '-X' flag did.  No wonder: 'vim --help' has no entry for that flag.  But ':h startup-options' *does* say what the flag does.  Please update the output of 'vim --help'.

            I shall now hunt for other discrepancies between 'vim --help' and ':h startup-options'.

            -Manny 

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • tooth pik
            ... and what about then simultaneously press shift ? or maybe you have a keyboard that produces other than Z for SHIFT-z? and please don t top-post -- _|_ _
            Message 5 of 7 , Jul 8 7:54 AM
              On Mon, Jul 08, 2013 at 02:41:11PM +0100, Dimitar DIMITROV wrote:
              > No, I didn't right ZZ but zzzzzz. It's different :)

              and what about "then simultaneously press shift"? or maybe you have a
              keyboard that produces other than Z for SHIFT-z?

              and please don't top-post

              --
              _|_ _ __|_|_ ._ o|
              |_(_)(_)|_| ||_)||<
              |

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Bram Moolenaar
              ... % vim --help | grep X -X Do not connect to X server Perhaps your Vim was not compiled with X11 support? -- Snoring is prohibited unless
              Message 6 of 7 , Jul 8 8:25 AM
                Manuel Ortega wrote:

                > > 1. command /usr/local/bin/vim -nNX -u NONE
                >
                > Bram,
                >
                > I looked at this and didn't remember offhand what the '-X' flag did. No
                > wonder: 'vim --help' has no entry for that flag. But ':h startup-options'
                > *does* say what the flag does. Please update the output of 'vim --help'.
                >
                > I shall now hunt for other discrepancies between 'vim --help' and ':h
                > startup-options'.

                % vim --help | grep X
                -X Do not connect to X server

                Perhaps your Vim was not compiled with X11 support?

                --
                Snoring is prohibited unless all bedroom windows are closed and securely
                locked.
                [real standing law in Massachusetts, United States of America]

                /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                \\\ an exciting new programming language -- http://www.Zimbu.org ///
                \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Charles Campbell
                ... I think you wanted a new topic; irregardless, you appeared to have Replied to an unrelated topic ( Re: vim stops). A better approach with Seamonkey, for
                Message 7 of 7 , Jul 8 9:12 AM
                  Manuel Ortega wrote:
                  >
                  > 1. command /usr/local/bin/vim -nNX -u NONE
                  >
                  >
                  > Bram,
                  >
                  > I looked at this and didn't remember offhand what the '-X' flag did.
                  > No wonder: 'vim --help' has no entry for that flag. But ':h
                  > startup-options' *does* say what the flag does. Please update the
                  > output of 'vim --help'.
                  >
                  > I shall now hunt for other discrepancies between 'vim --help' and ':h
                  > startup-options'.
                  >
                  I think you wanted a new topic; irregardless, you appeared to have
                  "Replied" to an unrelated topic ("Re: vim stops). A better approach
                  with Seamonkey, for example, is (typically) to right click on the "To"
                  field and then to "compose mail to". Avoids losing your new topic in an
                  unrelated thread. You should investigate to find out what works best
                  with your email agent.

                  Regards,
                  Chip Campbell

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.