Loading ...
Sorry, an error occurred while loading the content.

[PATCH] syntax/tex: subequations is not a math environment

Expand Messages
  • Anton Khirnov
    # HG changeset patch # User Anton Khirnov # Date 1350881984 -7200 # Node ID d06f0b678ab404b4fae324d057fc7a48be856020 # Parent
    Message 1 of 1 , Jul 5, 2013
    • 0 Attachment
      # HG changeset patch
      # User Anton Khirnov <anton@...>
      # Date 1350881984 -7200
      # Node ID d06f0b678ab404b4fae324d057fc7a48be856020
      # Parent 0134f1a6b8a09b98a72df28b1de188b109bd9a00
      syntax/tex: subequations is not a math environment

      subequations only affects the numbering of equations in environments
      that are contained within it, it is not a math environment by itself.

      diff -r 0134f1a6b8a0 -r d06f0b678ab4 runtime/syntax/tex.vim
      --- a/runtime/syntax/tex.vim Sun Oct 21 04:00:08 2012 +0200
      +++ b/runtime/syntax/tex.vim Mon Oct 22 06:59:44 2012 +0200
      @@ -353,7 +353,7 @@

      " Bad Math (mismatched): {{{1
      if !exists("tex_no_math")
      - syn match texBadMath "\\end\s*{\s*\(array\|gathered\|bBpvV]matrix\|split\|subequations\|smallmatrix\|xxalignat\)\s*}"
      + syn match texBadMath "\\end\s*{\s*\(array\|gathered\|bBpvV]matrix\|split\|smallmatrix\|xxalignat\)\s*}"
      syn match texBadMath "\\end\s*{\s*\(align\|alignat\|displaymath\|displaymath\|eqnarray\|equation\|flalign\|gather\|math\|multline\|xalignat\)\*\=\s*}"
      syn match texBadMath "\\[\])]"
      endif
      @@ -398,7 +398,6 @@
      call TexNewMathZone("G","gather",1)
      call TexNewMathZone("H","math",1)
      call TexNewMathZone("I","multline",1)
      - call TexNewMathZone("J","subequations",0)
      call TexNewMathZone("K","xalignat",1)
      call TexNewMathZone("L","xxalignat",0)


      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.