Loading ...
Sorry, an error occurred while loading the content.

Re: [BUG][PATCH] incorrect undo-history

Expand Messages
  • Bram Moolenaar
    ... Good catch. And thanks for the fix. -- It s not hard to meet expenses, they re everywhere. /// Bram Moolenaar -- Bram@Moolenaar.net --
    Message 1 of 2 , Jul 3 5:20 AM
    • 0 Attachment
      Ozaki wrote:

      > Since v7.3.1270, 'undo' does not work correctly under certain conditions.
      >
      > vim -N -u NONE
      > :put ='aaa'
      > u
      >
      > expected: buffer empties, and it is an 'oldest change'
      > actual: 'aaa' remains at line 1, and it is an 'oldest change' ( i
      > cannot undo any more )
      >
      > I propose the attached fixes.

      Good catch. And thanks for the fix.


      --
      It's not hard to meet expenses, they're everywhere.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.