Loading ...
Sorry, an error occurred while loading the content.

[bug] cursorline disappears (set cul)

Expand Messages
  • Charles Campbell
    This problem appeared with a recent patch (I can t backtrack on the patches to find out which one on my work machine -- however, I suspect its patch#1277).
    Message 1 of 2 , Jul 1, 2013
    View Source
    • 0 Attachment
      This problem appeared with a recent patch (I can't backtrack on the
      patches to find out which one on my work machine -- however, I suspect
      its patch#1277).

      Have two files, tmp1 and tmp2, with several lines contained in each:

      vim -O tmp1 tmp2
      :set cul
      :wincmd l
      :set cul
      :wincmd h

      Note that the "current line" in the tmp2 file disappears. This affects
      the "ProcTrak" plugin which we're using at Goddard Space Flight Center's
      MMS project.

      Typically, the display has two windows:

      +--------+------------+
      | | |
      | Log | Procedure |
      | File | File |
      | | |
      +--------+------------+

      (you should use a monospace font to view the above, but I didn't do this
      email with html to avoid the associated petulance).

      So the log file is queried at a 3Hz rate; it often has procedure+line
      data and so the procedure file display is updated accordingly. It was
      showing the current line in the procedure file window, but now "set cul"
      is no longer effective.

      Regards,
      Chip Campbell


      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Right, patch 1277 changed a bit too much. A redraw may remove the cursor line. -- Q: How many hardware engineers does it take to change a lightbulb? A:
      Message 2 of 2 , Jul 1, 2013
      View Source
      • 0 Attachment
        Charles Campbell wrote:

        > This problem appeared with a recent patch (I can't backtrack on the
        > patches to find out which one on my work machine -- however, I suspect
        > its patch#1277).
        >
        > Have two files, tmp1 and tmp2, with several lines contained in each:
        >
        > vim -O tmp1 tmp2
        > :set cul
        > :wincmd l
        > :set cul
        > :wincmd h
        >
        > Note that the "current line" in the tmp2 file disappears. This affects
        > the "ProcTrak" plugin which we're using at Goddard Space Flight Center's
        > MMS project.
        >
        > Typically, the display has two windows:
        >
        > +--------+------------+
        > | | |
        > | Log | Procedure |
        > | File | File |
        > | | |
        > +--------+------------+
        >
        > (you should use a monospace font to view the above, but I didn't do this
        > email with html to avoid the associated petulance).
        >
        > So the log file is queried at a 3Hz rate; it often has procedure+line
        > data and so the procedure file display is updated accordingly. It was
        > showing the current line in the procedure file window, but now "set cul"
        > is no longer effective.

        Right, patch 1277 changed a bit too much. A redraw may remove the
        cursor line.


        --
        Q: How many hardware engineers does it take to change a lightbulb?
        A: None. We'll fix it in software.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.