Loading ...
Sorry, an error occurred while loading the content.
 

Re: Patch 7.3.1179

Expand Messages
  • Nikolay Pavlov
    ... they stopped working. ... keymap=hebrew, that map no longer works. I tried changing the imap to the actual characters entered by the keymap, e.g. ;י ...
    Message 1 of 7 , Jun 28 4:19 AM


      On Jun 28, 2013 3:09 PM, "Nikolay Pavlov" <zyx.vim@...> wrote:
      >
      > There is another victim now:
      >
      > On Jun 28, 2013 8:52 AM, "Ron Aaron" <ronware.org@...> wrote:
      > >
      > > They have always worked before, but in one of the fairly recent builds they stopped working.
      > >
      > > I have an input map of `h  to something.  When I have a rl window and keymap=hebrew, that map no longer works.  I tried changing the imap to the actual characters entered by the keymap, e.g. ;י ... but it also does not work.

      It looks now like it is better to revert it or add an option with new behavior *disabled* by default. If it conflicts with keymaps then it means almost any global mapping is disabled when keymap is active. This is obviously not standable.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Andy Wokula
      ... There was a good reason for the new behavior. Overview about discussion so far: Initial discussion: vim_use, Jan 2013: Buffer-local unmap of global
      Message 2 of 7 , Jun 28 9:17 AM
        Am 22.06.2013 14:37, schrieb ZyX:
        > How to disable this behavior? I have a bunch of global mappings
        > starting with comma and translit3 plugin which translates things like
        > “,,” into “„” in an IMAP-like fashion (translation is done only when
        > last character of sequence is typed; preceding characters found in the
        > buffer are used to check whether something is to be translated).
        > Translit3 plugin is enabled only for specific buffers and thus is
        > using <buffer> mappings. Thus I am completely against new behavior.

        There was a good reason for the new behavior. Overview about discussion
        so far:

        Initial discussion:
        vim_use, Jan 2013: Buffer-local unmap of global mapping
        vim_dev, Jan 2013: Prioritize buffer-local mappings over global ones (with patch)

        (This) Patch:
        vim_dev: Patch 7.3.1179

        Problems with the patch:
        vim_dev: Quick Fix/No File Buffers and the q key
        vim_dev: imaps don't work with keymap=hebrew

        ZyX' patch:
        vim_dev: [PATCH] Add 'waitforglobalmap' option

        --
        Andy

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.