Loading ...
Sorry, an error occurred while loading the content.

Re: Patch 7.3.1249

Expand Messages
  • Bram Moolenaar
    ... And make it very difficult to find a typo in an option name... Well, we could silently ignore bogus modelines unless verbose is set. But users will need
    Message 1 of 8 , Jun 27, 2013
    • 0 Attachment
      Ben Fritz wrote:

      > On Thursday, June 27, 2013 2:35:04 PM UTC-5, Andy Wokula wrote:
      > > Am 26.06.2013 20:04, schrieb Bram Moolenaar:
      > >
      > > > Patch 7.3.1249
      > >
      > > > Problem: Modeline not recognized when using "Vim" instead of "vim".
      > >
      > > > Solution: Also accept "Vim".
      > >
      > > > Files: src/buffer.c
      > >
      > >
      > >
      > > -1 for this change.
      > >
      > > I don't want lines starting with or containing "Vim:" to define a modeline.
      > >
      > > Several of my (text) files yell errors now.
      > >
      >
      > Maybe Vim could examine what it thinks is a modeline first, and then
      > refuse to execute it if anything invalid is found?
      >
      > In TOhtml I had to intentionally mangle modelines using character
      > references, so that a modeline in the file to be converted didn't
      > convert to an invalid modeline that Vim proceeded to yell about.
      >
      > If Vim would just silently ignore invalid modelines that would prevent
      > such a need and also solve your problem.

      And make it very difficult to find a typo in an option name...

      Well, we could silently ignore bogus modelines unless 'verbose' is set.
      But users will need to read the help to figure that out.

      --
      FIRST GUARD: Ah! Now ... we're not allowed to ...
      SIR LAUNCELOT runs him through, grabs his spear and stabs the other
      guard who collapses in a heap. Hiccoughs quietly.
      "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Manuel Ortega
      ... The commit message for this patch says that it s a problem that modelines can t start with Vim . But what I don t understand is why that is a problem
      Message 2 of 8 , Jun 27, 2013
      • 0 Attachment
        On Thu, Jun 27, 2013 at 3:50 PM, Bram Moolenaar <Bram@...> wrote:

        Andy Wokula wrote:

        > Am 26.06.2013 20:04, schrieb Bram Moolenaar:
        > > Patch 7.3.1249
        > > Problem:    Modeline not recognized when using "Vim" instead of "vim".
        > > Solution:   Also accept "Vim".
        > > Files:          src/buffer.c
        >
        > -1 for this change.
        > I don't want lines starting with or containing "Vim:" to define a modeline.
        > Several of my (text) files yell errors now.

        Do more people see this problem?

        The background is that I accidentally changed "vim" to "Vim" and then
        had a really hard time to figure out why the modeline wasn't working.

        The commit message for this patch says that it's a "problem" that modelines can't start with 'Vim'.  But what I don't understand is why that is a problem in the first place.  Thus I don't understand why it needs to be "solved".

        Nothing in ':h modeline' says that the capitalized form *should* work.  Both forms are defined in lowercase.

        -Manny 

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      Your message has been successfully submitted and would be delivered to recipients shortly.