Loading ...
Sorry, an error occurred while loading the content.

Re: Broken syntax in vim.vim

Expand Messages
  • Manuel Ortega
    On Wed, Jun 26, 2013 at 1:09 PM, Charles Campbell
    Message 1 of 18 , Jun 26, 2013
    • 0 Attachment
      On Wed, Jun 26, 2013 at 1:09 PM, Charles Campbell <Charles.E.Campbell@...> wrote:


      Sounds like nasty stuff.  Two problems:

      1. There is no isk+=: in syntax/vim.vim v7.3-25

      Not here either.

       
      2. My copy of ftplugin/vim.vim, which I don't maintain, also does not have isk+=: in it.


      But mine does (line 26: setlocal isk+=:), and I don't fiddle with mine either.

      -Manny

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • mattn
      https://gist.github.com/mattn/5865363 I fixed patch. Could you try this again? -- -- You received this message from the vim_dev maillist. Do not top-post!
      Message 2 of 18 , Jun 26, 2013
      • 0 Attachment
        https://gist.github.com/mattn/5865363

        I fixed patch.
        Could you try this again?

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • mattn
        ... I found a bug. a, bs/foo/bar/g is broken. Fixed this. https://gist.github.com/mattn/5865363 http://go-gyazo.appspot.com/bf30bee5ac94c3ca.png -- -- You
        Message 3 of 18 , Jun 26, 2013
        • 0 Attachment
          On Thursday, June 27, 2013 2:36:36 PM UTC+9, mattn wrote:
          > https://gist.github.com/mattn/5865363
          >
          > I fixed patch.
          > Could you try this again?

          I found a bug.

          'a,'bs/foo/bar/g is broken.

          Fixed this.

          https://gist.github.com/mattn/5865363

          http://go-gyazo.appspot.com/bf30bee5ac94c3ca.png

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Ingo Karkat
          ... While I respect your decision to keep the dev process as it currently works for you, and while I don t want to resurrect the old discussion
          Message 4 of 18 , Jun 26, 2013
          • 0 Attachment
            On 26-Jun-2013 19:18 +0200, Bram Moolenaar wrote:

            > [44 lines deleted]
            >
            > Right. I don't know how this got there. If it really is for syntax
            > highlighting it should be in the syntax plugin, not the ftplugin.

            While I respect your decision to keep the dev process as it currently
            works for you, and while I don't want to resurrect the old discussion
            (https://groups.google.com/d/msg/vim_dev/9tggyPAX7sY/Hcz0TSkZpPIJ), I
            can't stop myself from mentioning that with atomic commits of runtime
            changes (like you do for source code patches), there would be a much
            better chance of determining what this change was about. (Assuming you
            had written a suitable commit message.)

            Come on, you could just give it a try and do slightly more fine-grained
            commits of runtime updates in the future. If it's too much effort, just
            revert back to the bulky updates (occasionally).

            > In case of doubt I prefer to leave 'iskeyword' alone.

            Alright, so you're going to remove "isk+=:", but keep "isk+=#" (which is
            undisputedly beneficial) in ftplugin/vim.vim?! Thanks!

            -- regards, ingo

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.