Loading ...
Sorry, an error occurred while loading the content.

Re: Quick Fix/No File Buffers and the q key

Expand Messages
  • Christian Brabandt
    Hi Amadeus! ... This is probably caused by patch 7.3.1179. regards, Christian -- Man sollte nie schweigen, wenn man nur einigen Ruf hat; Schweigen wird für
    Message 1 of 4 , Jun 24, 2013
    • 0 Attachment
      Hi Amadeus!

      On Mo, 24 Jun 2013, Amadeus Demarzi wrote:

      > I use `q` as my leader key, which means I have the following set in my vimrc:
      >
      > let mapleader="q"
      > nnoremap q <nop>
      > vnoremap q <nop>
      > nnoremap Q q
      > vnoremap Q q
      >
      > However, it seems on the newer builds of MacVim (specifically version 7.3 with patches 1-1233) that when I press `q` in quickfix or nofile splits (like in NerdTree) it just closes the buffer, and doesn't execute the start of a leader key pattern.
      >
      > Perhaps there might be some new configs I need to set with the newer updates? Or perhaps it's a bug.

      This is probably caused by patch 7.3.1179.

      regards,
      Christian
      --
      Man sollte nie schweigen, wenn man nur einigen Ruf hat; Schweigen wird
      für Verachtung und Zurückziehen angesehen, und man [wird] gehaßt bloß
      für Schüchternheit.
      -- Jean Paul

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Amadeus Demarzi
      Just a quick bump on this issue? Technically it seems like remaps in quickfix and other specialized buffers can be broken due to patch 1179. Cheers, Amadeus
      Message 2 of 4 , Jun 26, 2013
      • 0 Attachment
        Just a quick bump on this issue? Technically it seems like remaps in quickfix and other specialized buffers can be broken due to patch 1179.

        Cheers,
        Amadeus

        On Monday, June 24, 2013 11:54:56 AM UTC-7, Christian Brabandt wrote:
        > Hi Amadeus!
        >
        >
        >
        > On Mo, 24 Jun 2013, Amadeus Demarzi wrote:
        >
        >
        >
        > > I use `q` as my leader key, which means I have the following set in my vimrc:
        >
        > >
        >
        > > let mapleader="q"
        >
        > > nnoremap q <nop>
        >
        > > vnoremap q <nop>
        >
        > > nnoremap Q q
        >
        > > vnoremap Q q
        >
        > >
        >
        > > However, it seems on the newer builds of MacVim (specifically version 7.3 with patches 1-1233) that when I press `q` in quickfix or nofile splits (like in NerdTree) it just closes the buffer, and doesn't execute the start of a leader key pattern.
        >
        > >
        >
        > > Perhaps there might be some new configs I need to set with the newer updates? Or perhaps it's a bug.
        >
        >
        >
        > This is probably caused by patch 7.3.1179.
        >
        >
        >
        > regards,
        >
        > Christian
        >
        > --
        >
        > Man sollte nie schweigen, wenn man nur einigen Ruf hat; Schweigen wird
        >
        > f�r Verachtung und Zur�ckziehen angesehen, und man [wird] geha�t blo�
        >
        > f�r Sch�chternheit.
        >
        > -- Jean Paul

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Amadeus Demarzi
        Looks like my issue was fixed with most recent patches. Cheers and thanks! ... -- -- You received this message from the vim_dev maillist. Do not top-post!
        Message 3 of 4 , Jul 3, 2013
        • 0 Attachment
          Looks like my issue was fixed with most recent patches.

          Cheers and thanks!

          On Wednesday, June 26, 2013 10:04:33 PM UTC-7, Amadeus Demarzi wrote:
          > Just a quick bump on this issue? Technically it seems like remaps in quickfix and other specialized buffers can be broken due to patch 1179.
          >
          >
          >
          > Cheers,
          >
          > Amadeus
          >
          >
          >
          > On Monday, June 24, 2013 11:54:56 AM UTC-7, Christian Brabandt wrote:
          >
          > > Hi Amadeus!
          >
          > >
          >
          > >
          >
          > >
          >
          > > On Mo, 24 Jun 2013, Amadeus Demarzi wrote:
          >
          > >
          >
          > >
          >
          > >
          >
          > > > I use `q` as my leader key, which means I have the following set in my vimrc:
          >
          > >
          >
          > > >
          >
          > >
          >
          > > > let mapleader="q"
          >
          > >
          >
          > > > nnoremap q <nop>
          >
          > >
          >
          > > > vnoremap q <nop>
          >
          > >
          >
          > > > nnoremap Q q
          >
          > >
          >
          > > > vnoremap Q q
          >
          > >
          >
          > > >
          >
          > >
          >
          > > > However, it seems on the newer builds of MacVim (specifically version 7.3 with patches 1-1233) that when I press `q` in quickfix or nofile splits (like in NerdTree) it just closes the buffer, and doesn't execute the start of a leader key pattern.
          >
          > >
          >
          > > >
          >
          > >
          >
          > > > Perhaps there might be some new configs I need to set with the newer updates? Or perhaps it's a bug.
          >
          > >
          >
          > >
          >
          > >
          >
          > > This is probably caused by patch 7.3.1179.
          >
          > >
          >
          > >
          >
          > >
          >
          > > regards,
          >
          > >
          >
          > > Christian
          >
          > >
          >
          > > --
          >
          > >
          >
          > > Man sollte nie schweigen, wenn man nur einigen Ruf hat; Schweigen wird
          >
          > >
          >
          > > f�r Verachtung und Zur�ckziehen angesehen, und man [wird] geha�t blo�
          >
          > >
          >
          > > f�r Sch�chternheit.
          >
          > >
          >
          > > -- Jean Paul

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.