Loading ...
Sorry, an error occurred while loading the content.
 

Re: Missing commands in index.txt doc

Expand Messages
  • Shane Thornton
    ... I am experiences some issues using both plugins, ft_improved and fanfingtastic for getting t/f commands to be multiline. I m using version 7.3.829. For
    Message 1 of 11 , Jun 22, 2013
      On Saturday, June 22, 2013 12:55:29 AM UTC-7, Christian Brabandt wrote:
      > Hi Shane!
      >
      >
      >
      > On Fr, 21 Jun 2013, Shane Thornton wrote:
      >
      >
      >
      > > On Friday, June 21, 2013 7:45:26 AM UTC-7, Shane Thornton wrote:
      >
      > > > If you type ":h z" and get to the commands starting with z there is
      >
      > > > zH/zL missing from the list there. :)
      >
      > >
      >
      > > If I put my cursor on the C in that first sentence, then try to
      >
      > > navigate to the <space> before "noticed" by using only the 'tn' or ';'
      >
      > > command I am unable to do so. The cursor will get caught at the
      >
      > > <space> before "new". However, if I do the same thing using 'fn' and
      >
      > > ';' I have no issues, except the cursor is on "n" in noticed. It does
      >
      > > work with the number modifier, but it would be better without using
      >
      > > them, and just tapping ';' to get there if I'm editing fast and don't
      >
      > > want to count characters. This is helpful when till-tapping over to
      >
      > > somewhere, then hitting 'v' for visual mode, then till-tapping over to
      >
      > > the end letter and using an operator for the selection. With Vim's
      >
      > > current behavior that is not possible, and although I understand it
      >
      > > would change something, I think it would change it in a way that it
      >
      > > would fix existing issues and not interrupt anyone's expectations of
      >
      > > how the program should behave, it would instead just make it behave it
      >
      > > a way that one would expect.
      >
      >
      >
      > What is your vim version? I made a patch, that changes it. I think you
      >
      > need 7.3.235 to have this work.
      >
      >
      >
      > > The idea of using n/N instead of ;/, is probably a little over the
      >
      > > top, but the above idea and making it multiline I think would hurt
      >
      > > anyone.
      >
      >
      >
      > I made the ft_improved plugin to make f and t work multiline.
      >
      >
      >
      > regards,
      >
      > Christian
      >
      > --
      >
      > Die Ehe ist eine sehr gute Institution, aber ich bin nicht reif f�r
      >
      > eine Institution.
      >
      > -- Mae West

      I am experiences some issues using both plugins, ft_improved and fanfingtastic
      for getting t/f commands to be multiline. I'm using version 7.3.829. For
      example, on the following text below, if I put my cursor on the ["] and try t/f
      on "o" it does nothing. However, if I try to get to g, it does jump. Other
      times, if I use the t command it will put the cursor on top of the letter
      itself. The behavior is very sporadic. It would be nice to have this fixed once
      and for all to include an ability inside Vim itself to be maintained.

      " Main options.
      :set nocompatible
      :au GUIEnter * simalt ~x
      :syntax on
      :set backspace=2
      :set number
      :set guioptions-=T "disable toolbar
      :set guioptions-=m "disable menu
      :set mouse=a

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      Hi Shane! ... I can t reproduce it. Which version of ft_improved did you use?. (Make sure you tried with the github version). putting the cursor on the first
      Message 2 of 11 , Jun 22, 2013
        Hi Shane!

        On Sa, 22 Jun 2013, Shane Thornton wrote:

        > On Saturday, June 22, 2013 12:55:29 AM UTC-7, Christian Brabandt wrote:
        > > Hi Shane!
        > >
        > >
        > >
        > > On Fr, 21 Jun 2013, Shane Thornton wrote:
        > >
        > >
        > >
        > > > On Friday, June 21, 2013 7:45:26 AM UTC-7, Shane Thornton wrote:
        > >
        > > > > If you type ":h z" and get to the commands starting with z there is
        > >
        > > > > zH/zL missing from the list there. :)
        > >
        > > >
        > >
        > > > If I put my cursor on the C in that first sentence, then try to
        > >
        > > > navigate to the <space> before "noticed" by using only the 'tn' or ';'
        > >
        > > > command I am unable to do so. The cursor will get caught at the
        > >
        > > > <space> before "new". However, if I do the same thing using 'fn' and
        > >
        > > > ';' I have no issues, except the cursor is on "n" in noticed. It does
        > >
        > > > work with the number modifier, but it would be better without using
        > >
        > > > them, and just tapping ';' to get there if I'm editing fast and don't
        > >
        > > > want to count characters. This is helpful when till-tapping over to
        > >
        > > > somewhere, then hitting 'v' for visual mode, then till-tapping over to
        > >
        > > > the end letter and using an operator for the selection. With Vim's
        > >
        > > > current behavior that is not possible, and although I understand it
        > >
        > > > would change something, I think it would change it in a way that it
        > >
        > > > would fix existing issues and not interrupt anyone's expectations of
        > >
        > > > how the program should behave, it would instead just make it behave it
        > >
        > > > a way that one would expect.
        > >
        > >
        > >
        > > What is your vim version? I made a patch, that changes it. I think you
        > >
        > > need 7.3.235 to have this work.
        > >
        > >
        > >
        > > > The idea of using n/N instead of ;/, is probably a little over the
        > >
        > > > top, but the above idea and making it multiline I think would hurt
        > >
        > > > anyone.
        > >
        > >
        > >
        > > I made the ft_improved plugin to make f and t work multiline.
        > >
        > >
        > >
        > > regards,
        > >
        > > Christian
        > >
        > > --
        > >
        > > Die Ehe ist eine sehr gute Institution, aber ich bin nicht reif f�r
        > >
        > > eine Institution.
        > >
        > > -- Mae West
        >
        > I am experiences some issues using both plugins, ft_improved and fanfingtastic
        > for getting t/f commands to be multiline. I'm using version 7.3.829. For
        > example, on the following text below, if I put my cursor on the ["] and try t/f
        > on "o" it does nothing. However, if I try to get to g, it does jump. Other
        > times, if I use the t command it will put the cursor on top of the letter
        > itself. The behavior is very sporadic. It would be nice to have this fixed once
        > and for all to include an ability inside Vim itself to be maintained.
        >
        > " Main options.
        > :set nocompatible
        > :au GUIEnter * simalt ~x
        > :syntax on
        > :set backspace=2
        > :set number
        > :set guioptions-=T "disable toolbar
        > :set guioptions-=m "disable menu
        > :set mouse=a

        I can't reproduce it. Which version of ft_improved did you use?. (Make
        sure you tried with the github version).

        putting the cursor on the first char of line 1 and using fo or to puts
        it on the expected char.

        Here was my test. (your sample was put in the file testfile1.vim):
        vim -u NONE -U NONE -N -c 'so ~/.vim/plugin/ft_improved.vim' -c ':norm dto'
        -c 'wq'

        leaves you with this file:

        ----------------------------
        options.
        :set nocompatible
        :au GUIEnter * simalt ~x
        :syntax on
        :set backspace=2
        :set number
        :set guioptions-=T "disable toolbar
        :set guioptions-=m "disable menu
        :set mouse=a
        ----------------------------

        Is this what you expect?

        PS: You might want to open an issue at the github page for the plugin:
        https://github.com/chrisbra/improvedft

        so I can track it better.

        regards,
        Christian.
        --
        Jemand, der immer lustig ist, ist was Unerträgliches.
        -- Loriot (eigentlich Vicco von Bülow)

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Shane Thornton
        ... I was using the version in vundle. That version doesn t work. I just tried the version in Github and it works fine. There is another listing for your
        Message 3 of 11 , Jun 22, 2013
          On Saturday, June 22, 2013 2:07:41 PM UTC-7, Christian Brabandt wrote:
          > Hi Shane!
          >
          >
          >
          > On Sa, 22 Jun 2013, Shane Thornton wrote:
          >
          >
          >
          > > On Saturday, June 22, 2013 12:55:29 AM UTC-7, Christian Brabandt wrote:
          >
          > > > Hi Shane!
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > On Fr, 21 Jun 2013, Shane Thornton wrote:
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > > On Friday, June 21, 2013 7:45:26 AM UTC-7, Shane Thornton wrote:
          >
          > > >
          >
          > > > > > If you type ":h z" and get to the commands starting with z there is
          >
          > > >
          >
          > > > > > zH/zL missing from the list there. :)
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > > If I put my cursor on the C in that first sentence, then try to
          >
          > > >
          >
          > > > > navigate to the <space> before "noticed" by using only the 'tn' or ';'
          >
          > > >
          >
          > > > > command I am unable to do so. The cursor will get caught at the
          >
          > > >
          >
          > > > > <space> before "new". However, if I do the same thing using 'fn' and
          >
          > > >
          >
          > > > > ';' I have no issues, except the cursor is on "n" in noticed. It does
          >
          > > >
          >
          > > > > work with the number modifier, but it would be better without using
          >
          > > >
          >
          > > > > them, and just tapping ';' to get there if I'm editing fast and don't
          >
          > > >
          >
          > > > > want to count characters. This is helpful when till-tapping over to
          >
          > > >
          >
          > > > > somewhere, then hitting 'v' for visual mode, then till-tapping over to
          >
          > > >
          >
          > > > > the end letter and using an operator for the selection. With Vim's
          >
          > > >
          >
          > > > > current behavior that is not possible, and although I understand it
          >
          > > >
          >
          > > > > would change something, I think it would change it in a way that it
          >
          > > >
          >
          > > > > would fix existing issues and not interrupt anyone's expectations of
          >
          > > >
          >
          > > > > how the program should behave, it would instead just make it behave it
          >
          > > >
          >
          > > > > a way that one would expect.
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > What is your vim version? I made a patch, that changes it. I think you
          >
          > > >
          >
          > > > need 7.3.235 to have this work.
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > > The idea of using n/N instead of ;/, is probably a little over the
          >
          > > >
          >
          > > > > top, but the above idea and making it multiline I think would hurt
          >
          > > >
          >
          > > > > anyone.
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > I made the ft_improved plugin to make f and t work multiline.
          >
          > > >
          >
          > > >
          >
          > > >
          >
          > > > regards,
          >
          > > >
          >
          > > > Christian
          >
          > > >
          >
          > > > --
          >
          > > >
          >
          > > > Die Ehe ist eine sehr gute Institution, aber ich bin nicht reif f�r
          >
          > > >
          >
          > > > eine Institution.
          >
          > > >
          >
          > > > -- Mae West
          >
          > >
          >
          > > I am experiences some issues using both plugins, ft_improved and fanfingtastic
          >
          > > for getting t/f commands to be multiline. I'm using version 7.3.829. For
          >
          > > example, on the following text below, if I put my cursor on the ["] and try t/f
          >
          > > on "o" it does nothing. However, if I try to get to g, it does jump. Other
          >
          > > times, if I use the t command it will put the cursor on top of the letter
          >
          > > itself. The behavior is very sporadic. It would be nice to have this fixed once
          >
          > > and for all to include an ability inside Vim itself to be maintained.
          >
          > >
          >
          > > " Main options.
          >
          > > :set nocompatible
          >
          > > :au GUIEnter * simalt ~x
          >
          > > :syntax on
          >
          > > :set backspace=2
          >
          > > :set number
          >
          > > :set guioptions-=T "disable toolbar
          >
          > > :set guioptions-=m "disable menu
          >
          > > :set mouse=a
          >
          >
          >
          > I can't reproduce it. Which version of ft_improved did you use?. (Make
          >
          > sure you tried with the github version).
          >
          >
          >
          > putting the cursor on the first char of line 1 and using fo or to puts
          >
          > it on the expected char.
          >
          >
          >
          > Here was my test. (your sample was put in the file testfile1.vim):
          >
          > vim -u NONE -U NONE -N -c 'so ~/.vim/plugin/ft_improved.vim' -c ':norm dto'
          >
          > -c 'wq'
          >
          >
          >
          > leaves you with this file:
          >
          >
          >
          > ----------------------------
          >
          > options.
          >
          > :set nocompatible
          >
          > :au GUIEnter * simalt ~x
          >
          > :syntax on
          >
          > :set backspace=2
          >
          > :set number
          >
          > :set guioptions-=T "disable toolbar
          >
          > :set guioptions-=m "disable menu
          >
          > :set mouse=a
          >
          > ----------------------------
          >
          >
          >
          > Is this what you expect?
          >
          >
          >
          > PS: You might want to open an issue at the github page for the plugin:
          >
          > https://github.com/chrisbra/improvedft
          >
          >
          >
          > so I can track it better.
          >
          >
          >
          > regards,
          >
          > Christian.
          >
          > --
          >
          > Jemand, der immer lustig ist, ist was Unertr�gliches.
          >
          > -- Loriot (eigentlich Vicco von B�low)

          I was using the version in vundle. That version doesn't work. I just tried the
          version in Github and it works fine. There is another listing for your plugin
          at https://github.com/vim-scripts/ft_improved also.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.