Loading ...
Sorry, an error occurred while loading the content.
 

Re: fix tests for DOS/Windows

Expand Messages
  • Bram Moolenaar
    ... When I ran all tests it did pass. Don t know what went wrong the first time. Well, at first the test50 target was missing. -- hundred-and-one symptoms
    Message 1 of 11 , Jun 20, 2013
      Dominique Pelle wrote:

      > Bram Moolenaar <Bram@...> wrote:
      > >
      > > Taro Muraoka wrote:
      > >
      > >> There are tests failed on DOS/Windows environment.
      > >> I have fixed two of them.
      > >> Please check attached patches.
      > >>
      > >>
      > >> test50: Short name seems depending on OS version.
      > >> On my Win7, "c:/x.x.y" has short name "c:/XX9B80~1.Y", it will not be matched.
      > >> So I made it flexible.
      > >>
      > >> test77: failed when "cksum" available (MinGW or Cygwin).
      > >
      > > Thanks. test50 fails on Unix though, I'll need to fix that.
      >
      > I'm not sure if cksum behaves like md5sum, but
      > for md5sum, it is necessary to use the -b flag (md5sum -b)
      > to have the same md5 on Windows and Linux
      > because by default, md5sum opens file in text mode
      > which can give different results on Windows and on
      > Linux. I don't see a -b option to cksum though in the
      > man page on Linux though.

      When I ran all tests it did pass. Don't know what went wrong the first
      time. Well, at first the "test50" target was missing.

      --
      hundred-and-one symptoms of being an internet addict:
      257. Your "hundred-and-one" lists include well over 101 items, since you
      automatically interpret all numbers in hexadecimal notation.
      (hex 101 = decimal 257)

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ken Takata
      Hi Bram, ... No, it doesn t solve the problem. When Vim loads test17.in, the binary part is already broken, because the default value of encoding is cp932 on
      Message 2 of 11 , Jul 1, 2013
        Hi Bram,

        2013/06/20 The 16:03:03 UTC+9 Bram Moolenaar wrote:
        > When running the tests reloading is not an option.
        >
        > Perhaps explicitly setting 'fenc' would work?

        No, it doesn't solve the problem. When Vim loads test17.in,
        the binary part is already broken, because the default value of
        'encoding' is cp932 on my Windows environment.
        To load the binary part properly:

        1. 'enc' should be set to latin1 or utf-8.
        2. After setting 'enc' properly, test17.in should be reloaded with
        'fenc=latin1'. (E.g. use ':e ++enc=latin1')

        If reloading is not allowed, the binary part should be a separate file.
        Here is a patch.

        Thanks,
        Ken Takata

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Bram Moolenaar
        ... Thanks. I suppose there is no other way than to use a separate file. We should use latin1 encoding so that it works without the multi_byte feature. --
        Message 3 of 11 , Jul 1, 2013
          Ken Takata wrote:

          > 2013/06/20 The 16:03:03 UTC+9 Bram Moolenaar wrote:
          > > When running the tests reloading is not an option.
          > >
          > > Perhaps explicitly setting 'fenc' would work?
          >
          > No, it doesn't solve the problem. When Vim loads test17.in,
          > the binary part is already broken, because the default value of
          > 'encoding' is cp932 on my Windows environment.
          > To load the binary part properly:
          >
          > 1. 'enc' should be set to latin1 or utf-8.
          > 2. After setting 'enc' properly, test17.in should be reloaded with
          > 'fenc=latin1'. (E.g. use ':e ++enc=latin1')
          >
          > If reloading is not allowed, the binary part should be a separate file.
          > Here is a patch.

          Thanks. I suppose there is no other way than to use a separate file.

          We should use "latin1" encoding so that it works without the multi_byte
          feature.

          --
          With sufficient thrust, pigs fly just fine.
          -- RFC 1925

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.