Loading ...
Sorry, an error occurred while loading the content.

Re: How to make the related python library dynamicly loaded CORRECTLY when compiling vim?

Expand Messages
  • Nikolay Pavlov
    ... But I get the E370:Could not load library libpython2.7.a when I compile vim against self compiled python versions. ... versions before I compile vim.
    Message 1 of 6 , Jun 14, 2013
    • 0 Attachment


      On Jun 14, 2013 10:00 AM, "Bohr Shaw" <bohrshaw@...> wrote:
      >
      > On Friday, June 14, 2013 11:52:23 AM UTC+8, ZyX wrote:
      > > On Jun 14, 2013 7:41 AM, "Bohr Shaw" <bohr...@...> wrote:
      > >
      > > >
      > >
      > > > I compile vim against two system python versions without any problem. But I get the "E370:Could not load library libpython2.7.a" when I compile vim against self compiled python versions.
      > >
      > > >
      > >
      > > > I just change my environment path to point to the correct python versions before I compile vim. Although I compiled without errors but I doubt if I missing anything important?
      > >
      > > >
      > >
      > > > Thanks for helping me! My English is limited.
      > >
      > > You need shared library, not .a file. AFAIR there is either --enable-shared or --with-shared ./configure python argument.
      > >
      > > > --
      > >
      > > > --
      > >
      > > > You received this message from the "vim_dev" maillist.
      > >
      > > > Do not top-post! Type your reply below the text you are replying to.
      > >
      > > > For more information, visit http://www.vim.org/maillist.php
      > >
      > > >
      > >
      > > > ---
      > >
      > > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
      > >
      > > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
      > >
      > > > For more options, visit https://groups.google.com/groups/opt_out.
      > >
      > > >
      > >
      > > >
      >
      > I tried --enable-shared or --with-shared with ./configure, but I get a warning these options are unrecognised.

      Check out ./configure --help. There should be similar option.

      > --
      > --
      > You received this message from the "vim_dev" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >
      > ---
      > You received this message because you are subscribed to the Google Groups "vim_dev" group.
      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      > For more options, visit https://groups.google.com/groups/opt_out.
      >
      >

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Kirill Igumenshchev
      I spent few days on this and would really really like some help too. Read a bunch on inet. I use scientific linux 6.4, which is based on centos 6.4. I install
      Message 2 of 6 , Jun 25, 2013
      • 0 Attachment
        I spent few days on this and would really really like some help too. Read a bunch on inet. I use scientific linux 6.4, which is based on centos 6.4. I install everything using environment-modules so that I can use the same configuration on clusters.

        I compiled python 2.7.5 and 3.3.2 with --enable-shared. for python 2, i had to modify makefile and add -fPIC option.

        trying" ":py print 1", i get:
        E448: Could not load library function _PyArg_Parse_SizeT
        E263: Sorry, this command is disabled, the Python library could not be loaded.

        before recompiling python with --enable-shared, I had the error:
        E370: Could not load library libpython2.7.a
        E263: Sorry, this command is disabled, the Python library could not be loaded.

        Thank you!



        On Friday, 14 June 2013 01:38:16 UTC-7, ZyX wrote:
        > On Jun 14, 2013 10:00 AM, "Bohr Shaw" <bohr...@...> wrote:
        >
        > >
        >
        > > On Friday, June 14, 2013 11:52:23 AM UTC+8, ZyX wrote:
        >
        > > > On Jun 14, 2013 7:41 AM, "Bohr Shaw" <bohr...@...> wrote:
        >
        > > >
        >
        > > > >
        >
        > > >
        >
        > > > > I compile vim against two system python versions without any problem. But I get the "E370:Could not load library libpython2.7.a" when I compile vim against self compiled python versions.
        >
        > > >
        >
        > > > >
        >
        > > >
        >
        > > > > I just change my environment path to point to the correct python versions before I compile vim. Although I compiled without errors but I doubt if I missing anything important?
        >
        > > >
        >
        > > > >
        >
        > > >
        >
        > > > > Thanks for helping me! My English is limited.
        >
        > > >
        >
        > > > You need shared library, not .a file. AFAIR there is either --enable-shared or --with-shared ./configure python argument.
        >
        > > >
        >
        > > > > --
        >
        > > >
        >
        > > > > --
        >
        > > >
        >
        > > > > You received this message from the "vim_dev" maillist.
        >
        > > >
        >
        > > > > Do not top-post! Type your reply below the text you are replying to.
        >
        > > >
        >
        > > > > For more information, visit http://www.vim.org/maillist.php
        >
        > > >
        >
        > > > >
        >
        > > >
        >
        > > > > ---
        >
        > > >
        >
        > > > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
        >
        > > >
        >
        > > > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
        >
        > > >
        >
        > > > > For more options, visit https://groups.google.com/groups/opt_out.
        >
        > > >
        >
        > > > >
        >
        > > >
        >
        > > > >
        >
        > >
        >
        > > I tried --enable-shared or --with-shared with ./configure, but I get a warning these options are unrecognised.
        >
        > Check out ./configure --help. There should be similar option.
        >
        > > --
        >
        > > --
        >
        > > You received this message from the "vim_dev" maillist.
        >
        > > Do not top-post! Type your reply below the text you are replying to.
        >
        > > For more information, visit http://www.vim.org/maillist.php
        >
        > >
        >
        > > ---
        >
        > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
        >
        > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
        >
        > > For more options, visit https://groups.google.com/groups/opt_out.
        >
        > >
        >
        > >

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Kirill Igumenshchev
        I also tried installing vim-7.3.tar.bz2 rather then svn version. python 2.7.5 worked but :py print 1 gave segmentation fault. python plugins (ATP LAtex)
        Message 3 of 6 , Jun 25, 2013
        • 0 Attachment
          I also tried installing vim-7.3.tar.bz2 rather then svn version.

          python 2.7.5 worked but ":py print 1" gave segmentation fault. python plugins (ATP LAtex) worked though.


          On Friday, 14 June 2013 01:38:16 UTC-7, ZyX wrote:
          > On Jun 14, 2013 10:00 AM, "Bohr Shaw" <bohr...@...> wrote:
          >
          > >
          >
          > > On Friday, June 14, 2013 11:52:23 AM UTC+8, ZyX wrote:
          >
          > > > On Jun 14, 2013 7:41 AM, "Bohr Shaw" <bohr...@...> wrote:
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > > I compile vim against two system python versions without any problem. But I get the "E370:Could not load library libpython2.7.a" when I compile vim against self compiled python versions.
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > > I just change my environment path to point to the correct python versions before I compile vim. Although I compiled without errors but I doubt if I missing anything important?
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > > Thanks for helping me! My English is limited.
          >
          > > >
          >
          > > > You need shared library, not .a file. AFAIR there is either --enable-shared or --with-shared ./configure python argument.
          >
          > > >
          >
          > > > > --
          >
          > > >
          >
          > > > > --
          >
          > > >
          >
          > > > > You received this message from the "vim_dev" maillist.
          >
          > > >
          >
          > > > > Do not top-post! Type your reply below the text you are replying to.
          >
          > > >
          >
          > > > > For more information, visit http://www.vim.org/maillist.php
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > > ---
          >
          > > >
          >
          > > > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
          >
          > > >
          >
          > > > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
          >
          > > >
          >
          > > > > For more options, visit https://groups.google.com/groups/opt_out.
          >
          > > >
          >
          > > > >
          >
          > > >
          >
          > > > >
          >
          > >
          >
          > > I tried --enable-shared or --with-shared with ./configure, but I get a warning these options are unrecognised.
          >
          > Check out ./configure --help. There should be similar option.
          >
          > > --
          >
          > > --
          >
          > > You received this message from the "vim_dev" maillist.
          >
          > > Do not top-post! Type your reply below the text you are replying to.
          >
          > > For more information, visit http://www.vim.org/maillist.php
          >
          > >
          >
          > > ---
          >
          > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
          >
          > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
          >
          > > For more options, visit https://groups.google.com/groups/opt_out.
          >
          > >
          >
          > >

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.