Loading ...
Sorry, an error occurred while loading the content.

[patch] minor bug fix for gui_x11.c

Expand Messages
  • Kazunobu Kuriyama
    Hi, While configuring guifontset to have gvim work on my MacBook, I got the error message shown below (the content of the message itself is irrelevant to the
    Message 1 of 2 , Jun 13, 2013
    • 0 Attachment
      Hi,

      While configuring guifontset to have gvim work on my MacBook, I got the error message shown below (the content of the message itself is irrelevant to the bug I want to point out here, so you don't need to figure out what it says):

      E253: Fontset name: -bitstream-menlo-medium-r-normal--12-*-*-*-m-*-iso10646-1,-ricoh-ms gothic-medium-r-normal--15-0-0-0-p-0-iso10646-1,-ricoh-ms gothic-medium-r-normal--15-0-0-0-p-0-jisx0206.1983-0,-ricoh-ms gothic-medium-r-normal--15-0-0-0-p-0-jisx0201.1976-0^@
      Font0: -bitstream-menlo-medium-r-normal--12-87-100-100-m-0-iso8859-1^@
      Font1: -ricoh-ms gothic-medium-r-normal--15-0-0-0-p-0-jisx0208.1983-0^@
      Font1 width is not twice that of font0^@
      Font0 width: 7^@
      Font1 width: 15^@^@

      If you take a look at each end of the lines of the message, you see a ^@ or ^@'s (That's why I call them minor :-). The attached patch fixes it by removing redundant \n's in gui_x11.c so that the length of the message strings will be calculated correctly.

      Regards,
      KK

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Thanks, I ll include it. -- A computer program does what you tell it to do, not what you want it to do. /// Bram Moolenaar -- Bram@Moolenaar.net --
      Message 2 of 2 , Jun 13, 2013
      • 0 Attachment
        Kazunobu Kuriyama wrote:

        > While configuring guifontset to have gvim work on my MacBook, I got
        > the error message shown below (the content of the message itself is
        > irrelevant to the bug I want to point out here, so you don't need to
        > figure out what it says):
        >
        > E253: Fontset name:
        > -bitstream-menlo-medium-r-normal--12-*-*-*-m-*-iso10646-1,-ricoh-ms
        > gothic-medium-r-normal--15-0-0-0-p-0-iso10646-1,-ricoh-ms
        > gothic-medium-r-normal--15-0-0-0-p-0-jisx0206.1983-0,-ricoh-ms
        > gothic-medium-r-normal--15-0-0-0-p-0-jisx0201.1976-0^@
        > Font0: -bitstream-menlo-medium-r-normal--12-87-100-100-m-0-iso8859-1^@
        > Font1: -ricoh-ms gothic-medium-r-normal--15-0-0-0-p-0-jisx0208.1983-0^@
        > Font1 width is not twice that of font0^@
        > Font0 width: 7^@
        > Font1 width: 15^@^@
        >
        > If you take a look at each end of the lines of the message, you see a
        > ^@ or ^@'s (That's why I call them minor :-). The attached patch
        > fixes it by removing redundant \n's in gui_x11.c so that the length of
        > the message strings will be calculated correctly.

        Thanks, I'll include it.

        --
        A computer program does what you tell it to do, not what you want it to do.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.