Loading ...
Sorry, an error occurred while loading the content.

Re: Issue 141 in vim:

Expand Messages
  • Zulox4
    ... On Linux, I tested with two different keyboard settings, french and english and it works well; but not on Windows, it works only with english keyboard.
    Message 1 of 11 , Jun 12, 2013
    • 0 Attachment
      On Wednesday, June 12, 2013 12:33:23 PM UTC+2, Bram Moolenaar wrote:
      > Yasuhiro Matsumoto wrote:
      >
      >
      >
      > > On Wednesday, June 12, 2013 10:48:42 AM UTC+9, mattn wrote:
      >
      > > > On Wednesday, June 12, 2013 12:11:35 AM UTC+9, Ben Fritz wrote:
      >
      > > > > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
      >
      > > > > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
      >
      > > > > > > Status: New
      >
      > > > > > > Owner: ----
      >
      > > > > > > Labels: Type-Defect Priority-Medium
      >
      > > > > > > New issue 141 by Zulolox4...@...: <C-@>
      >
      > > > > > > http://code.google.com/p/vim/issues/detail?id=141
      >
      > > > > > I could handle CTRL-@ with following patch.
      >
      > > > >
      >
      > > > > > https://gist.github.com/mattn/5755848
      >
      > > > >
      >
      > > > > > I found that some keys doesn't handle correctly at os_win32.c:796 .
      >
      > > > >
      >
      > > > > > Ctrl-6 fire Ctrl-^
      >
      > > > > > Ctrl-2 fire Ctrl-@
      >
      > > > > > Ctrl-- fire Ctrl-_
      >
      > > > > > I don't know why this code is needed. My patch can handle all keys above.
      >
      > > > > CTRL-6 at least is probably intentional:
      >
      > > > > Possibly the others have similar reasons to exist.
      >
      > > > Ok, I'll fix code that treat the keys both.
      >
      > >
      >
      > > https://gist.github.com/5762321
      >
      >
      >
      > The codes would depend on the keyboard layout. Since it's only one
      >
      > byte, I suspect that the 0xDE, 0xC0 and 0xE2 codes are on different keys
      >
      > on other keyboards. Thus this will break it for some people.
      >
      >
      >
      > --
      >
      > hundred-and-one symptoms of being an internet addict:
      >
      > 160. You get in the elevator and double-click the button for the floor
      >
      > you want.
      >
      >
      >
      > /// Bram Moolenaar -- Bram. -- http://www.Moolenaar.net \\\
      >
      > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      >
      > \\\ an exciting new programming language -- http://www.Zimbu.org ///
      >
      > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      On Linux, I tested with two different keyboard settings, french and english and it works well; but not on Windows, it works only with english keyboard.
      How could assign the good codes 0xDE, 0xC0 and 0xE2 to the good key for different keyboard layout ?

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 141 by HoweJ...@gmail.com: http://code.google.com/p/vim/issues/detail?id=141 Have you gotten it to work in other programs in the
      Message 2 of 11 , Mar 6, 2014
      • 0 Attachment
        Comment #1 on issue 141 by HoweJ...@...: <C-@>
        http://code.google.com/p/vim/issues/detail?id=141

        Have you gotten it to work in other programs in the terminal? ^@ actually
        maps to the null character in Unix (see
        http://www.unix-manuals.com/refs/misc/ascii-table.html), so if you're using
        Cygwin this is in fact the expected behavior. I'm not sure about the
        Windows command line though. Have you tried using gvim?

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Comment #2 on issue 141 by Zulolox4...@gmail.com: http://code.google.com/p/vim/issues/detail?id=141 Thanks ! I found the probleme, it doesn t work when
        Message 3 of 11 , Mar 9, 2014
        • 0 Attachment
          Comment #2 on issue 141 by Zulolox4...@...: <C-@>
          http://code.google.com/p/vim/issues/detail?id=141

          Thanks !
          I found the probleme, it doesn't work when using a keyboard not US. On a
          french keyboard for Ctrl-@ vim keystroke The Ctrl and 2 keys combination it
          works !
          Best regards !

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • vim@...
          Updates: Status: Invalid Comment #3 on issue 141 by chrisbr...@googlemail.com: https://code.google.com/p/vim/issues/detail?id=141 (No comment was entered
          Message 4 of 11 , Sep 30 1:35 PM
          • 0 Attachment
            Updates:
            Status: Invalid

            Comment #3 on issue 141 by chrisbr...@...: <C-@>
            https://code.google.com/p/vim/issues/detail?id=141

            (No comment was entered for this change.)

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.