Loading ...
Sorry, an error occurred while loading the content.

Issue 141 in vim:

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 141 by Zulolox4...@gmail.com: http://code.google.com/p/vim/issues/detail?id=141
    Message 1 of 11 , Jun 10, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 141 by Zulolox4...@...: <C-@>
      http://code.google.com/p/vim/issues/detail?id=141

      What steps will reproduce the problem?
      1. Ctrl-@ doesn't work on Windows version

      What do you see instead?
      In insert mode I see only @ character.
      In normal mode I see only @ character on status bar
      it should display ^@ .

      What version of the product are you using? On what operating system?
      MS-Windows 32-bit console version
      Included patches: 1-1163
      Compiled by Vim7-Win32-PC
      Huge version without GUI. Features included (+) or not (-):
      +arabic +ex_extra -mouseshape +tag_binary
      +autocmd +extra_search +multi_byte +tag_old_static
      -balloon_eval +farsi +multi_lang -tag_any_white
      -browse +file_in_path -mzscheme -tcl
      ++builtin_terms +find_in_path -netbeans_intg -tgetent
      +byte_offset +float +path_extra -termresponse
      +cindent +folding -perl +textobjects
      +clientserver -footer +persistent_undo +title
      +clipboard -gettext -postscript -toolbar
      +cmdline_compl -hangul_input +printer +user_commands
      +cmdline_hist +iconv/dyn +profile +vertsplit
      +cmdline_info +insert_expand -python +virtualedit
      +comments +jumplist -python3 +visual
      +conceal +keymap +quickfix +visualextra
      +cryptv +langmap +reltime +viminfo
      +cscope +libcall +rightleft +vreplace
      +cursorbind +linebreak -ruby +wildignore
      +cursorshape +lispindent +scrollbind +wildmenu
      +dialog_con +listcmds +signs +windows
      +diff +localmap +smartindent +writebackup
      +digraphs -lua -sniff -xfontset
      -dnd +menu +startuptime -xim
      -ebcdic +mksession +statusline -xterm_save
      +emacs_tags +modify_fname -sun_workshop -xpm_w32
      +eval +mouse +syntax
      system vimrc file: "$VIM\vimrc"
      user vimrc file: "$HOME\_vimrc"
      2nd user vimrc file: "$VIM\_vimrc"
      user exrc file: "$HOME\_exrc"
      2nd user exrc file: "$VIM\_exrc"
      Compilation: cl -c /W3 /nologo -I. -Iproto -DHAVE_PATHDEF -DWIN32
      -DFEAT_CSCO
      PE -DWINVER=0x0400 -D_WIN32_WINNT=0x0400 /Fo.\ObjCi386/ /Ox /GL
      -DNDEBUG
      /Zl /MT -DDYNAMIC_ICONV -DFEAT_HUGE /Fd.\ObjCi386/ /Zi
      Linking: link /RELEASE /nologo /subsystem:console /map /mapinfo:lines
      /LTCG:STAT
      US oldnames.lib kernel32.lib advapi32.lib shell32.lib gdi32.lib
      comdlg32.lib ol
      e32.lib uuid.lib /machine:i386 /nodefaultlib libcmt.lib user32.lib
      /PDB:vim.pdb -debug
      Please provide any additional information below.


      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • mattn
      ... I could handle CTRL-@ with following patch. https://gist.github.com/mattn/5755848 I found that some keys doesn t handle correctly at os_win32.c:796 .
      Message 2 of 11 , Jun 11, 2013
      • 0 Attachment
        On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
        > Status: New
        > Owner: ----
        > Labels: Type-Defect Priority-Medium
        > New issue 141 by Zulolox4...@...: <C-@>
        >
        > http://code.google.com/p/vim/issues/detail?id=141

        I could handle CTRL-@ with following patch.

        https://gist.github.com/mattn/5755848

        I found that some keys doesn't handle correctly at os_win32.c:796 .

        Ctrl-6 fire Ctrl-^
        Ctrl-2 fire Ctrl-@
        Ctrl-- fire Ctrl-_

        I don't know why this code is needed. My patch can handle all keys above.

        Anyone, do you know why this is left-field code?

        - Yasuhiro Matsumoto

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... CTRL-6 at least is probably intentional: *CTRL-^* *CTRL-6* CTRL-^ Edit the alternate file. Mostly the alternate file is the previously edited file.
        Message 3 of 11 , Jun 11, 2013
        • 0 Attachment
          On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
          > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
          > > Status: New
          > > Owner: ----
          > > Labels: Type-Defect Priority-Medium
          > > New issue 141 by Zulolox4...@...: <C-@>
          > >
          > > http://code.google.com/p/vim/issues/detail?id=141
          >
          > I could handle CTRL-@ with following patch.
          >
          > https://gist.github.com/mattn/5755848
          >
          > I found that some keys doesn't handle correctly at os_win32.c:796 .
          >
          > Ctrl-6 fire Ctrl-^
          > Ctrl-2 fire Ctrl-@
          > Ctrl-- fire Ctrl-_
          >
          > I don't know why this code is needed. My patch can handle all keys above.
          >

          CTRL-6 at least is probably intentional:

          *CTRL-^* *CTRL-6*
          CTRL-^ Edit the alternate file. Mostly the alternate file is
          the previously edited file. This is a quick way to
          toggle between two files. It is equivalent to ":e #",
          except that it also works when there is no file name.

          If the 'autowrite' or 'autowriteall' option is on and
          the buffer was changed, write it.
          Mostly the ^ character is positioned on the 6 key,
          pressing CTRL and 6 then gets you what we call CTRL-^.
          But on some non-US keyboards CTRL-^ is produced in
          another way.

          Possibly the others have similar reasons to exist.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • mattn
          ... Ok, I ll fix code that treat the keys both. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text
          Message 4 of 11 , Jun 11, 2013
          • 0 Attachment
            On Wednesday, June 12, 2013 12:11:35 AM UTC+9, Ben Fritz wrote:
            > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
            > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
            > > > Status: New
            > > > Owner: ----
            > > > Labels: Type-Defect Priority-Medium
            > > > New issue 141 by Zulolox4...@...: <C-@>
            > > > http://code.google.com/p/vim/issues/detail?id=141
            > > I could handle CTRL-@ with following patch.
            >
            > > https://gist.github.com/mattn/5755848
            >
            > > I found that some keys doesn't handle correctly at os_win32.c:796 .
            >
            > > Ctrl-6 fire Ctrl-^
            > > Ctrl-2 fire Ctrl-@
            > > Ctrl-- fire Ctrl-_
            >
            > > I don't know why this code is needed. My patch can handle all keys above.
            >
            > CTRL-6 at least is probably intentional:
            >
            > Possibly the others have similar reasons to exist.

            Ok, I'll fix code that treat the keys both.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • mattn
            ... https://gist.github.com/5762321 Done -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
            Message 5 of 11 , Jun 11, 2013
            • 0 Attachment
              On Wednesday, June 12, 2013 10:48:42 AM UTC+9, mattn wrote:
              > On Wednesday, June 12, 2013 12:11:35 AM UTC+9, Ben Fritz wrote:
              > > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
              > > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
              > > > > Status: New
              > > > > Owner: ----
              > > > > Labels: Type-Defect Priority-Medium
              > > > > New issue 141 by Zulolox4...@...: <C-@>
              > > > > http://code.google.com/p/vim/issues/detail?id=141
              > > > I could handle CTRL-@ with following patch.
              > >
              > > > https://gist.github.com/mattn/5755848
              > >
              > > > I found that some keys doesn't handle correctly at os_win32.c:796 .
              > >
              > > > Ctrl-6 fire Ctrl-^
              > > > Ctrl-2 fire Ctrl-@
              > > > Ctrl-- fire Ctrl-_
              > > > I don't know why this code is needed. My patch can handle all keys above.
              > > CTRL-6 at least is probably intentional:
              > > Possibly the others have similar reasons to exist.
              > Ok, I'll fix code that treat the keys both.

              https://gist.github.com/5762321

              Done

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Zulox4
              ... Hello I tested the patch from github, using the link, it doesn t work for vim console win32 version. But Ctrl-2 combination it work. For a French keyboard
              Message 6 of 11 , Jun 11, 2013
              • 0 Attachment
                On Tuesday, June 11, 2013 5:11:35 PM UTC+2, Ben Fritz wrote:
                > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
                >
                > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
                >
                > > > Status: New
                >
                > > > Owner: ----
                >
                > > > Labels: Type-Defect Priority-Medium
                >
                > > > New issue 141 by Zulolox4...@...: <C-@>
                >
                > > >
                >
                > > > http://code.google.com/p/vim/issues/detail?id=141
                >
                > >
                >
                > > I could handle CTRL-@ with following patch.
                >
                > >
                >
                > > https://gist.github.com/mattn/5755848
                >
                > >
                >
                > > I found that some keys doesn't handle correctly at os_win32.c:796 .
                >
                > >
                >
                > > Ctrl-6 fire Ctrl-^
                >
                > > Ctrl-2 fire Ctrl-@
                >
                > > Ctrl-- fire Ctrl-_
                >
                > >
                >
                > > I don't know why this code is needed. My patch can handle all keys above.
                >
                > >
                >
                >
                >
                > CTRL-6 at least is probably intentional:
                >
                >
                >
                > *CTRL-^* *CTRL-6*
                >
                > CTRL-^ Edit the alternate file. Mostly the alternate file is
                >
                > the previously edited file. This is a quick way to
                >
                > toggle between two files. It is equivalent to ":e #",
                >
                > except that it also works when there is no file name.
                >
                >
                >
                > If the 'autowrite' or 'autowriteall' option is on and
                >
                > the buffer was changed, write it.
                >
                > Mostly the ^ character is positioned on the 6 key,
                >
                > pressing CTRL and 6 then gets you what we call CTRL-^.
                >
                > But on some non-US keyboards CTRL-^ is produced in
                >
                > another way.
                >
                >
                >
                > Possibly the others have similar reasons to exist.

                Hello
                I tested the patch from github, using the link, it doesn't work for vim console win32 version.
                But Ctrl-2 combination it work.
                For a French keyboard Ctrl-2 combination doesn't work, because the keystroke 2 give é, (Shift-2 combination give 2), and Ctrl-Shift-2 doesn't work. But when using Caps-Lock on, Ctrl-2 work and send Ctrl-@. For information, on a french keyboard, @ key is obtained from combination of Alt GR(Alt key on the Right) and 0 key.
                Best regards !

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Bram Moolenaar
                ... The codes would depend on the keyboard layout. Since it s only one byte, I suspect that the 0xDE, 0xC0 and 0xE2 codes are on different keys on other
                Message 7 of 11 , Jun 12, 2013
                • 0 Attachment
                  Yasuhiro Matsumoto wrote:

                  > On Wednesday, June 12, 2013 10:48:42 AM UTC+9, mattn wrote:
                  > > On Wednesday, June 12, 2013 12:11:35 AM UTC+9, Ben Fritz wrote:
                  > > > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
                  > > > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
                  > > > > > Status: New
                  > > > > > Owner: ----
                  > > > > > Labels: Type-Defect Priority-Medium
                  > > > > > New issue 141 by Zulolox4...@...: <C-@>
                  > > > > > http://code.google.com/p/vim/issues/detail?id=141
                  > > > > I could handle CTRL-@ with following patch.
                  > > >
                  > > > > https://gist.github.com/mattn/5755848
                  > > >
                  > > > > I found that some keys doesn't handle correctly at os_win32.c:796 .
                  > > >
                  > > > > Ctrl-6 fire Ctrl-^
                  > > > > Ctrl-2 fire Ctrl-@
                  > > > > Ctrl-- fire Ctrl-_
                  > > > > I don't know why this code is needed. My patch can handle all keys above.
                  > > > CTRL-6 at least is probably intentional:
                  > > > Possibly the others have similar reasons to exist.
                  > > Ok, I'll fix code that treat the keys both.
                  >
                  > https://gist.github.com/5762321

                  The codes would depend on the keyboard layout. Since it's only one
                  byte, I suspect that the 0xDE, 0xC0 and 0xE2 codes are on different keys
                  on other keyboards. Thus this will break it for some people.

                  --
                  hundred-and-one symptoms of being an internet addict:
                  160. You get in the elevator and double-click the button for the floor
                  you want.

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Zulox4
                  ... On Linux, I tested with two different keyboard settings, french and english and it works well; but not on Windows, it works only with english keyboard.
                  Message 8 of 11 , Jun 12, 2013
                  • 0 Attachment
                    On Wednesday, June 12, 2013 12:33:23 PM UTC+2, Bram Moolenaar wrote:
                    > Yasuhiro Matsumoto wrote:
                    >
                    >
                    >
                    > > On Wednesday, June 12, 2013 10:48:42 AM UTC+9, mattn wrote:
                    >
                    > > > On Wednesday, June 12, 2013 12:11:35 AM UTC+9, Ben Fritz wrote:
                    >
                    > > > > On Tuesday, June 11, 2013 5:25:42 AM UTC-5, mattn wrote:
                    >
                    > > > > > On Tuesday, June 11, 2013 1:33:45 PM UTC+9, v...@... wrote:
                    >
                    > > > > > > Status: New
                    >
                    > > > > > > Owner: ----
                    >
                    > > > > > > Labels: Type-Defect Priority-Medium
                    >
                    > > > > > > New issue 141 by Zulolox4...@...: <C-@>
                    >
                    > > > > > > http://code.google.com/p/vim/issues/detail?id=141
                    >
                    > > > > > I could handle CTRL-@ with following patch.
                    >
                    > > > >
                    >
                    > > > > > https://gist.github.com/mattn/5755848
                    >
                    > > > >
                    >
                    > > > > > I found that some keys doesn't handle correctly at os_win32.c:796 .
                    >
                    > > > >
                    >
                    > > > > > Ctrl-6 fire Ctrl-^
                    >
                    > > > > > Ctrl-2 fire Ctrl-@
                    >
                    > > > > > Ctrl-- fire Ctrl-_
                    >
                    > > > > > I don't know why this code is needed. My patch can handle all keys above.
                    >
                    > > > > CTRL-6 at least is probably intentional:
                    >
                    > > > > Possibly the others have similar reasons to exist.
                    >
                    > > > Ok, I'll fix code that treat the keys both.
                    >
                    > >
                    >
                    > > https://gist.github.com/5762321
                    >
                    >
                    >
                    > The codes would depend on the keyboard layout. Since it's only one
                    >
                    > byte, I suspect that the 0xDE, 0xC0 and 0xE2 codes are on different keys
                    >
                    > on other keyboards. Thus this will break it for some people.
                    >
                    >
                    >
                    > --
                    >
                    > hundred-and-one symptoms of being an internet addict:
                    >
                    > 160. You get in the elevator and double-click the button for the floor
                    >
                    > you want.
                    >
                    >
                    >
                    > /// Bram Moolenaar -- Bram. -- http://www.Moolenaar.net \\\
                    >
                    > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                    >
                    > \\\ an exciting new programming language -- http://www.Zimbu.org ///
                    >
                    > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                    On Linux, I tested with two different keyboard settings, french and english and it works well; but not on Windows, it works only with english keyboard.
                    How could assign the good codes 0xDE, 0xC0 and 0xE2 to the good key for different keyboard layout ?

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • vim@...
                    Comment #1 on issue 141 by HoweJ...@gmail.com: http://code.google.com/p/vim/issues/detail?id=141 Have you gotten it to work in other programs in the
                    Message 9 of 11 , Mar 6, 2014
                    • 0 Attachment
                      Comment #1 on issue 141 by HoweJ...@...: <C-@>
                      http://code.google.com/p/vim/issues/detail?id=141

                      Have you gotten it to work in other programs in the terminal? ^@ actually
                      maps to the null character in Unix (see
                      http://www.unix-manuals.com/refs/misc/ascii-table.html), so if you're using
                      Cygwin this is in fact the expected behavior. I'm not sure about the
                      Windows command line though. Have you tried using gvim?

                      --
                      You received this message because this project is configured to send all
                      issue notifications to this address.
                      You may adjust your notification preferences at:
                      https://code.google.com/hosting/settings

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • vim@...
                      Comment #2 on issue 141 by Zulolox4...@gmail.com: http://code.google.com/p/vim/issues/detail?id=141 Thanks ! I found the probleme, it doesn t work when
                      Message 10 of 11 , Mar 9, 2014
                      • 0 Attachment
                        Comment #2 on issue 141 by Zulolox4...@...: <C-@>
                        http://code.google.com/p/vim/issues/detail?id=141

                        Thanks !
                        I found the probleme, it doesn't work when using a keyboard not US. On a
                        french keyboard for Ctrl-@ vim keystroke The Ctrl and 2 keys combination it
                        works !
                        Best regards !

                        --
                        You received this message because this project is configured to send all
                        issue notifications to this address.
                        You may adjust your notification preferences at:
                        https://code.google.com/hosting/settings

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      • vim@...
                        Updates: Status: Invalid Comment #3 on issue 141 by chrisbr...@googlemail.com: https://code.google.com/p/vim/issues/detail?id=141 (No comment was entered
                        Message 11 of 11 , Sep 30, 2014
                        • 0 Attachment
                          Updates:
                          Status: Invalid

                          Comment #3 on issue 141 by chrisbr...@...: <C-@>
                          https://code.google.com/p/vim/issues/detail?id=141

                          (No comment was entered for this change.)

                          --
                          You received this message because this project is configured to send all
                          issue notifications to this address.
                          You may adjust your notification preferences at:
                          https://code.google.com/hosting/settings

                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/d/optout.
                        Your message has been successfully submitted and would be delivered to recipients shortly.