Loading ...
Sorry, an error occurred while loading the content.

[RFC] Revision of Objective-C Syntax

Expand Messages
  • Kazunobu Kuriyama
    Hi, I m the maintainer of the Objective-C syntax file, syntax/objc.vim. As the new features that have been added to the language for years appear to become
    Message 1 of 15 , Jun 4, 2013
    • 0 Attachment
      Hi,

      I'm the maintainer of the Objective-C syntax file, syntax/objc.vim. As the new features that have been added to the language for years appear to become stable and have passed the point of no return (really?), I'm now thinking of revising the syntax file completely for the sake of the "Modern" Objective-C, featuring declared properties, fast enumeration, blocks, literal syntax, ARC, and some stuff around them.

      Attached is a draft for a new version. I would appreciate to it if some of you would kindly review it and give me some feedback to brush it up.

      With best regards,
      KK

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Wellenbrock
      ... I just tried opening an Objective-C file with your syntax file and got the following errors: AdjustIo.h 81L, 2743C Error detected while processing
      Message 2 of 15 , Jun 4, 2013
      • 0 Attachment
        On Tuesday, June 4, 2013 3:12:20 PM UTC+2, Kazunobu Kuriyama wrote:
        > Hi,
        >
        >
        >
        > I'm the maintainer of the Objective-C syntax file, syntax/objc.vim. As the new features that have been added to the language for years appear to become stable and have passed the point of no return (really?), I'm now thinking of revising the syntax file completely for the sake of the "Modern" Objective-C, featuring declared properties, fast enumeration, blocks, literal syntax, ARC, and some stuff around them.
        >
        >
        >
        > Attached is a draft for a new version. I would appreciate to it if some of you would kindly review it and give me some feedback to brush it up.
        >
        >
        >
        > With best regards,
        >
        > KK

        I just tried opening an Objective-C file with your syntax file and got the following errors:

        "AdjustIo.h" 81L, 2743C
        Error detected while processing /usr/share/vim/vim73/syntax/objc.vim:
        line 6:
        E492: Not an editor command: ^M
        line 8:
        E15: Invalid expression: exists("b:current_syntax")^M
        line 107:
        E488: Trailing characters
        line 110:
        E171: Missing :endif
        Press ENTER or type command to continue

        What am I doing wrong?

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • ZyX ZyX
        On Jun 4, 2013 5:34 PM, Christian Wellenbrock
        Message 3 of 15 , Jun 4, 2013
        • 0 Attachment


          On Jun 4, 2013 5:34 PM, "Christian Wellenbrock" <christian.wellenbrock@...> wrote:
          >
          > On Tuesday, June 4, 2013 3:12:20 PM UTC+2, Kazunobu Kuriyama wrote:
          > > Hi,
          > >
          > >
          > >
          > > I'm the maintainer of the Objective-C syntax file, syntax/objc.vim.  As the new features that have been added to the language for years appear to become stable and have passed the point of no return (really?), I'm now thinking of revising the syntax file completely for the sake of the "Modern" Objective-C, featuring declared properties, fast enumeration, blocks, literal syntax, ARC, and some stuff around them.
          > >
          > >
          > >
          > > Attached is a draft for a new version.  I would appreciate to it if some of you would kindly review it and give me some feedback to brush it up.
          > >
          > >
          > >
          > > With best regards,
          > >
          > > KK
          >
          > I just tried opening an Objective-C file with your syntax file and got the following errors:
          >
          > "AdjustIo.h" 81L, 2743C
          > Error detected while processing /usr/share/vim/vim73/syntax/objc.vim:
          > line    6:
          > E492: Not an editor command: ^M
          > line    8:
          > E15: Invalid expression: exists("b:current_syntax")^M
          > line  107:
          > E488: Trailing characters
          > line  110:
          > E171: Missing :endif
          > Press ENTER or type command to continue
          >
          > What am I doing wrong?

          You are trying to open file with CRLF (Windows) line endings on *nix (linux or Mac OS). It is not you, but sender who is doing wrong.

          > --
          > --
          > You received this message from the "vim_dev" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to the Google Groups "vim_dev" group.
          > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          > For more options, visit https://groups.google.com/groups/opt_out.
          >
          >

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • David Fishburn
          ... You can quickly work around this issue by opening the objc.vim in Vim. Anytime files are sent to Bram for inclusion they should be using the Unix
          Message 4 of 15 , Jun 4, 2013
          • 0 Attachment
            ...>

            > "AdjustIo.h" 81L, 2743C
            > Error detected while processing /usr/share/vim/vim73/syntax/objc.vim:
            > line    6:
            > E492: Not an editor command: ^M
            > line    8:
            > E15: Invalid expression: exists("b:current_syntax")^M
            > line  107:
            > E488: Trailing characters
            > line  110:
            > E171: Missing :endif
            > Press ENTER or type command to continue
            >
            > What am I doing wrong?

            You are trying to open file with CRLF (Windows) line endings on *nix (linux or Mac OS). It is not you, but sender who is doing wrong.



            You can quickly work around this issue by opening the objc.vim in Vim.  Anytime files are sent to Bram for inclusion they should be using the Unix fileformat (ff).
            :e set ff=unix
            :wq

            Then start Vim again and try your test.

            HTH,
            David

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • Christian Wellenbrock
            ... Thanks that worked. I attached the fixed unix version. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below
            Message 5 of 15 , Jun 4, 2013
            • 0 Attachment
              On Tuesday, June 4, 2013 4:27:49 PM UTC+2, David Fishburn wrote:
              > ...>
              >
              >
              >
              >
              >
              >
              > > "AdjustIo.h" 81L, 2743C
              >
              > > Error detected while processing /usr/share/vim/vim73/syntax/objc.vim:
              >
              > > line    6:
              >
              > > E492: Not an editor command: ^M
              >
              > > line    8:
              >
              > > E15: Invalid expression: exists("b:current_syntax")^M
              >
              > > line  107:
              >
              > > E488: Trailing characters
              >
              > > line  110:
              >
              > > E171: Missing :endif
              >
              > > Press ENTER or type command to continue
              >
              > >
              >
              > > What am I doing wrong?
              >
              > You are trying to open file with CRLF (Windows) line endings on *nix (linux or Mac OS). It is not you, but sender who is doing wrong.
              >
              >
              >
              >
              >
              >
              >
              > You can quickly work around this issue by opening the objc.vim in Vim.  Anytime files are sent to Bram for inclusion they should be using the Unix fileformat (ff).
              >
              > :e set ff=unix
              > :wq
              >
              >
              > Then start Vim again and try your test.
              >
              >
              >
              > HTH,
              > David

              Thanks that worked. I attached the fixed unix version.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Wellenbrock
              ... I quickly scrolled over some AFNetworking sources [1]. I like the highlighting of `YES`, `NO`, `@autoreleasepool` etc. There are however at least two
              Message 6 of 15 , Jun 4, 2013
              • 0 Attachment
                On Tuesday, June 4, 2013 4:33:11 PM UTC+2, Christian Wellenbrock wrote:
                > On Tuesday, June 4, 2013 4:27:49 PM UTC+2, David Fishburn wrote:
                >
                > > ...>
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > > > "AdjustIo.h" 81L, 2743C
                >
                > >
                >
                > > > Error detected while processing /usr/share/vim/vim73/syntax/objc.vim:
                >
                > >
                >
                > > > line    6:
                >
                > >
                >
                > > > E492: Not an editor command: ^M
                >
                > >
                >
                > > > line    8:
                >
                > >
                >
                > > > E15: Invalid expression: exists("b:current_syntax")^M
                >
                > >
                >
                > > > line  107:
                >
                > >
                >
                > > > E488: Trailing characters
                >
                > >
                >
                > > > line  110:
                >
                > >
                >
                > > > E171: Missing :endif
                >
                > >
                >
                > > > Press ENTER or type command to continue
                >
                > >
                >
                > > >
                >
                > >
                >
                > > > What am I doing wrong?
                >
                > >
                >
                > > You are trying to open file with CRLF (Windows) line endings on *nix (linux or Mac OS). It is not you, but sender who is doing wrong.
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > >
                >
                > > You can quickly work around this issue by opening the objc.vim in Vim.  Anytime files are sent to Bram for inclusion they should be using the Unix fileformat (ff).
                >
                > >
                >
                > > :e set ff=unix
                >
                > > :wq
                >
                > >
                >
                > >
                >
                > > Then start Vim again and try your test.
                >
                > >
                >
                > >
                >
                > >
                >
                > > HTH,
                >
                > > David
                >
                >
                >
                > Thanks that worked. I attached the fixed unix version.

                I quickly scrolled over some AFNetworking sources [1]. I like the highlighting of `YES`, `NO`, `@autoreleasepool` etc.

                There are however at least two issues that can be seen in this screenshot [2]. On the left, the current objc.vim is shown, on the right your new one. The code can be found here [3].

                1. I liked the blue `-` sign at the start of the method indicating an instance method.
                2. It seems like a random set of braces and semicolons is highlighted red on the right.

                [1] https://github.com/AFNetworking/AFNetworking
                [2] http://i.imgur.com/Qtc29Lo.png
                [3] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L361-L384

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Kazunobu Kuriyama
                Hi, Christian, Thank you for your prompt feedback. The picture with the source code was awfully helpful to find and fix the problems. Hopefully, the attached
                Message 7 of 15 , Jun 4, 2013
                • 0 Attachment
                  Hi, Christian,

                  Thank you for your prompt feedback. The picture with the source code was awfully helpful to find and fix the problems. Hopefully, the attached version should fix the problems you pointed out, at least for the given part of the code.

                  KK

                  On Jun 4, 2013, at 11:51 PM, Christian Wellenbrock <christian.wellenbrock@...> wrote:
                  >
                  > I quickly scrolled over some AFNetworking sources [1]. I like the highlighting of `YES`, `NO`, `@autoreleasepool` etc.
                  >
                  > There are however at least two issues that can be seen in this screenshot [2]. On the left, the current objc.vim is shown, on the right your new one. The code can be found here [3].
                  >
                  > 1. I liked the blue `-` sign at the start of the method indicating an instance method.
                  > 2. It seems like a random set of braces and semicolons is highlighted red on the right.
                  >
                  > [1] https://github.com/AFNetworking/AFNetworking
                  > [2] http://i.imgur.com/Qtc29Lo.png
                  > [3] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L361-L384

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Christian Wellenbrock
                  ... Yes the update fixed the problems. You saved it with Windows line endings again though. While we re at it, there are still red braces in other methods
                  Message 8 of 15 , Jun 4, 2013
                  • 0 Attachment
                    On Tuesday, June 4, 2013 7:39:33 PM UTC+2, Kazunobu Kuriyama wrote:
                    > Hi, Christian,
                    >
                    >
                    >
                    > Thank you for your prompt feedback. The picture with the source code was awfully helpful to find and fix the problems. Hopefully, the attached version should fix the problems you pointed out, at least for the given part of the code.
                    >
                    >
                    >
                    > KK
                    >
                    >
                    >
                    > On Jun 4, 2013, at 11:51 PM, Christian Wellenbrock wrote:
                    >
                    > >
                    >
                    > > I quickly scrolled over some AFNetworking sources [1]. I like the highlighting of `YES`, `NO`, `@autoreleasepool` etc.
                    >
                    > >
                    >
                    > > There are however at least two issues that can be seen in this screenshot [2]. On the left, the current objc.vim is shown, on the right your new one. The code can be found here [3].
                    >
                    > >
                    >
                    > > 1. I liked the blue `-` sign at the start of the method indicating an instance method.
                    >
                    > > 2. It seems like a random set of braces and semicolons is highlighted red on the right.
                    >
                    > >
                    >
                    > > [1] https://github.com/AFNetworking/AFNetworking
                    >
                    > > [2] http://i.imgur.com/Qtc29Lo.png
                    >
                    > > [3] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L361-L384

                    Yes the update fixed the problems. You saved it with Windows line endings again though. While we're at it, there are still red braces in other methods (that are red with the current syntax file as well). See the screenshot [1] of the code [2]. Maybe you can fix those too?

                    [1] http://i.imgur.com/kYXunaD.png
                    [2] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L198-L207

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Christian Wellenbrock
                    2013/6/4 Kazunobu Kuriyama ... No problem ;) ... I didn t know about this. Thank you for your explanation! -- -- You received
                    Message 9 of 15 , Jun 4, 2013
                    • 0 Attachment
                      2013/6/4 Kazunobu Kuriyama <kazunobu.kuriyama@...>
                      On Jun 5, 2013, at 3:41 AM, Christian Wellenbrock <christian.wellenbrock@...> wrote:

                      > <snip>
                      > Yes the update fixed the problems. You saved it with Windows line endings again though.

                      I apologize to you for getting you into trouble again.  Though the file itself is in unix format and I double-checked not to send window-friendly attachments, my Mail did something unnecessary.
                       
                      No problem ;) 
                       
                      > While we're at it, there are still red braces in other methods (that are red with the current syntax file as well). See the screenshot [1] of the code [2]. Maybe you can fix those too?
                      >
                      > [1] http://i.imgur.com/kYXunaD.png
                      > [2] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L198-L207

                      I'm afraid the phenomenon you saw with the new objc.vim presumably inherits from that of c.vim.  The new objc.vim as well as the current version has heavily relied on c.vim for obvious reasons and sources it at the initialization.  Actually, if you open a C file and write a snippet of code like

                      func(arg, ^{
                          I_am_a_lambda;
                      });

                      you will see what you've just seen with the objc.vim, though objc.vim is apparently irrelevant in this case.

                      The previous red brace problem was fixed by myself because it was a problem of a lambda function argument within a ObjC method call syntax which is at my disposal. On the other hand, the present case is a problem of a lambda function argument within a pure C function call syntax...

                      Hmm, ok, I'll look into c.vim, too. Of course, if some could fix the problem, I would highly appreciate to it ;=)

                      I didn't know about this. Thank you for your explanation!

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                       
                       
                    • David Fishburn
                      ... Kazunobu, What do you have in your .vimrc for this setting: fileformats You might want to try: set fileformats=unix,dos,mac Leave files in Unix
                      Message 10 of 15 , Jun 4, 2013
                      • 0 Attachment
                        ...

                        > Yes the update fixed the problems. You saved it with Windows line endings again though.

                        I apologize to you for getting you into trouble again.  Though the file itself is in unix format and I double-checked not to send window-friendly attachments, my Mail did something unnecessary.


                        Kazunobu,

                        What do you have in your .vimrc for this setting:
                        fileformats

                        You might want to try:
                            set fileformats=unix,dos,mac      " Leave files in Unix format first

                        That way, if the file is already in unix format, leave it that way.  It allows you to open up any of those fileformats without forcing a change when you save them.
                        This means when you create a new file, it will be in Unix format first.

                        If you primarily work on Windows, then you might want to try this:

                        if has('win32') || has('win64') || has('win16') || has('win95')
                            set fileformats=dos,unix,mac      " Leave files in DOS format first
                        elseif has('mac')
                            set fileformats=mac,unix,dos      " Leave files in Mac format first
                        else
                            set fileformats=unix,dos,mac      " Leave files in Unix format first
                        endif

                        But then, when you create a file for Bram, make sure you change the ff=unix once.  There after, you should never have to worry about the format changing with the above setting.

                        People may have other suggestions, but this works for me.

                        HTH,
                        David

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                         
                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                         
                         
                      • Kazunobu Kuriyama
                        David, Thank you for your kind series of notes. Since I have lived with unix or its variants for a long time (my first windows98 machine was taken over by
                        Message 11 of 15 , Jun 4, 2013
                        • 0 Attachment
                          David,

                          Thank you for your kind series of notes.  Since I have lived with unix or its variants for a long time (my first windows98 machine was taken over by Linux in a week), I've never set file format explicitly to send emails to the list.  Now I'm using MacOS X 10.8.3 and find myself in trouble I've never met with 10.6.7.  Since my vim replies fileformat=unix to the question :set fileformat, I guess the cause of the trouble mainly lies in my mailer.

                          I"ll read your instructions carefully and train the beast.  Till then, I humbly ask all your patience :-)

                          Thank you again,
                          KK

                          On Jun 5, 2013, at 5:30 AM, David Fishburn <dfishburn.vim@...> wrote:

                          ...

                          > Yes the update fixed the problems. You saved it with Windows line endings again though.

                          I apologize to you for getting you into trouble again.  Though the file itself is in unix format and I double-checked not to send window-friendly attachments, my Mail did something unnecessary.


                          Kazunobu,

                          What do you have in your .vimrc for this setting:
                          fileformats

                          You might want to try:
                              set fileformats=unix,dos,mac      " Leave files in Unix format first

                          That way, if the file is already in unix format, leave it that way.  It allows you to open up any of those fileformats without forcing a change when you save them.
                          This means when you create a new file, it will be in Unix format first.

                          If you primarily work on Windows, then you might want to try this:

                          if has('win32') || has('win64') || has('win16') || has('win95')
                              set fileformats=dos,unix,mac      " Leave files in DOS format first
                          elseif has('mac')
                              set fileformats=mac,unix,dos      " Leave files in Mac format first
                          else
                              set fileformats=unix,dos,mac      " Leave files in Unix format first
                          endif

                          But then, when you create a file for Bram, make sure you change the ff=unix once.  There after, you should never have to worry about the format changing with the above setting.

                          People may have other suggestions, but this works for me.

                          HTH,
                          David


                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                           
                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                           
                           

                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                           
                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                           
                           
                        • Kazunobu Kuriyama
                          Hi, Attached is the latest draft of syntax/objc.vim, in which the bug, kindly reported by Christian Wellenbrock, is fixed: ... Now, all the reported bugs have
                          Message 12 of 15 , Jun 9, 2013
                          • 0 Attachment
                            Hi,

                            Attached is the latest draft of syntax/objc.vim, in which the bug, kindly reported by Christian Wellenbrock, is fixed:

                            On Jun 5, 2013, at 3:41 AM, Christian Wellenbrock <christian.wellenbrock@...> wrote:

                            > <snip>
                            > Yes the update fixed the problems. You saved it with Windows line endings again though. While we're at it, there are still red braces in other methods (that are red with the current syntax file as well). See the screenshot [1] of the code [2]. Maybe you can fix those too?
                            >
                            > [1] http://i.imgur.com/kYXunaD.png
                            > [2] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L198-L207


                            Now, all the reported bugs have been fixed. In addition, I fixed some subtle bugs found by myself, optimized the code a little bit so that fast scrolling would not collapse highlighting temporarily, and added more stuff on object literals and ARC to fulfill VIM syntax highlighting support for Modern Objective-C.

                            So, I'd like to submit another version of the draft, suitably modified for VIM distribution, to Bram in a day or two if none of you objects to it.

                            Of course, any comment is always welcome.

                            Best regards,
                            KK

                            --
                            --
                            You received this message from the "vim_dev" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Adam Sharp
                            ... I m fairly new to vim so I m prepared to concede I may have stuffed something up—just wanted to report that I downloaded the latest version from this
                            Message 13 of 15 , Jan 23, 2014
                            • 0 Attachment
                              On Sunday, 9 June 2013 23:39:53 UTC+10, Kazunobu Kuriyama wrote:
                              > Attached is the latest draft of syntax/objc.vim, in which the bug, kindly reported by Christian Wellenbrock, is fixed:
                              >
                              > On Jun 5, 2013, at 3:41 AM, Christian Wellenbrock wrote:
                              > > <snip>
                              >
                              > > Yes the update fixed the problems. You saved it with Windows line endings again though. While we're at it, there are still red braces in other methods (that are red with the current syntax file as well). See the screenshot [1] of the code [2]. Maybe you can fix those too?
                              >
                              > >
                              >
                              > > [1] http://i.imgur.com/kYXunaD.png
                              >
                              > > [2] https://github.com/AFNetworking/AFNetworking/blob/master/AFNetworking/AFURLConnectionOperation.m#L198-L207
                              >
                              > Now, all the reported bugs have been fixed.

                              I'm fairly new to vim so I'm prepared to concede I may have stuffed something up—just wanted to report that I downloaded the latest version from this thread and added it to ~/.vim/autoload/, but I still seem get red braces for blocks passed to functions, e.g.:

                              dispatch_async(queue, ^{
                              // code
                              });

                              or in a Kiwi spec:

                              describe(@"testing", ^{
                              it(@"is awesome", ^{
                              // ...
                              });
                              });

                              Am I missing something?

                              Thanks,
                              Adam

                              --
                              --
                              You received this message from the "vim_dev" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_dev" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Adam Sharp
                              ... So it turns it I was doing it wrong: after moving the file into ~/.vim/syntax and running it through dos2unix, it started working. No more red braces. If I
                              Message 14 of 15 , Jan 23, 2014
                              • 0 Attachment
                                On 24 January 2014 13:53, Adam Sharp <adsharp@...> wrote:
                                > I'm fairly new to vim so I'm prepared to concede I may have stuffed something up—just wanted to report that I downloaded the latest version from this thread and added it to ~/.vim/autoload/ [...]

                                So it turns it I was doing it wrong: after moving the file into
                                ~/.vim/syntax and running it through dos2unix, it started working. No
                                more red braces.

                                If I do find any issues, is this still the right place to report them?

                                –Adam

                                --
                                --
                                You received this message from the "vim_dev" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • David Fishburn
                                ... required. HTH, David -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are replying to. For
                                Message 15 of 15 , Jan 24, 2014
                                • 0 Attachment

                                  On Thu, Jan 23, 2014 at 11:25 PM, Adam Sharp <adsharp@...> wrote:
                                  ...

                                  So it turns it I was doing it wrong: after moving the file into
                                  ~/.vim/syntax and running it through dos2unix, it started working. No
                                  more red braces.

                                  If I do find any issues, is this still the right place to report them?


                                  Start on vim_use.  Typically someone there would direct you here is required.

                                  HTH,
                                  David 

                                  --
                                  --
                                  You received this message from the "vim_dev" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php
                                   
                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                Your message has been successfully submitted and would be delivered to recipients shortly.