Loading ...
Sorry, an error occurred while loading the content.

Re: rtp hacks, sourcing after/*

Expand Messages
  • Gary Johnson
    ... I would expect the ftdetect files from the plugin to not be sourced because the plugin wasn t added to rtp until after the sourcing was done by the
    Message 1 of 9 , May 27, 2013
    • 0 Attachment
      On 2013-05-27, Marc Weber wrote:

      > You'll notice that the ftdetect files and the after files from the
      > plugin were not sourced.

      I would expect the ftdetect files from the plugin to not be sourced
      because the plugin wasn't added to 'rtp' until after the sourcing
      was done by the :filetype command. That's an error in your ~/.vimrc
      file that can easily be fixed by putting the 'rtp' setting ahead of
      the :filetype command.

      As I wrote in an earlier reply, the after files from the plugin
      aren't sourced because you didn't include them in the 'rtp'. That's
      easily fixed with

      :set rtp+=~/A,~/A/after

      Possibly better would be

      :set rtp^=~/A
      :set rtp+=~/A/after

      in case a plugin file needed to take the place of a $VIMRUNTIME
      file.

      With those two issues understood, it should be pretty easy to get
      your plugin manager thingy working.

      Regards,
      Gary

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.