Loading ...
Sorry, an error occurred while loading the content.

New regexp engine bugs fixed

Expand Messages
  • Bram Moolenaar
    I have fixed all the reported bugs in the NFA regexp engine. All the syntax highlighted files that I have received show exactly the same highlighting with the
    Message 1 of 12 , May 27, 2013
    • 0 Attachment
      I have fixed all the reported bugs in the NFA regexp engine.
      All the syntax highlighted files that I have received show exactly the
      same highlighting with the old and the new engine.

      If you still encounter a problem, please report it. You can verify with
      both engines using the 'regexpengine' option. For syntax highlighting you
      probably need to restart Vim since the compiled regexp is cached.
      If you can reproduce it with a simple pattern search that would be best.
      Prepend "\%#=1" or "\%#=2" to the pattern to select the regexp engine.

      I could also still use more syntax-highlighted test files. Especially
      for obscure languages.

      I am now going to work on performance. XML is still very slow, some of
      the patterns there are not supported by the new engine yet. That's not
      so easy to fix.

      --
      If someone questions your market projections, simply point out that your
      target market is "People who are nuts" and "People who will buy any damn
      thing". Nobody is going to tell you there aren't enough of those people
      to go around.
      (Scott Adams - The Dilbert principle)

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Amadeus Demarzi
      Not sure if this has already been fixed, but I noticed that with this JS Syntax file: https://github.com/pangloss/vim-javascript/ That lines directly after a
      Message 2 of 12 , May 27, 2013
      • 0 Attachment
        Not sure if this has already been fixed, but I noticed that with this JS Syntax file:

        https://github.com/pangloss/vim-javascript/

        That lines directly after a comment continue to appear commented until there is an empty line.

        This is from the 1020 changeset merged into MacVim btw: https://github.com/b4winckler/macvim , so it could've been fixed in a subsequence 1021+ change set?

        On Monday, May 27, 2013 10:59:51 AM UTC+1, Bram Moolenaar wrote:
        > I have fixed all the reported bugs in the NFA regexp engine.
        >
        > All the syntax highlighted files that I have received show exactly the
        >
        > same highlighting with the old and the new engine.
        >
        >
        >
        > If you still encounter a problem, please report it. You can verify with
        >
        > both engines using the 'regexpengine' option. For syntax highlighting you
        >
        > probably need to restart Vim since the compiled regexp is cached.
        >
        > If you can reproduce it with a simple pattern search that would be best.
        >
        > Prepend "\%#=1" or "\%#=2" to the pattern to select the regexp engine.
        >
        >
        >
        > I could also still use more syntax-highlighted test files. Especially
        >
        > for obscure languages.
        >
        >
        >
        > I am now going to work on performance. XML is still very slow, some of
        >
        > the patterns there are not supported by the new engine yet. That's not
        >
        > so easy to fix.
        >
        >
        >
        > --
        >
        > If someone questions your market projections, simply point out that your
        >
        > target market is "People who are nuts" and "People who will buy any damn
        >
        > thing". Nobody is going to tell you there aren't enough of those people
        >
        > to go around.
        >
        > (Scott Adams - The Dilbert principle)
        >
        >
        >
        > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        >
        > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        >
        > \\\ an exciting new programming language -- http://www.Zimbu.org ///
        >
        > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Bram Moolenaar
        ... I don t have an example Javascript file. Would be good to have one, preferably a public one. -- A)bort, R)etry, P)lease don t bother me again /// Bram
        Message 3 of 12 , May 28, 2013
        • 0 Attachment
          Amadeus Demarzi wrote:

          > Not sure if this has already been fixed, but I noticed that with this
          > JS Syntax file:
          >
          > https://github.com/pangloss/vim-javascript/
          >
          > That lines directly after a comment continue to appear commented until
          > there is an empty line.
          >
          > This is from the 1020 changeset merged into MacVim btw:
          > https://github.com/b4winckler/macvim , so it could've been fixed in a
          > subsequence 1021+ change set?

          I don't have an example Javascript file. Would be good to have one,
          preferably a public one.

          --
          A)bort, R)etry, P)lease don't bother me again

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Hiroshi Shirosaki
          Hello, I noticed a syntax highlighting issue with filetype=html. test.html contains the following one line. When opening test.html,
          Message 4 of 12 , May 28, 2013
          • 0 Attachment
            Hello,

            I noticed a syntax highlighting issue with filetype=html.

            test.html contains the following one line.

            <script ><![CDATA[]]>


            When opening test.html, "[CDATA[]]" is highlighted as error with set re=0.

            But "[CDATA[]]" is not highlighted as error with set re=1.

            It seems due to new regexp engine.

            Tested with Vim 7.3.1036 on Ubuntu Linux.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Amadeus Demarzi
            This is far from a complete JS example file, but it does trigger the bug I mentioned in the afore-linked repo: https://gist.github.com/amadeus/5667508 ... --
            Message 5 of 12 , May 28, 2013
            • 0 Attachment
              This is far from a complete JS example file, but it does trigger the bug I mentioned in the afore-linked repo:

              https://gist.github.com/amadeus/5667508

              On Monday, May 27, 2013 10:59:51 AM UTC+1, Bram Moolenaar wrote:
              > I have fixed all the reported bugs in the NFA regexp engine.
              >
              > All the syntax highlighted files that I have received show exactly the
              >
              > same highlighting with the old and the new engine.
              >
              >
              >
              > If you still encounter a problem, please report it. You can verify with
              >
              > both engines using the 'regexpengine' option. For syntax highlighting you
              >
              > probably need to restart Vim since the compiled regexp is cached.
              >
              > If you can reproduce it with a simple pattern search that would be best.
              >
              > Prepend "\%#=1" or "\%#=2" to the pattern to select the regexp engine.
              >
              >
              >
              > I could also still use more syntax-highlighted test files. Especially
              >
              > for obscure languages.
              >
              >
              >
              > I am now going to work on performance. XML is still very slow, some of
              >
              > the patterns there are not supported by the new engine yet. That's not
              >
              > so easy to fix.
              >
              >
              >
              > --
              >
              > If someone questions your market projections, simply point out that your
              >
              > target market is "People who are nuts" and "People who will buy any damn
              >
              > thing". Nobody is going to tell you there aren't enough of those people
              >
              > to go around.
              >
              > (Scott Adams - The Dilbert principle)
              >
              >
              >
              > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              >
              > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              >
              > \\\ an exciting new programming language -- http://www.Zimbu.org ///
              >
              > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • mattn
              I can t reproduce it in 7.3.1036 http://go-gyazo.appspot.com/f5d64c5ab3601051.png ... -- -- You received this message from the vim_dev maillist. Do not
              Message 6 of 12 , May 28, 2013
              • 0 Attachment
                I can't reproduce it in 7.3.1036

                http://go-gyazo.appspot.com/f5d64c5ab3601051.png

                On Wednesday, May 29, 2013 11:09:39 AM UTC+9, Amadeus Demarzi wrote:
                > This is far from a complete JS example file, but it does trigger the bug I mentioned in the afore-linked repo:
                >
                > https://gist.github.com/amadeus/5667508
                >
                > On Monday, May 27, 2013 10:59:51 AM UTC+1, Bram Moolenaar wrote:
                > > I have fixed all the reported bugs in the NFA regexp engine.
                > >
                > > All the syntax highlighted files that I have received show exactly the
                > >
                > > same highlighting with the old and the new engine.
                > >
                > >
                > >
                > > If you still encounter a problem, please report it. You can verify with
                > >
                > > both engines using the 'regexpengine' option. For syntax highlighting you
                > >
                > > probably need to restart Vim since the compiled regexp is cached.
                > >
                > > If you can reproduce it with a simple pattern search that would be best.
                > >
                > > Prepend "\%#=1" or "\%#=2" to the pattern to select the regexp engine.
                > >
                > >
                > >
                > > I could also still use more syntax-highlighted test files. Especially
                > >
                > > for obscure languages.
                > >
                > >
                > >
                > > I am now going to work on performance. XML is still very slow, some of
                > >
                > > the patterns there are not supported by the new engine yet. That's not
                > >
                > > so easy to fix.
                > >
                > >
                > >
                > > --
                > >
                > > If someone questions your market projections, simply point out that your
                > >
                > > target market is "People who are nuts" and "People who will buy any damn
                > >
                > > thing". Nobody is going to tell you there aren't enough of those people
                > >
                > > to go around.
                > >
                > > (Scott Adams - The Dilbert principle)
                > >
                > >
                > >
                > > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                > >
                > > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                > >
                > > \\\ an exciting new programming language -- http://www.Zimbu.org ///
                > >
                > > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Bram Moolenaar
                ... Thanks for reporting this problem. I didn t have a HTML file in my syntax file collection yet. I added one from Vim docs (not very diverse though). I
                Message 7 of 12 , May 29, 2013
                • 0 Attachment
                  Hiroshi Shirosaki wrote:

                  > I noticed a syntax highlighting issue with filetype=html.
                  >
                  > test.html contains the following one line.
                  >
                  > <script ><![CDATA[]]>
                  >
                  >
                  > When opening test.html, "[CDATA[]]" is highlighted as error with set re=0.
                  >
                  > But "[CDATA[]]" is not highlighted as error with set re=1.
                  >
                  > It seems due to new regexp engine.
                  >
                  > Tested with Vim 7.3.1036 on Ubuntu Linux.

                  Thanks for reporting this problem.

                  I didn't have a HTML file in my syntax file collection yet. I added one
                  from Vim docs (not very diverse though). I added your line and can see
                  the difference. I'll find out how to fix it.

                  --
                  hundred-and-one symptoms of being an internet addict:
                  13. You refer to going to the bathroom as downloading.

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Bram Moolenaar
                  ... I don t see a problem with this file. The problem you refer to is that comments continue in the next line, right? -- hundred-and-one symptoms of being an
                  Message 8 of 12 , May 29, 2013
                  • 0 Attachment
                    Amadeus Demarzi wrote:

                    > This is far from a complete JS example file, but it does trigger the
                    > bug I mentioned in the afore-linked repo:
                    >
                    > https://gist.github.com/amadeus/5667508

                    I don't see a problem with this file. The problem you refer to is that
                    comments continue in the next line, right?

                    --
                    hundred-and-one symptoms of being an internet addict:
                    14. You start introducing yourself as "Jim at I-I-Net dot net dot au"

                    /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                    /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                    \\\ an exciting new programming language -- http://www.Zimbu.org ///
                    \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Amadeus Demarzi
                    It s very possible this issue was fixed. But to confirm, yes, it was as if single line comments continued onto the next line until there was an empty line.
                    Message 9 of 12 , May 29, 2013
                    • 0 Attachment
                      It's very possible this issue was fixed.

                      But to confirm, yes, it was as if single line comments continued onto the next line until there was an empty line.

                      Since I mostly just work in MacVim, I'll have to wait until these new changes get merged in to confirm it's fixed.

                      Thanks!

                      On Wednesday, May 29, 2013 6:42:26 PM UTC+1, Bram Moolenaar wrote:
                      > Amadeus Demarzi wrote:
                      >
                      >
                      >
                      > > This is far from a complete JS example file, but it does trigger the
                      >
                      > > bug I mentioned in the afore-linked repo:
                      >
                      > >
                      >
                      > > https://gist.github.com/amadeus/5667508
                      >
                      >
                      >
                      > I don't see a problem with this file. The problem you refer to is that
                      >
                      > comments continue in the next line, right?
                      >
                      >
                      >
                      > --
                      >
                      > hundred-and-one symptoms of being an internet addict:
                      >
                      > 14. You start introducing yourself as "Jim at I-I-Net dot net dot au"
                      >
                      >
                      >
                      > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                      >
                      > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                      >
                      > \\\ an exciting new programming language -- http://www.Zimbu.org ///
                      >
                      > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Hiroshi Shirosaki
                      ... It seems related to regexp _[^ ]* . Emitting end-of-line pattern would be wrong with negated collection. I attached a patch for this. Thank you. -- --
                      Message 10 of 12 , May 29, 2013
                      • 0 Attachment
                        On Thursday, May 30, 2013 2:42:26 AM UTC+9, Bram Moolenaar wrote:
                        > Hiroshi Shirosaki wrote:
                        > > I noticed a syntax highlighting issue with filetype=html.
                        > > test.html contains the following one line.
                        > > <script ><![CDATA[]]>
                        > >
                        > > When opening test.html, "[CDATA[]]" is highlighted as error with set re=0.
                        > >
                        > > But "[CDATA[]]" is not highlighted as error with set re=1.
                        >
                        > I didn't have a HTML file in my syntax file collection yet. I added one
                        >
                        > from Vim docs (not very diverse though). I added your line and can see
                        >
                        > the difference. I'll find out how to fix it.
                        >

                        It seems related to regexp '\_[^>]*'. Emitting end-of-line pattern would be wrong with negated collection.
                        I attached a patch for this.

                        Thank you.

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Bram Moolenaar
                        ... With a test, wonderful. -- If they don t keep on exercising their lips, he thought, their brains start working. -- Douglas Adams, The Hitchhiker s Guide
                        Message 11 of 12 , May 30, 2013
                        • 0 Attachment
                          Hiroshi Shirosaki wrote:

                          > > > I noticed a syntax highlighting issue with filetype=html.
                          > > > test.html contains the following one line.
                          > > > <script ><![CDATA[]]>
                          > > >
                          > > > When opening test.html, "[CDATA[]]" is highlighted as error with set re=0.
                          > > >
                          > > > But "[CDATA[]]" is not highlighted as error with set re=1.
                          > >
                          > > I didn't have a HTML file in my syntax file collection yet. I added one
                          > >
                          > > from Vim docs (not very diverse though). I added your line and can see
                          > >
                          > > the difference. I'll find out how to fix it.
                          > >
                          >
                          > It seems related to regexp '\_[^>]*'. Emitting end-of-line pattern
                          > would be wrong with negated collection.
                          > I attached a patch for this.

                          With a test, wonderful.

                          --
                          If they don't keep on exercising their lips, he thought, their brains
                          start working.
                          -- Douglas Adams, "The Hitchhiker's Guide to the Galaxy"

                          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                          \\\ an exciting new programming language -- http://www.Zimbu.org ///
                          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Amadeus Demarzi
                          I was able to test the a version of Vim with the latest patches, consider my JS comment error fixed! Cheers ... -- -- You received this message from the
                          Message 12 of 12 , May 31, 2013
                          • 0 Attachment
                            I was able to test the a version of Vim with the latest patches, consider my JS comment error fixed!

                            Cheers

                            On Thursday, May 30, 2013 11:51:26 AM UTC+2, Bram Moolenaar wrote:
                            > Hiroshi Shirosaki wrote:
                            >
                            >
                            >
                            > > > > I noticed a syntax highlighting issue with filetype=html.
                            >
                            > > > > test.html contains the following one line.
                            >
                            > > > > <script ><![CDATA[]]>
                            >
                            > > > >
                            >
                            > > > > When opening test.html, "[CDATA[]]" is highlighted as error with set re=0.
                            >
                            > > > >
                            >
                            > > > > But "[CDATA[]]" is not highlighted as error with set re=1.
                            >
                            > > >
                            >
                            > > > I didn't have a HTML file in my syntax file collection yet. I added one
                            >
                            > > >
                            >
                            > > > from Vim docs (not very diverse though). I added your line and can see
                            >
                            > > >
                            >
                            > > > the difference. I'll find out how to fix it.
                            >
                            > > >
                            >
                            > >
                            >
                            > > It seems related to regexp '\_[^>]*'. Emitting end-of-line pattern
                            >
                            > > would be wrong with negated collection.
                            >
                            > > I attached a patch for this.
                            >
                            >
                            >
                            > With a test, wonderful.
                            >
                            >
                            >
                            > --
                            >
                            > If they don't keep on exercising their lips, he thought, their brains
                            >
                            > start working.
                            >
                            > -- Douglas Adams, "The Hitchhiker's Guide to the Galaxy"
                            >
                            >
                            >
                            > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                            >
                            > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                            >
                            > \\\ an exciting new programming language -- http://www.Zimbu.org ///
                            >
                            > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                            --
                            --
                            You received this message from the "vim_dev" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          Your message has been successfully submitted and would be delivered to recipients shortly.