Loading ...
Sorry, an error occurred while loading the content.

Re: Error using "A" with wrap on

Expand Messages
  • Axel Bender
    Sorry, forgot to start with -i NONE -N -u NONE --noplugin -U NONE when I provided the sample. Using the above arguments, set columns=54 number wrap
    Message 1 of 8 , May 26, 2013
    View Source
    • 0 Attachment
      Sorry, forgot to start with "-i NONE -N -u NONE --noplugin -U NONE" when I provided the sample.

      Using the above arguments, set columns=54 number wrap showbreak=(cnt) can be used to reproduce the problem (which also presents itself when using "a" with the cursor being in the last column) with the following buffer contents:

      http://www.vim.org/the_true_story_of_vim/index.php
      1234567890

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Looks normal to me. There is a slight difference between having number set or not, but that s not really wrong. -- Imagine a world without hypothetical
      Message 2 of 8 , May 26, 2013
      View Source
      • 0 Attachment
        Axel Bender wrote:

        > Sorry, forgot to start with "-i NONE -N -u NONE --noplugin -U NONE"
        > when I provided the sample.
        >
        > Using the above arguments, set columns=54 number wrap showbreak=(cnt)
        > can be used to reproduce the problem (which also presents itself when
        > using "a" with the cursor being in the last column) with the following
        > buffer contents:
        >
        > http://www.vim.org/the_true_story_of_vim/index.php
        > 1234567890

        Looks normal to me. There is a slight difference between having
        'number' set or not, but that's not really wrong.

        --
        Imagine a world without hypothetical situations.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Axel Bender
        Hm, where was your cursor after A ? Did you get a new line before entering a character? Here the cursor would be positioned in the second line (the one with
        Message 3 of 8 , May 26, 2013
        View Source
        • 0 Attachment
          Hm, where was your cursor after "A"? Did you get a new line before entering a character?
          Here the cursor would be positioned in the second line (the one with the numbers), at column 5 in INSERT mode. Only after I enter a character I would get a new line...

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Bram Moolenaar
          ... The cursor is where the typed character will appear. Inserting a new line doesn t happen until you actually type the character. It s always been that
          Message 4 of 8 , May 26, 2013
          View Source
          • 0 Attachment
            Axel Bender wrote:

            > Hm, where was your cursor after "A"? Did you get a new line before
            > entering a character?
            > Here the cursor would be positioned in the second line (the one with
            > the numbers), at column 5 in INSERT mode. Only after I enter a
            > character I would get a new line...

            The cursor is where the typed character will appear. Inserting a new
            line doesn't happen until you actually type the character. It's always
            been that way.

            --
            No engineer can take a shower without wondering if some sort of Teflon coating
            would make showering unnecessary.
            (Scott Adams - The Dilbert principle)

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ an exciting new programming language -- http://www.Zimbu.org ///
            \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Axel Bender
            Ok, I take that, but what about the incorrect offset in the second line? -- -- You received this message from the vim_dev maillist. Do not top-post! Type
            Message 5 of 8 , May 26, 2013
            View Source
            • 0 Attachment
              Ok, I take that, but what about the incorrect offset in the second line?

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • nickles
              Can confirm this. Any solution? -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are replying
              Message 6 of 8 , May 27, 2013
              View Source
              • 0 Attachment
                Can confirm this. Any solution?

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.