Loading ...
Sorry, an error occurred while loading the content.

Re: [patch] get quickfix stack

Expand Messages
  • LCD 47
    ... Hmm, this is interesting. I can reproduce the problem if I run syntastic check (getlocstack() is missing the first entry), but not if I start from scratch
    Message 1 of 21 , May 22, 2013
    • 0 Attachment
      On 22 May 2013, Christian Brabandt <cblists@...> wrote:
      > Hi LCD!
      >
      > On Mi, 22 Mai 2013, LCD 47 wrote:
      > > On 22 May 2013, LCD 47 <lcd047@...> wrote:
      > > [...]

      > > > Excellent, thank you! I'll play with it for a while, then
      > > > post my conclusions.
      > >
      > > There seems to be a bug in getlocstack(), it misses the first
      > > entry. Example: after a single run of syntastic check:
      > >

      > > :echo len(getlocstack(0))
      > > 3
      > >
      > > :echo len(getloctitle(0))
      > > 4
      > > Here getloctitle() seems to work correctly.
      >
      > I don't see this. How did you make this? (I only checked by calling
      > :setloclist(0, [...]) several times and not sure how to make syntastic
      > do this.

      Hmm, this is interesting. I can reproduce the problem if I run
      syntastic check (getlocstack() is missing the first entry), but not if I
      start from scratch and I create a few loclists with lvimgrep
      (getlocstack() is working fine in that case). The difference is that
      syntastic runs lmake, then calls setloclist() a number of times.

      > > Also getlocstackptr() should probably return -1 rather than 0 if the
      > > stack is empty (calling getlocstack() to find out is expensive in
      > > terms of memory).
      >
      > Ok. Updated the patch.
      [...]

      Excellent, thank you!

      /lcd

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.