Loading ...
Sorry, an error occurred while loading the content.

Re: Vim very slow after update

Expand Messages
  • Christian Brabandt
    ... Globbing is still (7.3.996) very slow, even with patterns, that should work well for the new RE engine (e.g. **/foobar.*) regards, Christian -- Das
    Message 1 of 6 , May 21 1:02 PM
    • 0 Attachment
      On Di, 21 Mai 2013, Bram Moolenaar wrote:

      > It's the new regexp engine. If this bothers you set 'regexpengine' to
      > 1. It's not the default because we want to fix the slowness.
      > Patch 7.3.988 should help.

      Globbing is still (7.3.996) very slow, even with patterns, that should
      work well for the new RE engine (e.g. **/foobar.*)

      regards,
      Christian
      --
      Das größte Vorurteil, daß Dichter, die sich selber hingeben und
      vergessen, nicht das fremde Sich auffaßten und bemerkten. Sie sehen
      alles, weil sie sich sehen lassen; der andere sieht wenig, weil er
      wenig sehen läßt.
      -- Jean Paul

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... For that ** stuff the regexp engine isn t used much. Vim has to read directory contents, that s what makes it slow. The regexp matching is only a
      Message 2 of 6 , May 21 1:45 PM
      • 0 Attachment
        Christian Brabandt wrote:

        > On Di, 21 Mai 2013, Bram Moolenaar wrote:
        >
        > > It's the new regexp engine. If this bothers you set 'regexpengine' to
        > > 1. It's not the default because we want to fix the slowness.
        > > Patch 7.3.988 should help.
        >
        > Globbing is still (7.3.996) very slow, even with patterns, that should
        > work well for the new RE engine (e.g. **/foobar.*)

        For that "**" stuff the regexp engine isn't used much. Vim has to read
        directory contents, that's what makes it slow. The regexp matching is
        only a fraction of that.

        --
        Kiss me twice. I'm schizophrenic.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Bram! ... Ah, the problem was actually caused by using a debug built, which creates the logfile. Mit freundlichen Grüßen Christian -- Wir irren
        Message 3 of 6 , May 21 2:02 PM
        • 0 Attachment
          Hi Bram!

          On Di, 21 Mai 2013, Bram Moolenaar wrote:

          >
          > Christian Brabandt wrote:
          >
          > > On Di, 21 Mai 2013, Bram Moolenaar wrote:
          > >
          > > > It's the new regexp engine. If this bothers you set 'regexpengine' to
          > > > 1. It's not the default because we want to fix the slowness.
          > > > Patch 7.3.988 should help.
          > >
          > > Globbing is still (7.3.996) very slow, even with patterns, that should
          > > work well for the new RE engine (e.g. **/foobar.*)
          >
          > For that "**" stuff the regexp engine isn't used much. Vim has to read
          > directory contents, that's what makes it slow. The regexp matching is
          > only a fraction of that.

          Ah, the problem was actually caused by using a debug built, which
          creates the logfile.

          Mit freundlichen Grüßen
          Christian
          --
          Wir irren geschäftig umher, suchen nach einem bequemen Plätzchen im
          Leben.
          -- Maxim Gorkij

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.