Loading ...
Sorry, an error occurred while loading the content.
 

Re: [patch] confusing error E380/E381

Expand Messages
  • Bram Moolenaar
    ... Makes sense. I ll include it. -- I generally avoid temptation unless I can t resist it. -- Mae West /// Bram Moolenaar -- Bram@Moolenaar.net --
    Message 1 of 2 , May 11, 2013
      Christian Brabandt wrote:

      > Bram,
      > the help states:
      > ,----
      > | When ":colder" has been used and ":make" or ":grep" is used to add a new error
      > | list, one newer list is overwritten. This is especially useful if you are
      > | browsing with ":grep" |grep|. If you want to keep the more recent error
      > | lists, use ":cnewer 99" first.
      > `----
      >
      > Suppose you have 4 error lists and errorlist 1 is displayed. When using
      > :cnewer 99, you'll get Error E381 and the errorlist isn't updated. You
      > seem to be still in error list 1, although you are actually in the last
      > error list.
      >
      > You'll only notice that you are actually in another error list by
      > pressing Enter on it and it will jump to the error of the errorlist that
      > isn't displayed. (Also :cclose followed by :copen updates the errorlist
      > correctly and works around the issue).
      >
      > Here is a patch, that fixes the issue, by making sure, the error list is
      > updated even if an error occured.

      Makes sense. I'll include it.


      --
      'I generally avoid temptation unless I can't resist it."
      -- Mae West

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.