Re: Variable for "motion type" in Operator-pending mode
- On Thu, Apr 18, 2013 at 4:58 PM, glts <676c7473@...> wrote:
> Hi,If we could settle on a name for the variable, I would be happy to
> I have recently learnt of a patch that was submitted to the list almost
> five years ago. Please see here:
> The reception was positive but for some reason the discussion was
> abandoned. I would like to reopen the discussion. I'd be very interested
> in this feature and happy if the patch could eventually be included.
> As for the name of the variable, how about:
> The documentation says that when no motion type is given the variable
> will be empty, when an explicit motion type is given ("forced") it will
> be "v", "V", or "<C-V>". I don't think the word "force" is strictly
> required to make the intent of the variable clear.
> As for the underscore, the majority of v: variables with compound names
> don't have it and I think this short name would look nice next to the
> other variables which are relevant in this context:
> v:register v:count v:count1 v:prevcount v:operator v:motiontype
> What do you think?
update the patch and write a test. This is a low-risk patch unlikely to
cause any trouble, neither in 7.3 nor in 7.4.
Please make your opinion heard if you haven't already.
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
You received this message because you are subscribed to the Google Groups "vim_dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
For more options, visit https://groups.google.com/groups/opt_out.