Loading ...
Sorry, an error occurred while loading the content.

Re: display of listchars characters on the cursorline & visual-mode

Expand Messages
  • Ingo Karkat
    ... +1 from me; I also think the CursorLine_overrides_SpecialKey.patch is better. Thank you for including the graphical comparison; that s really helpful!
    Message 1 of 8 , May 2, 2013
    • 0 Attachment
      On 30-Apr-2013 06:38 +0200, nayuri.aohime wrote:

      > Hi,
      >
      > Fixed the display of listchars characters on the cursorline & visual-mode.
      > I've created a patch of two patterns.
      > I should not be judged because it is personal preference.
      >
      > SpecialKey_overrides_CursorLine.patch
      > -> Every highlighting listchars chatscters.
      >
      > CursorLine_overrides_SpecialKey.patch
      > -> Easy to use because it is similar to the current version.
      >
      > comparison.png
      > -> Please refer.
      > It is a comparison image in the following settings.
      > :colorscheme delek
      > :set cursorline list listchars=eol:$,tab:>-,trail:~,nbsp:%
      >
      > I prefer the CursorLine_overrides_SpecialKey.patch version.

      +1 from me; I also think the CursorLine_overrides_SpecialKey.patch is
      better. Thank you for including the graphical comparison; that's really
      helpful!

      Though purely cosmetic, this issue is indeed disturbing people; e.g. see
      the following Stack Overflow questions about this:


      http://stackoverflow.com/questions/8248872/in-vim-can-you-stop-the-color-change-of-white-space-characters-with-set-cursorl

      http://stackoverflow.com/questions/15606098/set-visibility-and-or-color-of-listchars-or-conceal-cchar-in-vim-when-cursorline

      -- regards, ingo

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • nayuri.aohime@...
      ... Hi, I ve found a bug in the previous patch, but fixed. Contents of the bug are: * set list listchars=eol:$ conceallevel=1 concealcursor=nvic * syntax match
      Message 2 of 8 , May 2, 2013
      • 0 Attachment
        2013年5月2日木曜日 22時37分48秒 UTC+9 Ingo Karkat:
        > On 30-Apr-2013 06:38 +0200, nayuri.aohime wrote:
        >
        >
        >
        > > Hi,
        >
        > >
        >
        > > Fixed the display of listchars characters on the cursorline & visual-mode.
        >
        > > I've created a patch of two patterns.
        >
        > > I should not be judged because it is personal preference.
        >
        > >
        >
        > > SpecialKey_overrides_CursorLine.patch
        >
        > > -> Every highlighting listchars chatscters.
        >
        > >
        >
        > > CursorLine_overrides_SpecialKey.patch
        >
        > > -> Easy to use because it is similar to the current version.
        >
        > >
        >
        > > comparison.png
        >
        > > -> Please refer.
        >
        > > It is a comparison image in the following settings.
        >
        > > :colorscheme delek
        >
        > > :set cursorline list listchars=eol:$,tab:>-,trail:~,nbsp:%
        >
        > >
        >
        > > I prefer the CursorLine_overrides_SpecialKey.patch version.
        >
        >
        >
        > +1 from me; I also think the CursorLine_overrides_SpecialKey.patch is
        >
        > better. Thank you for including the graphical comparison; that's really
        >
        > helpful!
        >
        >
        >
        > Though purely cosmetic, this issue is indeed disturbing people; e.g. see
        >
        > the following Stack Overflow questions about this:
        >
        >
        >
        >
        >
        > http://stackoverflow.com/questions/8248872/in-vim-can-you-stop-the-color-change-of-white-space-characters-with-set-cursorl
        >
        >
        >
        > http://stackoverflow.com/questions/15606098/set-visibility-and-or-color-of-listchars-or-conceal-cchar-in-vim-when-cursorline
        >
        >
        >
        > -- regards, ingo
        Hi,

        I've found a bug in the previous patch, but fixed.
        Contents of the bug are:
        * set list listchars=eol:$ conceallevel=1 concealcursor=nvic
        * syntax match NonText / / conceal cchar=.
        * Insert space(0x20), not displayed eol character.

        SpecialKey_overrides_CursorLine_ver2.patch
        -> Every highlighting listchars chatscters & conceal characters.

        CursorLine_overrides_SpecialKey_ver2.patch
        -> Easy to use because it is similar to the current version.

        This patches is ConcealCharacters will be treated the same as SpecialKey.
        Make the other versions it is easy.

        Best regards,
        DeaR

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • nayuri.aohime@...
        ... Hi, I ve found a bug in the previous patch, but fixed. Contents of the bug are: * set list listchars=eol:$ conceallevel=1 concealcursor=nvic * syntax match
        Message 3 of 8 , May 2, 2013
        • 0 Attachment
          2013年5月2日木曜日 22時37分48秒 UTC+9 Ingo Karkat:
          > On 30-Apr-2013 06:38 +0200, nayuri.aohime wrote:
          >
          >
          >
          > > Hi,
          >
          > >
          >
          > > Fixed the display of listchars characters on the cursorline & visual-mode.
          >
          > > I've created a patch of two patterns.
          >
          > > I should not be judged because it is personal preference.
          >
          > >
          >
          > > SpecialKey_overrides_CursorLine.patch
          >
          > > -> Every highlighting listchars chatscters.
          >
          > >
          >
          > > CursorLine_overrides_SpecialKey.patch
          >
          > > -> Easy to use because it is similar to the current version.
          >
          > >
          >
          > > comparison.png
          >
          > > -> Please refer.
          >
          > > It is a comparison image in the following settings.
          >
          > > :colorscheme delek
          >
          > > :set cursorline list listchars=eol:$,tab:>-,trail:~,nbsp:%
          >
          > >
          >
          > > I prefer the CursorLine_overrides_SpecialKey.patch version.
          >
          >
          >
          > +1 from me; I also think the CursorLine_overrides_SpecialKey.patch is
          >
          > better. Thank you for including the graphical comparison; that's really
          >
          > helpful!
          >
          >
          >
          > Though purely cosmetic, this issue is indeed disturbing people; e.g. see
          >
          > the following Stack Overflow questions about this:
          >
          >
          >
          >
          >
          > http://stackoverflow.com/questions/8248872/in-vim-can-you-stop-the-color-change-of-white-space-characters-with-set-cursorl
          >
          >
          >
          > http://stackoverflow.com/questions/15606098/set-visibility-and-or-color-of-listchars-or-conceal-cchar-in-vim-when-cursorline
          >
          >
          >
          > -- regards, ingo
          Hi,

          I've found a bug in the previous patch, but fixed.
          Contents of the bug are:
          * set list listchars=eol:$ conceallevel=1 concealcursor=nvic
          * syntax match NonText / / conceal cchar=.
          * Insert space(0x20), not displayed eol character.

          SpecialKey_overrides_CursorLine_ver2.patch
          -> Every highlighting listchars chatscters & conceal characters.

          CursorLine_overrides_SpecialKey_ver2.patch
          -> Easy to use because it is similar to the current version.

          This patches is ConcealCharacters will be treated the same as SpecialKey.
          Make the other versions it is easy.

          Best regards,
          DeaR

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • nayuri.aohime@...
          ... Hi, Sorry, ver2 patches have a bug, but fixed it. Contents of the bug are: * :set number foldenable cuesorline * Not highlighting line number columns &
          Message 4 of 8 , May 3, 2013
          • 0 Attachment
            2013年5月3日金曜日 5時37分36秒 UTC+9 nayuri...@...:
            > 2013年5月2日木曜日 22時37分48秒 UTC+9 Ingo Karkat:
            >
            > > On 30-Apr-2013 06:38 +0200, nayuri.aohime wrote:
            >
            > >
            >
            > >
            >
            > >
            >
            > > > Hi,
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > Fixed the display of listchars characters on the cursorline & visual-mode.
            >
            > >
            >
            > > > I've created a patch of two patterns.
            >
            > >
            >
            > > > I should not be judged because it is personal preference.
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > SpecialKey_overrides_CursorLine.patch
            >
            > >
            >
            > > > -> Every highlighting listchars chatscters.
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > CursorLine_overrides_SpecialKey.patch
            >
            > >
            >
            > > > -> Easy to use because it is similar to the current version.
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > comparison.png
            >
            > >
            >
            > > > -> Please refer.
            >
            > >
            >
            > > > It is a comparison image in the following settings.
            >
            > >
            >
            > > > :colorscheme delek
            >
            > >
            >
            > > > :set cursorline list listchars=eol:$,tab:>-,trail:~,nbsp:%
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > I prefer the CursorLine_overrides_SpecialKey.patch version.
            >
            > >
            >
            > >
            >
            > >
            >
            > > +1 from me; I also think the CursorLine_overrides_SpecialKey.patch is
            >
            > >
            >
            > > better. Thank you for including the graphical comparison; that's really
            >
            > >
            >
            > > helpful!
            >
            > >
            >
            > >
            >
            > >
            >
            > > Though purely cosmetic, this issue is indeed disturbing people; e.g. see
            >
            > >
            >
            > > the following Stack Overflow questions about this:
            >
            > >
            >
            > >
            >
            > >
            >
            > >
            >
            > >
            >
            > > http://stackoverflow.com/questions/8248872/in-vim-can-you-stop-the-color-change-of-white-space-characters-with-set-cursorl
            >
            > >
            >
            > >
            >
            > >
            >
            > > http://stackoverflow.com/questions/15606098/set-visibility-and-or-color-of-listchars-or-conceal-cchar-in-vim-when-cursorline
            >
            > >
            >
            > >
            >
            > >
            >
            > > -- regards, ingo
            >
            > Hi,
            >
            >
            >
            > I've found a bug in the previous patch, but fixed.
            >
            > Contents of the bug are:
            >
            > * set list listchars=eol:$ conceallevel=1 concealcursor=nvic
            >
            > * syntax match NonText / / conceal cchar=.
            >
            > * Insert space(0x20), not displayed eol character.
            >
            >
            >
            > SpecialKey_overrides_CursorLine_ver2.patch
            >
            > -> Every highlighting listchars chatscters & conceal characters.
            >
            >
            >
            > CursorLine_overrides_SpecialKey_ver2.patch
            >
            > -> Easy to use because it is similar to the current version.
            >
            >
            >
            > This patches is ConcealCharacters will be treated the same as SpecialKey.
            >
            > Make the other versions it is easy.
            >
            >
            >
            > Best regards,
            >
            > DeaR

            Hi,

            Sorry, ver2 patches have a bug, but fixed it.
            Contents of the bug are:
            * :set number foldenable cuesorline
            * Not highlighting line number columns & fold columns.

            Best regards,
            DeaR

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • mattn
            Bram, It s a definite bug, and he provides awesome fix. Let s merge which one! -- -- You received this message from the vim_dev maillist. Do not top-post!
            Message 5 of 8 , Nov 25, 2014
            • 0 Attachment
              Bram, It's a definite bug, and he provides awesome fix. Let's merge which one!

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • mattn
              ... presuku updated above patch. This patch is better than above. https://gist.github.com/presuku/d3d6b230b9b6dcfc0477 -- -- You received this message from the
              Message 6 of 8 , Nov 25, 2014
              • 0 Attachment
                On Wednesday, November 26, 2014 9:34:27 AM UTC+9, mattn wrote:
                > Bram, It's a definite bug, and he provides awesome fix. Let's merge which one!

                presuku updated above patch. This patch is better than above.

                https://gist.github.com/presuku/d3d6b230b9b6dcfc0477

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Bram Moolenaar
                ... Thanks. I can t find an item in the todo list for this, did one exist? -- The chat program is in public domain. This is not the GNU public license. If it
                Message 7 of 8 , Nov 27, 2014
                • 0 Attachment
                  Yasuhiro Matsumoto wrote:

                  > On Wednesday, November 26, 2014 9:34:27 AM UTC+9, mattn wrote:
                  > > Bram, It's a definite bug, and he provides awesome fix. Let's merge
                  > > which one!
                  >
                  > presuku updated above patch. This patch is better than above.
                  >
                  > https://gist.github.com/presuku/d3d6b230b9b6dcfc0477

                  Thanks. I can't find an item in the todo list for this, did one exist?

                  --
                  The chat program is in public domain. This is not the GNU public license.
                  If it breaks then you get to keep both pieces.
                  -- Copyright notice for the chat program

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                Your message has been successfully submitted and would be delivered to recipients shortly.