Loading ...
Sorry, an error occurred while loading the content.

Re: vim in terminal not redrawing background

Expand Messages
  • Christian Brabandt
    Hi Ondrej! ... Here is your problem. Do unset t_ut and it should work. For more information, read this blog post:
    Message 1 of 3 , May 1, 2013
    • 0 Attachment
      Hi Ondrej!

      On Di, 30 Apr 2013, Ondrej Platek wrote:

      > Hello,
      > I would like to report buggy behavior of Vim.
      >
      > When using Vim in terminal it happens that the area not filled
      > with text is not redrawn and it remains black.
      > I am using light color theme.
      > See the enclosed picture.
      >
      > I am using Vim mainly in gnu screen, but it happened to me also
      > in regular xfce4-terminal emulator.

      That sounds like a terminal problem. Let's see:

      > term=xterm-256color
      > t_ut=y

      Here is your problem. Do unset t_ut and it should work.

      For more information, read this blog post:
      http://snk.tuxfamily.org/log/vim-256color-bce.html

      regards,
      Christian
      --
      Mehrheiten zementieren das Bestehende, Fortschritt ist nur über
      Minderheiten möglich.
      -- Bertrand A. W. Russell

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.