Loading ...
Sorry, an error occurred while loading the content.

Re: macosx x11/motif gvim-7.3.706+ E250 dialog on startup

Expand Messages
  • Max Kirillov
    Hi. I also experienced this problem for some time. I dicovered there was some editing mistakes in recent which caused showing this message even if fontset is
    Message 1 of 8 , Apr 29, 2013
    • 0 Attachment
      Hi. I also experienced this problem for some time.

      I dicovered there was some editing mistakes in recent which
      caused showing this message even if fontset is not used.

      Patch which corrects the mistake is after the signature. It
      soppressed the message for me.

      The root cause is still unclear to me. Why would
      XCreateFontSet report anything about KOI8-R or GB2312.1980-0
      if I have utf-8 locale? I don't also have others installed.
      I am not familiar to libx11 to answer this question.

      Thanks,
      --
      Max

      patch:
      -------------------------
      diff -r 26fdbbc9927a -r 63f18a56fb20 src/syntax.c
      --- a/src/syntax.c Sun Apr 28 08:25:08 2013 +0300
      +++ b/src/syntax.c Mon Apr 29 06:23:22 2013 +0300
      @@ -8082,6 +8082,7 @@
      || do_tooltip
      # endif
      )
      + {
      if (free_font)
      gui_mch_free_fontset(HL_TABLE()[idx].sg_fontset);
      HL_TABLE()[idx].sg_fontset = fontset_name2handle(arg, 0
      @@ -8092,6 +8093,7 @@
      || do_tooltip
      # endif
      );
      + }
      if (HL_TABLE()[idx].sg_fontset != NOFONTSET)
      {
      /* If it worked and it's the Normal group, use it as the normal
      -------------------------

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Thanks for the patch! -- hundred-and-one symptoms of being an internet addict: 261. You find diskettes in your pockets when doing laundry. /// Bram
      Message 2 of 8 , May 1, 2013
      • 0 Attachment
        Max Kirillov wrote:

        > Hi. I also experienced this problem for some time.
        >
        > I dicovered there was some editing mistakes in recent which
        > caused showing this message even if fontset is not used.
        >
        > Patch which corrects the mistake is after the signature. It
        > soppressed the message for me.
        >
        > The root cause is still unclear to me. Why would
        > XCreateFontSet report anything about KOI8-R or GB2312.1980-0
        > if I have utf-8 locale? I don't also have others installed.
        > I am not familiar to libx11 to answer this question.

        Thanks for the patch!

        --
        hundred-and-one symptoms of being an internet addict:
        261. You find diskettes in your pockets when doing laundry.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.