Loading ...
Sorry, an error occurred while loading the content.

Re: [REQUEST] Officially drop support for

Expand Messages
  • Bram Moolenaar
    ... So we would require at least Python 2.3, right? It was released in 2003, ten years ago. I think that would be OK, unless there is a system that is stuck
    Message 1 of 5 , Apr 28, 2013
    • 0 Attachment
      ZyX wrote:

      > Reason: for <python-2.2 vim won’t compile in any case: there are no
      > iterator objects and thus my old change (with vim.bindeval) won’t
      > compile or (in case using dynamic library loading) run: <python-2.2 is
      > already not supported. Additionally <python-1.5 (1.6 till 2.1 were not
      > checked) requires varargs.h which none of C compilers I have support.
      >
      > Note that even with python-2.2 vim requires two changes in order to
      > compile and not crash afterwards (removing absent PyBool_Check (for
      > compiling) and assigning saved_python_thread at first
      > PyEval_SaveThread call (in order not to crash)).

      So we would require at least Python 2.3, right?
      It was released in 2003, ten years ago.
      I think that would be OK, unless there is a system that is stuck with
      Python 2.2.

      --
      "After a few years of marriage a man can look right at a woman
      without seeing her and a woman can see right through a man
      without looking at him."
      - Helen Rowland

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Marc Weber
      ... Even then people could continue using older Vim versions. Having nice python support should be a higher priority. Because scripting support differing from
      Message 2 of 5 , Apr 28, 2013
      • 0 Attachment
        Excerpts from Bram Moolenaar's message of Sun Apr 28 15:07:32 +0200 2013:
        > So we would require at least Python 2.3, right?
        > It was released in 2003, ten years ago.
        > I think that would be OK, unless there is a system that is stuck with
        > Python 2.2.
        Even then people could continue using older Vim versions.
        Having nice python support should be a higher priority.
        Because scripting support differing from VimL may have an positive
        effect on Vim's future IMHO.

        Marc Weber

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • ZyX
        ... I already made a patch to make it work on python-2.2 (not pushed currently). Test passes not completely†, but they indicate that python-2.2 is usable. I
        Message 3 of 5 , Apr 28, 2013
        • 0 Attachment
          > So we would require at least Python 2.3, right?
          > It was released in 2003, ten years ago.
          > I think that would be OK, unless there is a system that is stuck with
          > Python 2.2.

          I already made a patch to make it work on python-2.2 (not pushed currently). Test passes not completely†, but they indicate that python-2.2 is usable. I have not checked python versions other then 2.2‡ and (2.7 + 3.2).

          † problem is with settrace test and with my vim.options; latter is working fine, but old python uses 0 in place of False. There are also strange errors about negative (-1) refcount at DESTRUCTOR_FINISH calls for some WindowDestructor and ListDestructor, I do not know why.

          ‡ no dynamic python and no python3 as I don’t know how to force vim load needed library; while LD_LIBRARY_PATH works fine for ld.so

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • ZyX
          Note: when I say “python 2.2” here I mean “python 2.2.3”. Python 2.2 had some problems with compiling or installing, I do not remember exactly which
          Message 4 of 5 , Apr 28, 2013
          • 0 Attachment
            Note: when I say “python 2.2” here I mean “python 2.2.3”. Python 2.2 had some problems with compiling or installing, I do not remember exactly which (2.2.3 also had problems with compiling though; I had to execute one of last steps by hand).

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.