Loading ...
Sorry, an error occurred while loading the content.
 

Re: Fwd: Re: macosx x11/motif gvim-7.3.706+ E250 dialog on startup

Expand Messages
  • Roland Eggner
    Hi ! ... Maybe your problem is caused by a discrepancy between locale configuration and installed fonts. Suggestion (should work on Gentoo Linux,
    Message 1 of 8 , Apr 26, 2013
      Hi <raf@...>!

      On 2013-04-18 Thursday at 13:28 +1000 <raf@...> in another thread wrote:
      > Roland Eggner wrote:
      > > :!locale
      >
      > LANG="en_AU.UTF-8"
      > LC_COLLATE="en_AU.UTF-8"
      > LC_CTYPE="en_AU.UTF-8"
      > LC_MESSAGES="en_AU.UTF-8"
      > LC_MONETARY="en_AU.UTF-8"
      > LC_NUMERIC="en_AU.UTF-8"
      > LC_TIME="en_AU.UTF-8"
      > LC_ALL=
      >
      > > :!locale -a
      >
      > i've skipped all of the non-english ones.
      > there are many.
      >
      > en_AU
      > en_AU.ISO8859-1
      > en_AU.ISO8859-15
      > en_AU.US-ASCII
      > en_AU.UTF-8
      > en_CA
      > en_CA.ISO8859-1
      > en_CA.ISO8859-15
      > en_CA.US-ASCII
      > en_CA.UTF-8
      > en_GB
      > en_GB.ISO8859-1
      > en_GB.ISO8859-15
      > en_GB.US-ASCII
      > en_GB.UTF-8
      > en_IE
      > en_IE.UTF-8
      > en_NZ
      > en_NZ.ISO8859-1
      > en_NZ.ISO8859-15
      > en_NZ.US-ASCII
      > en_NZ.UTF-8
      > en_US
      > en_US.ISO8859-1
      > en_US.ISO8859-15
      > en_US.US-ASCII
      > en_US.UTF-8
      > C
      > POSIX

      On 2013-04-18 Thursday at 16:58 +1000 <raf@...> wrote:
      > ----- Forwarded message from raf <raf@...> -----
      > Subject: Re: macosx x11/motif gvim-7.3.706+ E250 dialog on startup
      > From: raf <raf@...>
      > To: vim_use@...
      > Date: Wed, 17 Apr 2013 12:05:31 +1000
      > Mail-Followup-To: vim_use@...
      > Reply-To: vim_use@...
      >
      > … …
      >
      > the error message i get for -*-courier-medium-r-normal-*-*-120-*-*-m-*-*
      > is very similar:
      >
      > E250: Fonts for the following charsets are missing in fontset -*-courier-medium-r-normal-*-*-120-*-*-m-*-*-*:
      > ISO8859-5
      > KOI8-R
      > ISO8859-7
      > JISX0208.1983-0
      > KSC5601.1987-0
      > GB2312.1980-0
      > JISX0201.1976-0
      > E250: Fonts for the following charsets are missing in fontset -*-courier-medium-r-normal-*-*-120-*-*-m-*-*-*:
      > ISO8859-5
      > KOI8-R
      > ISO8859-7
      > JISX0208.1983-0
      > KSC5601.1987-0
      > GB2312.1980-0
      > JISX0201.1976-0
      >
      > so it's not the choice of font that is the problem. it is the fact
      > that vim thinks that it needs to warn me about the fact that certain
      > obscure character sets that i don't use are not supported by the
      > chosen (or default) font.

      Maybe your problem is caused by a discrepancy between locale configuration and
      installed fonts.

      Suggestion (should work on Gentoo Linux, please tune to your macosx system):

      (1) Uninstall locales, which you do not use, e.g.
      su vim /etc/locale.gen
      :v/\v^(#|en_(AU|NZ|US)| … )/s/^/# /
      :wq
      su /usr/sbin/locale-gen
      To take effect your GUI (X-server?) probably needs to be restarted.
      Theoretically your system should become slightly faster, consume slightly less
      disk space, and become slightly less vulnerable in terms of security … all
      3 should not hurt, or what would you say?

      (2) “locale -a” should list ONLY locales, which you want to use. Install fonts
      for ANY of the listed locales.

      Documentation:
      man locale-gen locale.gen
      :h xfontset


      --
      Regards
      Roland Eggner
    • raf
      ... hi roland, thanks. that sounds like a good plan but there doesn t seem to be a system-supported way to uninstall locales from macosx. /etc/locale.gen etc.
      Message 2 of 8 , Apr 29, 2013
        Roland Eggner wrote:

        > Maybe your problem is caused by a discrepancy between locale configuration and
        > installed fonts.
        >
        > Suggestion (should work on Gentoo Linux, please tune to your macosx system):
        >
        > (1) Uninstall locales, which you do not use, e.g.
        > su vim /etc/locale.gen
        > :v/\v^(#|en_(AU|NZ|US)| … )/s/^/# /
        > :wq
        > su /usr/sbin/locale-gen
        > To take effect your GUI (X-server?) probably needs to be restarted.
        > Theoretically your system should become slightly faster, consume slightly less
        > disk space, and become slightly less vulnerable in terms of security … all
        > 3 should not hurt, or what would you say?
        >
        > (2) “locale -a” should list ONLY locales, which you want to use. Install fonts
        > for ANY of the listed locales.
        >
        > Documentation:
        > man locale-gen locale.gen
        > :h xfontset
        >
        > --
        > Regards
        > Roland Eggner

        hi roland,

        thanks. that sounds like a good plan but there doesn't seem to be a system-supported
        way to uninstall locales from macosx. /etc/locale.gen etc. don't exist.

        however, there is a program on sourceforge called monolingual that should do the trick.
        it uninstalls language localisations but i don't like that it permanently deletes them
        with no option to restore them if you change your mind later. i'll think about it.

        cheers,
        raf

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • raf
        ... monolingual doesn t work on macosx-10.6.8. it requires 10.7+ so that s not an option. i guess i ll have to keep my little patch to disable E250 messages in
        Message 3 of 8 , Apr 29, 2013
          raf wrote:

          > Roland Eggner wrote:
          >
          > > Maybe your problem is caused by a discrepancy between locale configuration and
          > > installed fonts.
          > >
          > > Suggestion (should work on Gentoo Linux, please tune to your macosx system):
          > >
          > > (1) Uninstall locales, which you do not use, e.g.
          > > su vim /etc/locale.gen
          > > :v/\v^(#|en_(AU|NZ|US)| … )/s/^/# /
          > > :wq
          > > su /usr/sbin/locale-gen
          > > To take effect your GUI (X-server?) probably needs to be restarted.
          > > Theoretically your system should become slightly faster, consume slightly less
          > > disk space, and become slightly less vulnerable in terms of security … all
          > > 3 should not hurt, or what would you say?
          > >
          > > (2) “locale -a” should list ONLY locales, which you want to use. Install fonts
          > > for ANY of the listed locales.
          > >
          > > Documentation:
          > > man locale-gen locale.gen
          > > :h xfontset
          > >
          > > --
          > > Regards
          > > Roland Eggner
          >
          > hi roland,
          >
          > thanks. that sounds like a good plan but there doesn't seem to be a system-supported
          > way to uninstall locales from macosx. /etc/locale.gen etc. don't exist.
          >
          > however, there is a program on sourceforge called monolingual that should do the trick.
          > it uninstalls language localisations but i don't like that it permanently deletes them
          > with no option to restore them if you change your mind later. i'll think about it.

          monolingual doesn't work on macosx-10.6.8. it requires 10.7+ so that's not an option.
          i guess i'll have to keep my little patch to disable E250 messages in place.

          cheers,
          raf

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • raf
          ... there s an older version that does work on macosx-10.6.8. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply
          Message 4 of 8 , Apr 29, 2013
            raf wrote:

            > monolingual doesn't work on macosx-10.6.8. it requires 10.7+ so that's not an option.
            > i guess i'll have to keep my little patch to disable E250 messages in place.

            there's an older version that does work on macosx-10.6.8.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Max Kirillov
            Hi. I also experienced this problem for some time. I dicovered there was some editing mistakes in recent which caused showing this message even if fontset is
            Message 5 of 8 , Apr 29, 2013
              Hi. I also experienced this problem for some time.

              I dicovered there was some editing mistakes in recent which
              caused showing this message even if fontset is not used.

              Patch which corrects the mistake is after the signature. It
              soppressed the message for me.

              The root cause is still unclear to me. Why would
              XCreateFontSet report anything about KOI8-R or GB2312.1980-0
              if I have utf-8 locale? I don't also have others installed.
              I am not familiar to libx11 to answer this question.

              Thanks,
              --
              Max

              patch:
              -------------------------
              diff -r 26fdbbc9927a -r 63f18a56fb20 src/syntax.c
              --- a/src/syntax.c Sun Apr 28 08:25:08 2013 +0300
              +++ b/src/syntax.c Mon Apr 29 06:23:22 2013 +0300
              @@ -8082,6 +8082,7 @@
              || do_tooltip
              # endif
              )
              + {
              if (free_font)
              gui_mch_free_fontset(HL_TABLE()[idx].sg_fontset);
              HL_TABLE()[idx].sg_fontset = fontset_name2handle(arg, 0
              @@ -8092,6 +8093,7 @@
              || do_tooltip
              # endif
              );
              + }
              if (HL_TABLE()[idx].sg_fontset != NOFONTSET)
              {
              /* If it worked and it's the Normal group, use it as the normal
              -------------------------

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Max Kirillov
              Hi. I also experienced this problem for some time. I dicovered there was some editing mistakes in recent which caused showing this message even if fontset is
              Message 6 of 8 , Apr 29, 2013
                Hi. I also experienced this problem for some time.

                I dicovered there was some editing mistakes in recent which
                caused showing this message even if fontset is not used.

                Patch which corrects the mistake is after the signature. It
                soppressed the message for me.

                The root cause is still unclear to me. Why would
                XCreateFontSet report anything about KOI8-R or GB2312.1980-0
                if I have utf-8 locale? I don't also have others installed.
                I am not familiar to libx11 to answer this question.

                Thanks,
                --
                Max

                patch:
                -------------------------
                diff -r 26fdbbc9927a -r 63f18a56fb20 src/syntax.c
                --- a/src/syntax.c Sun Apr 28 08:25:08 2013 +0300
                +++ b/src/syntax.c Mon Apr 29 06:23:22 2013 +0300
                @@ -8082,6 +8082,7 @@
                || do_tooltip
                # endif
                )
                + {
                if (free_font)
                gui_mch_free_fontset(HL_TABLE()[idx].sg_fontset);
                HL_TABLE()[idx].sg_fontset = fontset_name2handle(arg, 0
                @@ -8092,6 +8093,7 @@
                || do_tooltip
                # endif
                );
                + }
                if (HL_TABLE()[idx].sg_fontset != NOFONTSET)
                {
                /* If it worked and it's the Normal group, use it as the normal
                -------------------------

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Bram Moolenaar
                ... Thanks for the patch! -- hundred-and-one symptoms of being an internet addict: 261. You find diskettes in your pockets when doing laundry. /// Bram
                Message 7 of 8 , May 1, 2013
                  Max Kirillov wrote:

                  > Hi. I also experienced this problem for some time.
                  >
                  > I dicovered there was some editing mistakes in recent which
                  > caused showing this message even if fontset is not used.
                  >
                  > Patch which corrects the mistake is after the signature. It
                  > soppressed the message for me.
                  >
                  > The root cause is still unclear to me. Why would
                  > XCreateFontSet report anything about KOI8-R or GB2312.1980-0
                  > if I have utf-8 locale? I don't also have others installed.
                  > I am not familiar to libx11 to answer this question.

                  Thanks for the patch!

                  --
                  hundred-and-one symptoms of being an internet addict:
                  261. You find diskettes in your pockets when doing laundry.

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.